summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2012-06-02 19:27:41 +0000
committerMagnus Granberg <zorry@gentoo.org>2012-06-02 19:27:41 +0000
commit6322227c4c3dc1c15e4be1af4d29c43b6779ce9a (patch)
tree1b2aaec6a9c4aba464376507e725e2268c4d257c /sys-devel/gcc/gcc-4.7.0.ebuild
parentdev-db/firebird client: Not fit for production (bug 404403, comment #5) (diff)
downloadgentoo-2-6322227c4c3dc1c15e4be1af4d29c43b6779ce9a.tar.gz
gentoo-2-6322227c4c3dc1c15e4be1af4d29c43b6779ce9a.tar.bz2
gentoo-2-6322227c4c3dc1c15e4be1af4d29c43b6779ce9a.zip
Add ssp support for uclibc >= 0.9.33 on gcc 4.6.3 and 4.7.0
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/gcc/gcc-4.7.0.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.7.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-devel/gcc/gcc-4.7.0.ebuild b/sys-devel/gcc/gcc-4.7.0.ebuild
index 18a672cc39ca..6618fd6d49c1 100644
--- a/sys-devel/gcc/gcc-4.7.0.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.0.ebuild,v 1.2 2012/05/25 17:27:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.0.ebuild,v 1.3 2012/06/02 19:27:41 zorry Exp $
PATCH_VER="1.1"
UCLIBC_VER="1.0"
@@ -14,7 +14,8 @@ PIE_GLIBC_STABLE="x86 amd64 ppc ppc64 arm ia64"
PIE_UCLIBC_STABLE="x86 arm amd64 ppc ppc64"
SSP_STABLE="amd64 x86 ppc ppc64 arm"
# uclibc need tls and nptl support for SSP support
-SSP_UCLIBC_STABLE=""
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 ppc ppc64 arm"
#end Hardened stuff
inherit toolchain