summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2014-01-19 01:51:34 +0000
committerRyan Hill <dirtyepic@gentoo.org>2014-01-19 01:51:34 +0000
commit705440ecb874d70066e9659ccc4c3217ca11a0e0 (patch)
tree11cc0d6ba0a8b28aa0fc29dfffe06cd195539899 /sys-devel/gcc/gcc-4.7.0.ebuild
parentAdd cross-compiling support #486680. (diff)
downloadgentoo-2-705440ecb874d70066e9659ccc4c3217ca11a0e0.tar.gz
gentoo-2-705440ecb874d70066e9659ccc4c3217ca11a0e0.tar.bz2
gentoo-2-705440ecb874d70066e9659ccc4c3217ca11a0e0.zip
Bump all to EAPI 2.
Signed-off-by: Ryan Hill <dirtyepic@gentoo.org> (Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'sys-devel/gcc/gcc-4.7.0.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.7.0.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-devel/gcc/gcc-4.7.0.ebuild b/sys-devel/gcc/gcc-4.7.0.ebuild
index 19e5e3e4f63d..4a7a2b27d5ca 100644
--- a/sys-devel/gcc/gcc-4.7.0.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.0.ebuild,v 1.11 2013/12/23 21:36:09 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.0.ebuild,v 1.12 2014/01/19 01:51:34 dirtyepic Exp $
+
+EAPI="2"
PATCH_VER="1.2"
UCLIBC_VER="1.0"
@@ -18,7 +20,7 @@ SSP_STABLE="amd64 x86 ppc ppc64 arm"
SSP_UCLIBC_STABLE="x86 amd64 ppc ppc64 arm"
#end Hardened stuff
-inherit toolchain
+inherit eutils toolchain
DESCRIPTION="The GNU Compiler Collection"
@@ -34,7 +36,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi
-src_unpack() {
+src_prepare() {
if has_version '<sys-libs/glibc-2.12' ; then
ewarn "Your host glibc is too old; disabling automatic fortify."
ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
@@ -46,7 +48,7 @@ src_unpack() {
EPATCH_EXCLUDE+=" 90_all_gcc-4.7-x32.patch"
fi
- toolchain_src_unpack
+ toolchain_src_prepare
use vanilla && return 0