summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-17 06:41:31 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-17 06:41:31 +0000
commit8b52aa536d9726f53b54ddc843c25ea7fa7125bd (patch)
treeca5d502594f7083591cfcd65c633fde084a8948a /sys-devel/gcc/gcc-4.7.0.ebuild
parentdrop x32 support for gcc-4.7 #543578 (diff)
downloadgentoo-2-8b52aa536d9726f53b54ddc843c25ea7fa7125bd.tar.gz
gentoo-2-8b52aa536d9726f53b54ddc843c25ea7fa7125bd.tar.bz2
gentoo-2-8b52aa536d9726f53b54ddc843c25ea7fa7125bd.zip
Mask out the x32 patches all the time #543578.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/gcc/gcc-4.7.0.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.7.0.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-devel/gcc/gcc-4.7.0.ebuild b/sys-devel/gcc/gcc-4.7.0.ebuild
index e54f65345425..9d92d9d93a7b 100644
--- a/sys-devel/gcc/gcc-4.7.0.ebuild
+++ b/sys-devel/gcc/gcc-4.7.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.0.ebuild,v 1.14 2014/10/24 00:23:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.0.ebuild,v 1.15 2015/03/17 06:41:31 vapier Exp $
EAPI="2"
@@ -40,10 +40,8 @@ src_prepare() {
EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
fi
- # drop the x32 stuff once 4.7 goes stable
- if [[ ${CTARGET} != x86_64* ]] || ! has x32 $(get_all_abis TARGET) ; then
- EPATCH_EXCLUDE+=" 90_all_gcc-4.7-x32.patch"
- fi
+ # drop the x32 stuff in the next patchset #543578
+ EPATCH_EXCLUDE+=" 90_all_gcc-4.7-x32.patch"
toolchain_src_prepare