summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-02-25 04:42:07 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-02-25 04:42:07 +0000
commit5b49cebe6404dabd176e6174f331aa57295456f9 (patch)
treee7e260070a3cd8c104cbc0bd0ff4f971d6227ec3 /sys-devel/gcc/gcc-4.7.2-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-5b49cebe6404dabd176e6174f331aa57295456f9.tar.gz
gentoo-2-5b49cebe6404dabd176e6174f331aa57295456f9.tar.bz2
gentoo-2-5b49cebe6404dabd176e6174f331aa57295456f9.zip
4.7.2 p1.4: Fixes bug #451680 (bootstrap comparison failure on alpha),
bug #421305 and #417271 (libitm build breakage), and PR55940 (incorrect code building virtualbox kernel modules). Revbump for unmasking. (Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'sys-devel/gcc/gcc-4.7.2-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.7.2-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.7.2-r1.ebuild b/sys-devel/gcc/gcc-4.7.2-r1.ebuild
new file mode 100644
index 000000000000..f3f8621f113e
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.7.2-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.2-r1.ebuild,v 1.1 2013/02/25 04:42:07 dirtyepic Exp $
+
+PATCH_VER="1.4"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.5.5"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 ppc ppc64"
+SSP_STABLE="amd64 x86 ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 ppc ppc64 arm"
+#end Hardened stuff
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection"
+
+LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
+~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.18"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_unpack() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ # drop the x32 stuff once 4.7 goes stable
+ if [[ ${CTARGET} != x86_64* ]] || ! has x32 $(get_all_abis TARGET) ; then
+ EPATCH_EXCLUDE+=" 90_all_gcc-4.7-x32.patch"
+ fi
+
+ toolchain_src_unpack
+
+ use vanilla && return 0
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+}
+
+pkg_setup() {
+ toolchain_pkg_setup
+
+ ewarn
+ ewarn "LTO support is still experimental and unstable."
+ ewarn "Any bugs resulting from the use of LTO will not be fixed."
+ ewarn
+}