summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Gabert <pappy@gentoo.org>2004-07-22 13:11:32 +0000
committerAlexander Gabert <pappy@gentoo.org>2004-07-22 13:11:32 +0000
commit410b095b4477ad8743bd5abb2277c8adbfac9085 (patch)
treee4a8213bba91c2c1762a79e96cc2d905fc2c3a54 /sys-devel/gcc
parentmark x11-plugins/wmfortune, version 0.241, stable for x86. (Manifest recommit) (diff)
downloadgentoo-2-410b095b4477ad8743bd5abb2277c8adbfac9085.tar.gz
gentoo-2-410b095b4477ad8743bd5abb2277c8adbfac9085.tar.bz2
gentoo-2-410b095b4477ad8743bd5abb2277c8adbfac9085.zip
added hardened changes to gcc-3.3.4-r1, leaving keywords untouched
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/gcc-3.3.4-r1.ebuild14
2 files changed, 10 insertions, 10 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 97b6a0928cec..530793e36a2c 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.290 2004/07/22 12:33:26 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.291 2004/07/22 13:11:14 pappy Exp $
+
+ 22 Jul 2004; Alexander Gabert <pappy@gentoo.org> gcc-3.3.4-r1.ebuild:
+ fire up hardened changes for sparc and hppa, though still leaving keyworded on
+ sparc
22 Jul 2004; Alexander Gabert <pappy@gentoo.org> gcc-3.4.1.ebuild:
added hppa logic and note for glibc
diff --git a/sys-devel/gcc/gcc-3.3.4-r1.ebuild b/sys-devel/gcc/gcc-3.3.4-r1.ebuild
index 4f813714ab4f..86c7a16a1591 100644
--- a/sys-devel/gcc/gcc-3.3.4-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r1.ebuild,v 1.4 2004/07/20 18:33:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r1.ebuild,v 1.5 2004/07/22 13:11:32 pappy Exp $
inherit eutils flag-o-matic libtool gnuconfig
@@ -94,8 +94,9 @@ HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
## SpanKY says hppa is a no go with any 3.3.x
-# desire ~sparc
-KEYWORDS="-hppa ~x86 ~amd64 ~mips ~arm"
+
+KEYWORDS="-hppa ~x86 ~amd64 ~mips ~arm" # weeve: mark "~sparc" as you wish
+
IUSE="static nls bootstrap build X multilib gcj f77 objc pic hardened uclibc debug"
# Ok, this is a hairy one again, but lets assume that we
@@ -382,9 +383,7 @@ src_unpack() {
[ -n "${PIE_VER}" ] && release_version="${release_version}, pie-${PIE_VER}"
- # if use hardened && ( use x86 || use sparc || use amd64 )
- # the use hardened && use sparc part breaks glibc compiling - pappy
- if use hardened && ( use x86 || use amd64 )
+ if use hardened && ( use x86 || use amd64 || use sparc || use hppa )
then
einfo "Updating gcc to use automatic PIE + SSP building ..."
sed -e 's|^ALL_CFLAGS = |ALL_CFLAGS = -DEFAULT_PIE_SSP |' \
@@ -400,9 +399,6 @@ src_unpack() {
version_patch ${FILESDIR}/3.3.4/gcc334-gentoo-branding.patch \
"${BRANCH_UPDATE} (${release_version})" || die "Failed Branding"
- # TODO: on arches where we lack a Scrt1.o (like parisc) we still need unpack, compile and install logic
- # TODO: for the crt1Snocsu.o provided by a custom gcc-pie-ssp.tgz which can also be included in SRC_URI
-
# Misdesign in libstdc++ (Redhat)
cp -a ${S}/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h