summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-10-08 22:05:08 +0000
committerMike Frysinger <vapier@gentoo.org>2010-10-08 22:05:08 +0000
commit5b50e3ed8cbeac70e1f5a3bab334218227c17e1c (patch)
tree17a3d796a6508f0e9ceafd795186d4cc0107a4f1 /sys-devel/gnuconfig
parentStabilize for everyone. (diff)
downloadgentoo-2-5b50e3ed8cbeac70e1f5a3bab334218227c17e1c.tar.gz
gentoo-2-5b50e3ed8cbeac70e1f5a3bab334218227c17e1c.tar.bz2
gentoo-2-5b50e3ed8cbeac70e1f5a3bab334218227c17e1c.zip
Version bump.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/gnuconfig')
-rw-r--r--sys-devel/gnuconfig/ChangeLog8
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20100924.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-devel/gnuconfig/ChangeLog b/sys-devel/gnuconfig/ChangeLog
index b907b7c79ea5..34e002cbd716 100644
--- a/sys-devel/gnuconfig/ChangeLog
+++ b/sys-devel/gnuconfig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gnuconfig
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.50 2010/10/08 22:04:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.51 2010/10/08 22:05:08 vapier Exp $
+
+*gnuconfig-20100924 (08 Oct 2010)
+
+ 08 Oct 2010; Mike Frysinger <vapier@gentoo.org>
+ +gnuconfig-20100924.ebuild:
+ Version bump.
08 Oct 2010; Mike Frysinger <vapier@gentoo.org> gnuconfig-20100403.ebuild:
Stabilize for everyone.
diff --git a/sys-devel/gnuconfig/gnuconfig-20100924.ebuild b/sys-devel/gnuconfig/gnuconfig-20100924.ebuild
new file mode 100644
index 000000000000..4db3a724cf7e
--- /dev/null
+++ b/sys-devel/gnuconfig/gnuconfig-20100924.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-20100924.ebuild,v 1.1 2010/10/08 22:05:08 vapier Exp $
+
+inherit eutils
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.gnu.org/config.git"
+ inherit git
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Updated config.sub and config.guess file from GNU"
+HOMEPAGE="http://savannah.gnu.org/projects/config"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}
+
+maint_pkg_create() {
+ cd "${S}"
+
+ local ver=$(head -n 1 ChangeLog | awk '{print $1}' | sed -e 's:-::g')
+ [[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
+
+ cp "${FILESDIR}"/${PV}/*.patch . || die
+
+ local tar="${T}/gnuconfig-${ver}.tar.bz2"
+ tar -jcf ${tar} . || die "creating tar failed"
+ einfo "Packaged tar now available:"
+ einfo "$(du -b ${tar})"
+}
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git_src_unpack
+ maint_pkg_create
+ else
+ unpack ${A}
+ fi
+ epatch "${WORKDIR}"/*.patch
+ use elibc_uclibc && sed -i 's:linux-gnu:linux-uclibc:' testsuite/config-guess.data #180637
+}
+
+src_compile() { :;}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins config.{sub,guess} || die
+ fperms +x /usr/share/${PN}/config.{sub,guess}
+ dodoc ChangeLog
+}