summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-09-05 00:28:35 +0000
committerMike Frysinger <vapier@gentoo.org>2009-09-05 00:28:35 +0000
commitae69cccadb7e1b5a8a013c9815b4f8498c971696 (patch)
tree2bf3a963d14b952c22a766a92ed7164a0b5dc775 /sys-devel/gnuconfig
parentMarking fvwm-2.5.27 ppc64 for bug 266937 (diff)
downloadgentoo-2-ae69cccadb7e1b5a8a013c9815b4f8498c971696.tar.gz
gentoo-2-ae69cccadb7e1b5a8a013c9815b4f8498c971696.tar.bz2
gentoo-2-ae69cccadb7e1b5a8a013c9815b4f8498c971696.zip
Version bump.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/gnuconfig')
-rw-r--r--sys-devel/gnuconfig/ChangeLog10
-rw-r--r--sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch65
-rw-r--r--sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch14
-rw-r--r--sys-devel/gnuconfig/files/99999999/disable-broken-tests.patch15
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20090819.ebuild55
5 files changed, 115 insertions, 44 deletions
diff --git a/sys-devel/gnuconfig/ChangeLog b/sys-devel/gnuconfig/ChangeLog
index 5fb66ea3e5d0..7bb14277ae59 100644
--- a/sys-devel/gnuconfig/ChangeLog
+++ b/sys-devel/gnuconfig/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/gnuconfig
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.38 2009/03/09 21:32:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.39 2009/09/05 00:28:35 vapier Exp $
+
+*gnuconfig-20090819 (05 Sep 2009)
+
+ 05 Sep 2009; Mike Frysinger <vapier@gentoo.org>
+ files/99999999/0001-add-uClibc-guess-support.patch,
+ files/99999999/0002-add-ps2-targets-to-config.sub.patch,
+ +files/99999999/disable-broken-tests.patch, +gnuconfig-20090819.ebuild:
+ Version bump.
*gnuconfig-20090203 (09 Mar 2009)
diff --git a/sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch b/sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch
index add1f6dc265d..c3126d081a69 100644
--- a/sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch
+++ b/sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch
@@ -1,21 +1,22 @@
-From eeb92c3a61926ee07325efb48f1d72bad0e9c751 Mon Sep 17 00:00:00 2001
+From d5a10be0ad318f44d81c147033359e487e918ffd Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Thu, 9 Oct 2008 15:51:09 -0400
-Subject: [PATCH] add uClibc guess support
+Subject: [PATCH 1/2] add uClibc guess support
---
- config.guess | 77 ++++++++++++++++++++++++++++++++++++----------------------
- 1 files changed, 48 insertions(+), 29 deletions(-)
+ config.guess | 77 +++++++++++++++++++++++++++++++++++++---------------------
+ 1 files changed, 49 insertions(+), 28 deletions(-)
diff --git a/config.guess b/config.guess
-index f0f0d36..202f698 100755
+index bb0b03e..12734a7 100755
--- a/config.guess
+++ b/config.guess
-@@ -139,6 +139,23 @@ UNAME_RELEASE=`(uname -r) 2>/dev/null` || UNAME_RELEASE=unknown
+@@ -139,6 +139,25 @@ UNAME_RELEASE=`(uname -r) 2>/dev/null` || UNAME_RELEASE=unknown
UNAME_SYSTEM=`(uname -s) 2>/dev/null` || UNAME_SYSTEM=unknown
UNAME_VERSION=`(uname -v) 2>/dev/null` || UNAME_VERSION=unknown
-+if [ "${UNAME_SYSTEM}" = "Linux" ] ; then
++case "${UNAME_SYSTEM}" in
++Linux|GNU/*)
+ eval $set_cc_for_build
+ cat << EOF > $dummy.c
+ #include <features.h>
@@ -30,12 +31,22 @@ index f0f0d36..202f698 100755
+ #endif
+EOF
+ eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep LIBC= | sed -e 's: ::g'`
-+fi
++ ;;
++esac
+
# Note: order is significant - the case branches are not exclusive.
case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
-@@ -840,31 +857,31 @@ EOF
+@@ -849,7 +868,7 @@ EOF
+ exit ;;
+ *:GNU/*:*:*)
+ # other systems with GNU libc and userland
+- echo ${UNAME_MACHINE}-unknown-`echo ${UNAME_SYSTEM} | sed 's,^[^/]*/,,' | tr '[A-Z]' '[a-z]'``echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`-gnu
++ echo ${UNAME_MACHINE}-unknown-`echo ${UNAME_SYSTEM} | sed 's,^[^/]*/,,' | tr '[A-Z]' '[a-z]'``echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`-${LIBC}
+ exit ;;
+ i*86:Minix:*:*)
+ echo ${UNAME_MACHINE}-pc-minix
+@@ -859,31 +878,31 @@ EOF
if echo __ARM_EABI__ | $CC_FOR_BUILD -E - 2>/dev/null \
| grep -q __ARM_EABI__
then
@@ -74,18 +85,9 @@ index f0f0d36..202f698 100755
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
- mips:Linux:*:*)
- eval $set_cc_for_build
-@@ -887,7 +904,7 @@ EOF
- s: ::g
- p
- }'`"
-- test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
-+ test x"${CPU}" != x && { echo "${CPU}-unknown-linux-${LIBC}"; exit; }
- ;;
- mips64:Linux:*:*)
+ mips:Linux:*:* | mips64:Linux:*:*)
eval $set_cc_for_build
-@@ -910,16 +927,16 @@ EOF
+@@ -906,16 +925,16 @@ EOF
s: ::g
p
}'`"
@@ -106,18 +108,19 @@ index f0f0d36..202f698 100755
exit ;;
alpha:Linux:*:*)
case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
-@@ -932,8 +949,8 @@ EOF
+@@ -928,43 +947,43 @@ EOF
EV68*) UNAME_MACHINE=alphaev68 ;;
esac
- objdump --private-headers /bin/sh | grep ld.so.1 >/dev/null
+ objdump --private-headers /bin/sh | grep -q ld.so.1
- if test "$?" = 0 ; then LIBC="libc1" ; else LIBC="" ; fi
- echo ${UNAME_MACHINE}-unknown-linux-gnu${LIBC}
+ if test "$?" = 0 ; then LIBC="gnulibc1" ; fi
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
padre:Linux:*:*)
- echo sparc-unknown-linux-gnu
-@@ -941,34 +958,34 @@ EOF
+- echo sparc-unknown-linux-gnu
++ echo sparc-unknown-linux-${LIBC}
+ exit ;;
parisc:Linux:*:* | hppa:Linux:*:*)
# Look for CPU level
case `grep '^cpu[^a-z]*:' /proc/cpuinfo 2>/dev/null | cut -d' ' -f2` in
@@ -162,23 +165,13 @@ index f0f0d36..202f698 100755
exit ;;
i*86:Linux:*:*)
# The BFD linker knows what the default object file format is, so
-@@ -983,17 +1000,19 @@ EOF
+@@ -979,9 +998,11 @@ EOF
p'`
case "$ld_supported_targets" in
elf32-i386)
- TENTATIVE="${UNAME_MACHINE}-pc-linux-gnu"
+ TENTATIVE="${UNAME_MACHINE}-pc-linux-${LIBC}"
;;
- a.out-i386-linux)
-- echo "${UNAME_MACHINE}-pc-linux-gnuaout"
-+ echo "${UNAME_MACHINE}-pc-linux-${LIBC}aout"
- exit ;;
- "")
- # Either a pre-BFD a.out linker (linux-gnuoldld) or
- # one that does not give us useful --help.
-- echo "${UNAME_MACHINE}-pc-linux-gnuoldld"
-+ echo "${UNAME_MACHINE}-pc-linux-${LIBC}oldld"
- exit ;;
esac
+ # This should get integrated into the C code below, but now we hack
+ if [ "$LIBC" != "gnu" ] ; then echo "$TENTATIVE" && exit 0 ; fi
@@ -186,5 +179,5 @@ index f0f0d36..202f698 100755
eval $set_cc_for_build
sed 's/^ //' << EOF >$dummy.c
--
-1.6.0.1
+1.6.4
diff --git a/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch b/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch
index cf32d046ee33..ad2d89e9b123 100644
--- a/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch
+++ b/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch
@@ -1,17 +1,17 @@
-From 52054bdf40780dcc9ae252f544a9152c3a32a691 Mon Sep 17 00:00:00 2001
+From 96cb2b8095c7ac9d211f0abc6704b769344a8afa Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Thu, 9 Oct 2008 15:51:35 -0400
-Subject: [PATCH] add ps2 targets to config.sub
+Subject: [PATCH 2/2] add ps2 targets to config.sub
---
config.sub | 22 ++++++++++++++++++++--
1 files changed, 20 insertions(+), 2 deletions(-)
diff --git a/config.sub b/config.sub
-index 053e738..a31b87d 100755
+index 8ca084b..3243784 100755
--- a/config.sub
+++ b/config.sub
-@@ -244,7 +244,7 @@ case $basic_machine in
+@@ -251,7 +251,7 @@ case $basic_machine in
| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
| bfin \
| c4x | clipper \
@@ -20,7 +20,7 @@ index 053e738..a31b87d 100755
| fido | fr30 | frv \
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
| i370 | i860 | i960 | ia64 \
-@@ -726,6 +726,24 @@ case $basic_machine in
+@@ -747,6 +747,24 @@ case $basic_machine in
basic_machine=m68k-atari
os=-mint
;;
@@ -45,7 +45,7 @@ index 053e738..a31b87d 100755
mips3*-*)
basic_machine=`echo $basic_machine | sed -e 's/mips3/mips64/'`
;;
-@@ -1274,7 +1292,7 @@ case $os in
+@@ -1296,7 +1314,7 @@ case $os in
| -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
| -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
| -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
@@ -55,5 +55,5 @@ index 053e738..a31b87d 100755
;;
-qnx*)
--
-1.6.0.1
+1.6.4
diff --git a/sys-devel/gnuconfig/files/99999999/disable-broken-tests.patch b/sys-devel/gnuconfig/files/99999999/disable-broken-tests.patch
new file mode 100644
index 000000000000..4b707318c77d
--- /dev/null
+++ b/sys-devel/gnuconfig/files/99999999/disable-broken-tests.patch
@@ -0,0 +1,15 @@
+the test relies on `uname -m`, so it'll fail on non-i386 systems
+
+diff --git a/testsuite/config-guess.data b/testsuite/config-guess.data
+index 7f6f214..189b067 100644
+--- a/testsuite/config-guess.data
++++ b/testsuite/config-guess.data
+@@ -32,8 +32,6 @@ xtensa 2.6.15 Linux ignored xtensa-unknown-linux-gnu
+ x86_64 1.0 MINGW ignored x86_64-pc-mingw32
+ i386 1.0 MINGW ignored i386-pc-mingw32
+ SX-8R 1.0 SUPER-UX ignored sx8r-nec-superux1.0
+-i86xen 5.6 SunOS ignored i386-pc-solaris2.6
+-i86pc 5.6 SunOS ignored i386-pc-solaris2.6
+ IA64 6.0 Interix ignored ia64-unknown-interix6.0
+ BePC 1.0 Haiku ignored i586-pc-haiku
+ padre 2.6.15 Linux ignored sparc-unknown-linux-gnu
diff --git a/sys-devel/gnuconfig/gnuconfig-20090819.ebuild b/sys-devel/gnuconfig/gnuconfig-20090819.ebuild
new file mode 100644
index 000000000000..0cd36cdd4a43
--- /dev/null
+++ b/sys-devel/gnuconfig/gnuconfig-20090819.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-20090819.ebuild,v 1.1 2009/09/05 00:28:35 vapier Exp $
+
+inherit eutils
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.gnu.org/config.git"
+ inherit git
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Updated config.sub and config.guess file from GNU"
+HOMEPAGE="http://savannah.gnu.org/projects/config"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}
+
+maint_pkg_create() {
+ cd "${S}"
+
+ local ver=$(head -n 1 ChangeLog | awk '{print $1}' | sed -e 's:-::g')
+ [[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
+
+ cp "${FILESDIR}"/${PV}/*.patch . || die
+
+ local tar="${T}/gnuconfig-${ver}.tar.bz2"
+ tar -jcf ${tar} . || die "creating tar failed"
+ einfo "Packaged tar now available:"
+ einfo "$(du -b ${tar})"
+}
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git_src_unpack
+ maint_pkg_create
+ else
+ unpack ${A}
+ fi
+ epatch "${WORKDIR}"/*.patch
+ use elibc_uclibc && sed -i 's:linux-gnu:linux-uclibc:' testsuite/config-guess.data #180637
+}
+
+src_compile() { :;}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins config.{sub,guess} || die
+ fperms +x /usr/share/${PN}/config.{sub,guess}
+ dodoc ChangeLog
+}