summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-10-09 19:55:00 +0000
committerMike Frysinger <vapier@gentoo.org>2008-10-09 19:55:00 +0000
commitded3cc35aed946f8d01976666d374a679a0cdd3b (patch)
treeabc6cac4991bf5351c2615f8dc10c124115a7ccb /sys-devel/gnuconfig
parentLast rites: dev-java/gnu-jaxp (diff)
downloadgentoo-2-ded3cc35aed946f8d01976666d374a679a0cdd3b.tar.gz
gentoo-2-ded3cc35aed946f8d01976666d374a679a0cdd3b.tar.bz2
gentoo-2-ded3cc35aed946f8d01976666d374a679a0cdd3b.zip
Update patches to latest git #240420 by Jan Van Uytven.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-devel/gnuconfig')
-rw-r--r--sys-devel/gnuconfig/ChangeLog10
-rw-r--r--sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch (renamed from sys-devel/gnuconfig/files/99999999/config.guess.uclibc.patch)75
-rw-r--r--sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch (renamed from sys-devel/gnuconfig/files/99999999/config.sub.ps2.patch)27
-rw-r--r--sys-devel/gnuconfig/files/99999999/0003-add-more-superh-targets-to-config.sub.patch34
-rw-r--r--sys-devel/gnuconfig/files/99999999/config.sub.sh.patch39
5 files changed, 119 insertions, 66 deletions
diff --git a/sys-devel/gnuconfig/ChangeLog b/sys-devel/gnuconfig/ChangeLog
index e76af36b8ad2..1709e4b502d6 100644
--- a/sys-devel/gnuconfig/ChangeLog
+++ b/sys-devel/gnuconfig/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/gnuconfig
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.33 2008/05/28 19:43:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.34 2008/10/09 19:55:00 vapier Exp $
+
+ 09 Oct 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/99999999/0001-add-uClibc-guess-support.patch,
+ +files/99999999/0002-add-ps2-targets-to-config.sub.patch,
+ +files/99999999/0003-add-more-superh-targets-to-config.sub.patch,
+ -files/99999999/config.guess.uclibc.patch,
+ -files/99999999/config.sub.ps2.patch, -files/99999999/config.sub.sh.patch:
+ Update patches to latest git #240420 by Jan Van Uytven.
28 May 2008; Mike Frysinger <vapier@gentoo.org> gnuconfig-20080123.ebuild:
Stabilize all relevant arches.
diff --git a/sys-devel/gnuconfig/files/99999999/config.guess.uclibc.patch b/sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch
index 98e3d34c766f..add1f6dc265d 100644
--- a/sys-devel/gnuconfig/files/99999999/config.guess.uclibc.patch
+++ b/sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch
@@ -1,6 +1,19 @@
---- config.guess
-+++ config.guess
-@@ -141,2 +141,19 @@
+From eeb92c3a61926ee07325efb48f1d72bad0e9c751 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 9 Oct 2008 15:51:09 -0400
+Subject: [PATCH] add uClibc guess support
+
+---
+ config.guess | 77 ++++++++++++++++++++++++++++++++++++----------------------
+ 1 files changed, 48 insertions(+), 29 deletions(-)
+
+diff --git a/config.guess b/config.guess
+index f0f0d36..202f698 100755
+--- a/config.guess
++++ b/config.guess
+@@ -139,6 +139,23 @@ UNAME_RELEASE=`(uname -r) 2>/dev/null` || UNAME_RELEASE=unknown
+ UNAME_SYSTEM=`(uname -s) 2>/dev/null` || UNAME_SYSTEM=unknown
+ UNAME_VERSION=`(uname -v) 2>/dev/null` || UNAME_VERSION=unknown
+if [ "${UNAME_SYSTEM}" = "Linux" ] ; then
+ eval $set_cc_for_build
@@ -20,7 +33,11 @@
+fi
+
# Note: order is significant - the case branches are not exclusive.
-@@ -842,5 +859,5 @@
+
+ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
+@@ -840,31 +857,31 @@ EOF
+ if echo __ARM_EABI__ | $CC_FOR_BUILD -E - 2>/dev/null \
+ | grep -q __ARM_EABI__
then
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
@@ -28,7 +45,7 @@
- echo ${UNAME_MACHINE}-unknown-linux-gnueabi
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}eabi
fi
-@@ -848,21 +865,21 @@
+ exit ;;
avr32*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
@@ -57,12 +74,20 @@
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
-@@ -889,3 +906,3 @@
+ mips:Linux:*:*)
+ eval $set_cc_for_build
+@@ -887,7 +904,7 @@ EOF
+ s: ::g
+ p
}'`"
- test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
+ test x"${CPU}" != x && { echo "${CPU}-unknown-linux-${LIBC}"; exit; }
;;
-@@ -912,12 +929,12 @@
+ mips64:Linux:*:*)
+ eval $set_cc_for_build
+@@ -910,16 +927,16 @@ EOF
+ s: ::g
+ p
}'`"
- test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
+ test x"${CPU}" != x && { echo "${CPU}-unknown-linux-${LIBC}"; exit; }
@@ -79,14 +104,22 @@
- echo powerpc64-unknown-linux-gnu
+ echo powerpc64-unknown-linux-${LIBC}
exit ;;
-@@ -934,4 +951,4 @@
+ alpha:Linux:*:*)
+ case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
+@@ -932,8 +949,8 @@ EOF
+ EV68*) UNAME_MACHINE=alphaev68 ;;
+ esac
objdump --private-headers /bin/sh | grep ld.so.1 >/dev/null
- if test "$?" = 0 ; then LIBC="libc1" ; else LIBC="" ; fi
- echo ${UNAME_MACHINE}-unknown-linux-gnu${LIBC}
+ if test "$?" = 0 ; then LIBC="gnulibc1" ; fi
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
-@@ -940,5 +957,5 @@
+ padre:Linux:*:*)
+ echo sparc-unknown-linux-gnu
+@@ -941,34 +958,34 @@ EOF
+ parisc:Linux:*:* | hppa:Linux:*:*)
+ # Look for CPU level
case `grep '^cpu[^a-z]*:' /proc/cpuinfo 2>/dev/null | cut -d' ' -f2` in
- PA7*) echo hppa1.1-unknown-linux-gnu ;;
- PA8*) echo hppa2.0-unknown-linux-gnu ;;
@@ -95,12 +128,14 @@
+ PA8*) echo hppa2.0-unknown-linux-${LIBC} ;;
+ *) echo hppa-unknown-linux-${LIBC} ;;
esac
-@@ -946,3 +963,3 @@
+ exit ;;
parisc64:Linux:*:* | hppa64:Linux:*:*)
- echo hppa64-unknown-linux-gnu
+ echo hppa64-unknown-linux-${LIBC}
exit ;;
-@@ -952,18 +969,18 @@
+ s390:Linux:*:* | s390x:Linux:*:*)
+ echo ${UNAME_MACHINE}-ibm-linux
+ exit ;;
sh64*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
@@ -125,7 +160,11 @@
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
-@@ -982,9 +999,9 @@
+ i*86:Linux:*:*)
+ # The BFD linker knows what the default object file format is, so
+@@ -983,17 +1000,19 @@ EOF
+ p'`
+ case "$ld_supported_targets" in
elf32-i386)
- TENTATIVE="${UNAME_MACHINE}-pc-linux-gnu"
+ TENTATIVE="${UNAME_MACHINE}-pc-linux-${LIBC}"
@@ -134,11 +173,8 @@
- echo "${UNAME_MACHINE}-pc-linux-gnuaout"
+ echo "${UNAME_MACHINE}-pc-linux-${LIBC}aout"
exit ;;
- coff-i386)
-- echo "${UNAME_MACHINE}-pc-linux-gnucoff"
-+ echo "${UNAME_MACHINE}-pc-linux-${LIBC}coff"
- exit ;;
-@@ -993,5 +1010,7 @@
+ "")
+ # Either a pre-BFD a.out linker (linux-gnuoldld) or
# one that does not give us useful --help.
- echo "${UNAME_MACHINE}-pc-linux-gnuoldld"
+ echo "${UNAME_MACHINE}-pc-linux-${LIBC}oldld"
@@ -147,3 +183,8 @@
+ # This should get integrated into the C code below, but now we hack
+ if [ "$LIBC" != "gnu" ] ; then echo "$TENTATIVE" && exit 0 ; fi
# Determine whether the default compiler is a.out or elf
+ eval $set_cc_for_build
+ sed 's/^ //' << EOF >$dummy.c
+--
+1.6.0.1
+
diff --git a/sys-devel/gnuconfig/files/99999999/config.sub.ps2.patch b/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch
index 56b35801a372..cf32d046ee33 100644
--- a/sys-devel/gnuconfig/files/99999999/config.sub.ps2.patch
+++ b/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch
@@ -1,10 +1,16 @@
-Index: config.sub
-===================================================================
-RCS file: /cvsroot/config/config/config.sub,v
-retrieving revision 1.354
-diff -u -p -r1.354 config.sub
---- config.sub 17 Jan 2007 23:39:01 -0000 1.354
-+++ config.sub 8 Feb 2007 03:49:12 -0000
+From 52054bdf40780dcc9ae252f544a9152c3a32a691 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 9 Oct 2008 15:51:35 -0400
+Subject: [PATCH] add ps2 targets to config.sub
+
+---
+ config.sub | 22 ++++++++++++++++++++--
+ 1 files changed, 20 insertions(+), 2 deletions(-)
+
+diff --git a/config.sub b/config.sub
+index 053e738..a31b87d 100755
+--- a/config.sub
++++ b/config.sub
@@ -244,7 +244,7 @@ case $basic_machine in
| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
| bfin \
@@ -14,7 +20,7 @@ diff -u -p -r1.354 config.sub
| fido | fr30 | frv \
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
| i370 | i860 | i960 | ia64 \
-@@ -690,6 +690,24 @@ case $basic_machine in
+@@ -726,6 +726,24 @@ case $basic_machine in
basic_machine=m68k-atari
os=-mint
;;
@@ -39,7 +45,7 @@ diff -u -p -r1.354 config.sub
mips3*-*)
basic_machine=`echo $basic_machine | sed -e 's/mips3/mips64/'`
;;
-@@ -1222,7 +1240,7 @@ case $os in
+@@ -1274,7 +1292,7 @@ case $os in
| -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
| -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
| -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
@@ -48,3 +54,6 @@ diff -u -p -r1.354 config.sub
# Remember, each alternative MUST END IN *, to match a version number.
;;
-qnx*)
+--
+1.6.0.1
+
diff --git a/sys-devel/gnuconfig/files/99999999/0003-add-more-superh-targets-to-config.sub.patch b/sys-devel/gnuconfig/files/99999999/0003-add-more-superh-targets-to-config.sub.patch
new file mode 100644
index 000000000000..4b8ed906a7a0
--- /dev/null
+++ b/sys-devel/gnuconfig/files/99999999/0003-add-more-superh-targets-to-config.sub.patch
@@ -0,0 +1,34 @@
+From 1778a89105dbdbd11ffc7f44ead9996b7e32d5cf Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 9 Oct 2008 15:51:49 -0400
+Subject: [PATCH] add more superh targets to config.sub
+
+---
+ config.sub | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/config.sub b/config.sub
+index a31b87d..66f218c 100755
+--- a/config.sub
++++ b/config.sub
+@@ -279,7 +279,7 @@ case $basic_machine in
+ | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
+ | pyramid \
+ | score \
+- | sh | sh[1234] | sh[24]a | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
++ | sh | sh[1234] | sh[24]a | sh[24]a*eb | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
+ | sh64 | sh64le \
+ | sparc | sparc64 | sparc64b | sparc64v | sparc86x | sparclet | sparclite \
+ | sparcv8 | sparcv9 | sparcv9b | sparcv9v \
+@@ -362,7 +362,7 @@ case $basic_machine in
+ | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* | ppcbe-* \
+ | pyramid-* \
+ | romp-* | rs6000-* \
+- | sh-* | sh[1234]-* | sh[24]a-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
++ | sh-* | sh[1234]-* | sh[24]a-* | sh[24]a*eb-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
+ | shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
+ | sparc-* | sparc64-* | sparc64b-* | sparc64v-* | sparc86x-* | sparclet-* \
+ | sparclite-* \
+--
+1.6.0.1
+
diff --git a/sys-devel/gnuconfig/files/99999999/config.sub.sh.patch b/sys-devel/gnuconfig/files/99999999/config.sub.sh.patch
deleted file mode 100644
index ba34e95c298c..000000000000
--- a/sys-devel/gnuconfig/files/99999999/config.sub.sh.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-gnuconfig seems intent on only supporting superfluous targets that don't
-represent any real hardware (such as sh2a LE). GCC in its infinite wisdom is
-also incapable of supporting tuning for other variants in a sensible fashion.
-
-As such, we still need to be able to support such useful targets as
-sh2a_nofpueb in order to not only get the byte order right, but also to
-support -m2a-nofpu tuning from the kernel (though we tend to do this through
--Wa,-isa= instead, as the binutils people do a much better job of not screwing
-up their config code every other day. Way to go config.gcc..).
-
-The fact that the sh variant matching is the ugliest out of any of the other
-architectures doesn't seem to deter GCC folk from their well thought out and
-brilliantly managed config target list.
-
-Index: config.sub
-===================================================================
-RCS file: /cvsroot/config/config/config.sub,v
-retrieving revision 1.354
-diff -u -p -r1.354 config.sub
---- config.sub 17 Jan 2007 23:39:01 -0000 1.354
-+++ config.sub 8 Feb 2007 03:47:32 -0000
-@@ -277,7 +277,7 @@ case $basic_machine in
- | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
- | pyramid \
- | score \
-- | sh | sh[1234] | sh[24]a | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
-+ | sh | sh[1234] | sh[24]a | sh[24]a*eb | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
- | sh64 | sh64le \
- | sparc | sparc64 | sparc64b | sparc64v | sparc86x | sparclet | sparclite \
- | sparcv8 | sparcv9 | sparcv9b | sparcv9v \
-@@ -358,7 +358,7 @@ case $basic_machine in
- | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* | ppcbe-* \
- | pyramid-* \
- | romp-* | rs6000-* \
-- | sh-* | sh[1234]-* | sh[24]a-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
-+ | sh-* | sh[1234]-* | sh[24]a-* | sh[24]a*eb-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
- | shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
- | sparc-* | sparc64-* | sparc64b-* | sparc64v-* | sparc86x-* | sparclet-* \
- | sparclite-* \