summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-22 23:02:32 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-22 23:02:32 +0000
commit708736bf29ccdd4351c1c44e2550ab116331e768 (patch)
tree16d082ef78038a7e7dd0d503eaa983d972c58fb7 /sys-devel/libtool
parentswitch over to git (diff)
downloadgentoo-2-708736bf29ccdd4351c1c44e2550ab116331e768.tar.gz
gentoo-2-708736bf29ccdd4351c1c44e2550ab116331e768.tar.bz2
gentoo-2-708736bf29ccdd4351c1c44e2550ab116331e768.zip
simplify ebuild
(Portage version: 2.2_pre5)
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/libtool-1.3.5.ebuild37
1 files changed, 11 insertions, 26 deletions
diff --git a/sys-devel/libtool/libtool-1.3.5.ebuild b/sys-devel/libtool/libtool-1.3.5.ebuild
index dff8ba3a0054..5596e48a8b9d 100644
--- a/sys-devel/libtool/libtool-1.3.5.ebuild
+++ b/sys-devel/libtool/libtool-1.3.5.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.3.5.ebuild,v 1.7 2006/03/08 01:50:38 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
-
-inherit eutils libtool
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.3.5.ebuild,v 1.8 2008/04/22 23:02:32 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
DESCRIPTION="A shared library tool for developers"
-HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
+HOMEPAGE="http://www.gnu.org/software/libtool/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
@@ -13,29 +11,16 @@ SLOT="1.3"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE=""
-DEPEND=">=sys-devel/autoconf-2.58
- >=sys-devel/automake-1.8.3"
-# the autoconf dep is due to it complaining 'configure.ac:55: error: Autoconf version 2.58 or higher is required'
-# the automake dep is due to Bug #46037
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- echo
- # Install updated missing script
- portageq has_version / "sys-devel/automake" && {
- rm -f missing
- automake --add-missing
- }
-
- elibtoolize
+src_compile() {
+ econf \
+ --enable-ltdl-install \
+ --disable-static \
+ || die
+ emake -C libltdl || die
}
src_install() {
- cd libltdl
- make DESTDIR="${D}" install || die
-
+ emake -C libltdl DESTDIR="${D}" install-exec || die
# basically we just install ABI libs for old packages
- rm -r "${D}"/usr/include
- rm -f "${D}"/usr/lib/libltdl.{a,la,so}
+ rm "${D}"/usr/*/libltdl.{la,so} || die
}