summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-24 10:09:13 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-24 10:09:13 +0000
commite41651a50e4be9a3977402a9852a5c0e1771ee3f (patch)
tree374fdec27c2abeab4461fdcc31cfcb2021fc59eb /sys-devel/llvm
parentversion bump wrt bug #495150, thanks to Kent Fredric (diff)
downloadgentoo-2-e41651a50e4be9a3977402a9852a5c0e1771ee3f.tar.gz
gentoo-2-e41651a50e4be9a3977402a9852a5c0e1771ee3f.tar.bz2
gentoo-2-e41651a50e4be9a3977402a9852a5c0e1771ee3f.zip
Create the gold plugin symlink only with USE=gold.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/ChangeLog5
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild10
2 files changed, 10 insertions, 5 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index c1f70f80877f..90e24976d6ac 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.155 2013/12/20 21:50:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.156 2013/12/24 10:09:13 mgorny Exp $
+
+ 24 Dec 2013; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
+ Create the gold plugin symlink only with USE=gold.
20 Dec 2013; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
Disable libxml2 support in non-native ABIs since it is meaningful for
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 0688ba5ad4aa..c88e180c125b 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.69 2013/12/20 21:50:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.70 2013/12/24 10:09:13 mgorny Exp $
EAPI=5
@@ -360,9 +360,11 @@ multilib_src_install() {
use doc && dohtml -r "${S}"/docs/_build/html/
# Symlink the gold plugin.
- dodir /usr/${CHOST}/binutils-bin/lib/bfd-plugins
- dosym ../../../../$(get_libdir)/LLVMgold.so \
- /usr/${CHOST}/binutils-bin/lib/bfd-plugins/LLVMgold.so
+ if use gold; then
+ dodir /usr/${CHOST}/binutils-bin/lib/bfd-plugins
+ dosym ../../../../$(get_libdir)/LLVMgold.so \
+ /usr/${CHOST}/binutils-bin/lib/bfd-plugins/LLVMgold.so
+ fi
# install cmake modules
emake -C "${S%/}"_cmake/cmake/modules DESTDIR="${D}" install