summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-07-06 04:22:53 +0000
committerMike Frysinger <vapier@gentoo.org>2012-07-06 04:22:53 +0000
commit14f4c21c039a84d6805b027a10438e14995a1656 (patch)
tree426ee112955db4909f839776ada3c9a80dea86bd /sys-devel/m4
parentFix building with glibc-2.16 #424994 by Stevan Bajić. (diff)
downloadgentoo-2-14f4c21c039a84d6805b027a10438e14995a1656.tar.gz
gentoo-2-14f4c21c039a84d6805b027a10438e14995a1656.tar.bz2
gentoo-2-14f4c21c039a84d6805b027a10438e14995a1656.zip
Fix building with glibc-2.16 #424978 by Stevan Bajić.
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/m4')
-rw-r--r--sys-devel/m4/ChangeLog6
-rw-r--r--sys-devel/m4/files/m4-1.4.16-no-gets.patch24
-rw-r--r--sys-devel/m4/m4-1.4.16.ebuild3
3 files changed, 31 insertions, 2 deletions
diff --git a/sys-devel/m4/ChangeLog b/sys-devel/m4/ChangeLog
index 790791b175cb..f8ec6f63e4d8 100644
--- a/sys-devel/m4/ChangeLog
+++ b/sys-devel/m4/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/m4
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/ChangeLog,v 1.158 2012/06/28 12:43:25 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/ChangeLog,v 1.159 2012/07/06 04:22:53 vapier Exp $
+
+ 06 Jul 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/m4-1.4.16-no-gets.patch, m4-1.4.16.ebuild:
+ Fix building with glibc-2.16 #424978 by Stevan Bajić.
28 Jun 2012; Brent Baude <ranger@gentoo.org> m4-1.4.16.ebuild:
Marking m4-1.4.16 ppc for bug 423239
diff --git a/sys-devel/m4/files/m4-1.4.16-no-gets.patch b/sys-devel/m4/files/m4-1.4.16-no-gets.patch
new file mode 100644
index 000000000000..bb8069b8e766
--- /dev/null
+++ b/sys-devel/m4/files/m4-1.4.16-no-gets.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/424978
+
+hack until m4 pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
diff --git a/sys-devel/m4/m4-1.4.16.ebuild b/sys-devel/m4/m4-1.4.16.ebuild
index eee1197b819e..de41fdb5bc62 100644
--- a/sys-devel/m4/m4-1.4.16.ebuild
+++ b/sys-devel/m4/m4-1.4.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4.16.ebuild,v 1.8 2012/06/28 12:43:25 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4.16.ebuild,v 1.9 2012/07/06 04:22:53 vapier Exp $
EAPI="3"
@@ -21,6 +21,7 @@ RDEPEND=""
src_prepare() {
epatch "${FILESDIR}"/${P}-fix-test-readlink.patch #376639
+ epatch "${FILESDIR}"/${P}-no-gets.patch #424978
}
src_configure() {