summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-12-20 11:48:26 +0000
committerPeter Volkov <pva@gentoo.org>2010-12-20 11:48:26 +0000
commit28d9bb6a4c08497b6b29470e719685d1246dc6fa (patch)
tree21f3c4519015f1b0a3f7e03b7baaa8b7e3034880 /sys-devel/qconf
parentversion bump (diff)
downloadgentoo-2-28d9bb6a4c08497b6b29470e719685d1246dc6fa.tar.gz
gentoo-2-28d9bb6a4c08497b6b29470e719685d1246dc6fa.tar.bz2
gentoo-2-28d9bb6a4c08497b6b29470e719685d1246dc6fa.zip
Fixed LDFLAGS issue, bug #334133, thank Diego Elio Pettenò for report and Gavin Pryke for this fix.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/qconf')
-rw-r--r--sys-devel/qconf/ChangeLog8
-rw-r--r--sys-devel/qconf/qconf-1.5_pre717-r1.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-devel/qconf/ChangeLog b/sys-devel/qconf/ChangeLog
index abb10ab1a5c8..8c678effc93f 100644
--- a/sys-devel/qconf/ChangeLog
+++ b/sys-devel/qconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/qconf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/qconf/ChangeLog,v 1.11 2010/11/06 19:04:18 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/qconf/ChangeLog,v 1.12 2010/12/20 11:48:26 pva Exp $
+
+*qconf-1.5_pre717-r1 (20 Dec 2010)
+
+ 20 Dec 2010; Peter Volkov <pva@gentoo.org> +qconf-1.5_pre717-r1.ebuild:
+ Fixed LDFLAGS issue, bug #334133, thank Diego Elio Pettenò for report and
+ Gavin Pryke for this fix.
06 Nov 2010; Mark Loeser <halcy0n@gentoo.org> qconf-1.5_pre717.ebuild:
Stable for ppc64; bug #322353
diff --git a/sys-devel/qconf/qconf-1.5_pre717-r1.ebuild b/sys-devel/qconf/qconf-1.5_pre717-r1.ebuild
new file mode 100644
index 000000000000..543ff16f4c23
--- /dev/null
+++ b/sys-devel/qconf/qconf-1.5_pre717-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/qconf/qconf-1.5_pre717-r1.ebuild,v 1.1 2010/12/20 11:48:26 pva Exp $
+
+EAPI="2"
+
+inherit multilib qt4-r2
+
+DESCRIPTION="./configure like generator for qmake-based projects"
+HOMEPAGE="http://delta.affinix.com/qconf/"
+SRC_URI="http://delta.affinix.com/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="x11-libs/qt-core"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Fake ./configure. Fails on unknown options
+ ./configure \
+ --prefix=/usr/ \
+ --qtdir=/usr/$(get_libdir)/ || die "./configure failed"
+
+ [ ! -f Makefile ] && die "./configure failed"
+
+ eqmake4
+}
+
+src_install() {
+ dobin qconf || die
+ dodoc README TODO || die
+ insinto /usr/share/${PN}
+ doins -r conf modules
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+}