summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-10-17 17:44:54 +0000
committerMike Frysinger <vapier@gentoo.org>2014-10-17 17:44:54 +0000
commit070a6926277b1bd4950c273a9f1535b7f8b96051 (patch)
tree686b5b00ebff9b1c1e98a8526e41752ff96880fe /sys-devel
parentTweak nonfatal indirection for EAPI=0 to fix binpkg handling #523332 by Alex ... (diff)
downloadgentoo-2-070a6926277b1bd4950c273a9f1535b7f8b96051.tar.gz
gentoo-2-070a6926277b1bd4950c273a9f1535b7f8b96051.tar.bz2
gentoo-2-070a6926277b1bd4950c273a9f1535b7f8b96051.zip
Push out queued patches and move stuff from FILESDIR to the patchset.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/files/4.0.2/gcc-4.0.2-cross-compile.patch40
-rw-r--r--sys-devel/gcc/gcc-4.0.4.ebuild21
3 files changed, 9 insertions, 58 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 77f7ef5f22d1..a948cebedaf8 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.1021 2014/10/02 00:10:29 rhill Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.1022 2014/10/17 17:44:54 vapier Exp $
+
+ 17 Oct 2014; Mike Frysinger <vapier@gentoo.org>
+ -files/4.0.2/gcc-4.0.2-cross-compile.patch, gcc-4.0.4.ebuild:
+ Push out queued patches and move stuff from FILESDIR to the patchset.
02 Oct 2014; Ryan Hill <rhill@gentoo.org> gcc-4.7.3-r1.ebuild:
4.7.3 p1.5: Backport PR60155 fix to stable (bug #512586).
diff --git a/sys-devel/gcc/files/4.0.2/gcc-4.0.2-cross-compile.patch b/sys-devel/gcc/files/4.0.2/gcc-4.0.2-cross-compile.patch
deleted file mode 100644
index e14b57a3fdf4..000000000000
--- a/sys-devel/gcc/files/4.0.2/gcc-4.0.2-cross-compile.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Some notes on the 'bootstrap with or without libc headers' debate:
-http://linuxfromscratch.org/pipermail/lfs-dev/2005-July/052409.html
-http://gcc.gnu.org/ml/gcc/2005-07/msg01195.html
-
---- gcc/unwind-dw2.c
-+++ gcc/unwind-dw2.c
-@@ -253,9 +253,11 @@
- }
- #endif
-
-+#ifndef inhibit_libc
- #ifdef MD_UNWIND_SUPPORT
- #include MD_UNWIND_SUPPORT
- #endif
-+#endif
-
- /* Extract any interesting information from the CIE for the translation
- unit F belongs to. Return a pointer to the byte after the augmentation,
---- gcc/configure
-+++ gcc/configure
-@@ -12857,7 +12857,7 @@ then
- | powerpc*-*-*,powerpc64*-*-*)
- CROSS="$CROSS -DNATIVE_CROSS" ;;
- esac
--elif test "x$TARGET_SYSTEM_ROOT" != x; then
-+elif test "x$TARGET_SYSTEM_ROOT" != x -o $build != $host; then
- # This is just $(TARGET_SYSTEM_ROOT)$(NATIVE_SYSTEM_HEADER_DIR)
- SYSTEM_HEADER_DIR='$(CROSS_SYSTEM_HEADER_DIR)'
- fi
---- gcc/configure.ac
-+++ gcc/configure.ac
-@@ -1717,7 +1717,7 @@ then
- | powerpc*-*-*,powerpc64*-*-*)
- CROSS="$CROSS -DNATIVE_CROSS" ;;
- esac
--elif test "x$TARGET_SYSTEM_ROOT" != x; then
-+elif test "x$TARGET_SYSTEM_ROOT" != x -o $build != $host; then
- # This is just $(TARGET_SYSTEM_ROOT)$(NATIVE_SYSTEM_HEADER_DIR)
- SYSTEM_HEADER_DIR='$(CROSS_SYSTEM_HEADER_DIR)'
- fi
diff --git a/sys-devel/gcc/gcc-4.0.4.ebuild b/sys-devel/gcc/gcc-4.0.4.ebuild
index 4a2969e00228..00388e31c46b 100644
--- a/sys-devel/gcc/gcc-4.0.4.ebuild
+++ b/sys-devel/gcc/gcc-4.0.4.ebuild
@@ -1,32 +1,19 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.4.ebuild,v 1.17 2014/01/19 01:51:34 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.4.ebuild,v 1.18 2014/10/17 17:44:54 vapier Exp $
EAPI="2"
-PATCH_VER="1.1"
+PATCH_VER="1.2"
UCLIBC_VER="1.0"
-inherit eutils toolchain
+inherit toolchain
DESCRIPTION="The GNU Compiler Collection"
LICENSE="GPL-2+ LGPL-2.1+ FDL-1.2+"
-KEYWORDS="-* ~ia64 ~m68k"
+KEYWORDS=""
RDEPEND=""
DEPEND="${RDEPEND}
>=${CATEGORY}/binutils-2.15.94"
-
-src_prepare() {
- toolchain_src_prepare
-
- use vanilla && return 0
-
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
- # Fix cross-compiling
- epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-cross-compile.patch
-
- [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
-}