summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-05 16:25:26 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-05 16:25:26 +0000
commit1d445c763ed6501b34ce430709269666f41cc352 (patch)
tree6a0ae7437f5ae8c04ab0b39cbfcce7e29ef00cae /sys-devel
parentMove package from dev-util to dev-vcs, bug 56967. (diff)
downloadgentoo-2-1d445c763ed6501b34ce430709269666f41cc352.tar.gz
gentoo-2-1d445c763ed6501b34ce430709269666f41cc352.tar.bz2
gentoo-2-1d445c763ed6501b34ce430709269666f41cc352.zip
Convert to EAPI=3
(Portage version: 2.2.00.15738-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb-apple/ChangeLog7
-rw-r--r--sys-devel/gdb-apple/gdb-apple-1344.ebuild16
-rw-r--r--sys-devel/gdb-apple/gdb-apple-1346.ebuild14
-rw-r--r--sys-devel/gdb-apple/gdb-apple-563.ebuild16
-rw-r--r--sys-devel/gdb-apple/gdb-apple-768-r1.ebuild16
-rw-r--r--sys-devel/gdb-apple/gdb-apple-960.ebuild16
-rw-r--r--sys-devel/gdb-apple/gdb-apple-962.ebuild16
-rw-r--r--sys-devel/gdb-apple/gdb-apple-966.ebuild16
8 files changed, 47 insertions, 70 deletions
diff --git a/sys-devel/gdb-apple/ChangeLog b/sys-devel/gdb-apple/ChangeLog
index be211aae2122..250486663204 100644
--- a/sys-devel/gdb-apple/ChangeLog
+++ b/sys-devel/gdb-apple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gdb-apple
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.6 2010/03/04 21:32:45 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.7 2010/03/05 16:25:26 grobian Exp $
+
+ 05 Mar 2010; Fabian Groffen <grobian@gentoo.org> gdb-apple-563.ebuild,
+ gdb-apple-768-r1.ebuild, gdb-apple-960.ebuild, gdb-apple-962.ebuild,
+ gdb-apple-966.ebuild, gdb-apple-1344.ebuild, gdb-apple-1346.ebuild:
+ Convert to EAPI=3
*gdb-apple-1346 (04 Mar 2010)
diff --git a/sys-devel/gdb-apple/gdb-apple-1344.ebuild b/sys-devel/gdb-apple/gdb-apple-1344.ebuild
index 730ed671ca28..5183d7b42aae 100644
--- a/sys-devel/gdb-apple/gdb-apple-1344.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-1344.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-1344.ebuild,v 1.2 2009/09/25 11:52:08 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-1344.ebuild,v 1.3 2010/03/05 16:25:26 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic
@@ -22,10 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${PV}/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
[[ ${CHOST} == *-darwin8 ]] && epatch "${FILESDIR}"/${PN}-1344-darwin8.patch
@@ -33,18 +32,15 @@ src_unpack() {
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
}
-src_compile() {
+src_configure() {
replace-flags -O? -O2
econf \
--disable-werror \
$(use_enable nls) \
|| die
- emake || die
}
src_install() {
- local ED=${ED-${D}}
-
emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
rm -R "${D}"/nukeme || die
rm -Rf "${ED}"/usr/${CHOST} || die
diff --git a/sys-devel/gdb-apple/gdb-apple-1346.ebuild b/sys-devel/gdb-apple/gdb-apple-1346.ebuild
index 37f5707b64df..b5738d48bda0 100644
--- a/sys-devel/gdb-apple/gdb-apple-1346.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-1346.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-1346.ebuild,v 1.1 2010/03/04 21:32:45 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-1346.ebuild,v 1.2 2010/03/05 16:25:26 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic
@@ -22,10 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${PV}/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
[[ ${CHOST} == *-darwin8 ]] && epatch "${FILESDIR}"/${PN}-1344-darwin8.patch
@@ -33,18 +32,15 @@ src_unpack() {
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
}
-src_compile() {
+src_configure() {
replace-flags -O? -O2
econf \
--disable-werror \
$(use_enable nls) \
|| die
- emake || die
}
src_install() {
- local ED=${ED-${D}}
-
emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
rm -R "${D}"/nukeme || die
rm -Rf "${ED}"/usr/${CHOST} || die
diff --git a/sys-devel/gdb-apple/gdb-apple-563.ebuild b/sys-devel/gdb-apple/gdb-apple-563.ebuild
index 3a7e41fe20d4..1a942500a61d 100644
--- a/sys-devel/gdb-apple/gdb-apple-563.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-563.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-563.ebuild,v 1.1 2009/06/21 10:38:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-563.ebuild,v 1.2 2010/03/05 16:25:26 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic
@@ -22,10 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${PV}/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${P}-darwin7.patch
epatch "${FILESDIR}"/${P}-no-64bit.patch
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
@@ -34,18 +33,15 @@ src_unpack() {
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
}
-src_compile() {
+src_configure() {
replace-flags -O? -O2
econf \
--disable-werror \
$(use_enable nls) \
|| die
- emake || die
}
src_install() {
- local ED=${ED-${D}}
-
emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
rm -r "${D}"/nukeme || die
rm -Rf "${ED}"/usr/${CHOST} || die
diff --git a/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild b/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
index e0c373b94ab6..d5534b725621 100644
--- a/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild,v 1.1 2009/06/21 10:38:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild,v 1.2 2010/03/05 16:25:26 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic
@@ -22,10 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${PV}/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${P}-texinfo.patch
epatch "${FILESDIR}"/${P}-darwin-arch.patch
@@ -33,18 +32,15 @@ src_unpack() {
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
}
-src_compile() {
+src_configure() {
replace-flags -O? -O2
econf \
--disable-werror \
$(use_enable nls) \
|| die
- emake || die
}
src_install() {
- local ED=${ED-${D}}
-
emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
rm -r "${D}"/nukeme || die
rm -Rf "${ED}"/usr/${CHOST} || die
diff --git a/sys-devel/gdb-apple/gdb-apple-960.ebuild b/sys-devel/gdb-apple/gdb-apple-960.ebuild
index 9e2ddced2f5c..2147ee9370f5 100644
--- a/sys-devel/gdb-apple/gdb-apple-960.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-960.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-960.ebuild,v 1.1 2009/06/21 10:38:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-960.ebuild,v 1.2 2010/03/05 16:25:26 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic
@@ -22,10 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${PV}/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
epatch "${FILESDIR}"/${PN}-768-darwin-arch.patch
@@ -33,18 +32,15 @@ src_unpack() {
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
}
-src_compile() {
+src_configure() {
replace-flags -O? -O2
econf \
--disable-werror \
$(use_enable nls) \
|| die
- emake || die
}
src_install() {
- local ED=${ED-${D}}
-
emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
rm -r "$D"/nukeme || die
rm -Rf "${ED}"/usr/${CHOST} || die
diff --git a/sys-devel/gdb-apple/gdb-apple-962.ebuild b/sys-devel/gdb-apple/gdb-apple-962.ebuild
index ff452845373a..86633707a6ac 100644
--- a/sys-devel/gdb-apple/gdb-apple-962.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-962.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-962.ebuild,v 1.3 2009/11/27 08:40:03 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-962.ebuild,v 1.4 2010/03/05 16:25:26 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic
@@ -22,10 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${PV}/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
epatch "${FILESDIR}"/${PN}-768-darwin-arch.patch
epatch "${FILESDIR}"/${PN}-962-darwin8.patch
@@ -36,18 +35,15 @@ src_unpack() {
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
}
-src_compile() {
+src_configure() {
replace-flags -O? -O2
econf \
--disable-werror \
$(use_enable nls) \
|| die
- emake || die
}
src_install() {
- local ED=${ED-${D}}
-
emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
rm -r "${D}"/nukeme || die
rm -Rf "${ED}"/usr/${CHOST} || die
diff --git a/sys-devel/gdb-apple/gdb-apple-966.ebuild b/sys-devel/gdb-apple/gdb-apple-966.ebuild
index 043a83f7a3bd..766fa0e086bd 100644
--- a/sys-devel/gdb-apple/gdb-apple-966.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-966.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-966.ebuild,v 1.3 2009/11/27 08:40:03 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-966.ebuild,v 1.4 2010/03/05 16:25:26 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic
@@ -22,10 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${PV}/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
epatch "${FILESDIR}"/${PN}-768-darwin-arch.patch
epatch "${FILESDIR}"/${PN}-962-darwin8.patch
@@ -36,18 +35,15 @@ src_unpack() {
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
}
-src_compile() {
+src_configure() {
replace-flags -O? -O2
econf \
--disable-werror \
$(use_enable nls) \
|| die
- emake || die
}
src_install() {
- local ED=${ED-${D}}
-
emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
rm -R "${D}"/nukeme || die
rm -Rf "${ED}"/usr/${CHOST} || die