summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-08-07 16:28:38 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-08-07 16:28:38 +0000
commit38007ddcca5fe3a452907bdcfcf228915b13948b (patch)
treea4b85d73e285bd96845907620437331cff950289 /sys-devel
parentremove old (diff)
downloadgentoo-2-38007ddcca5fe3a452907bdcfcf228915b13948b.tar.gz
gentoo-2-38007ddcca5fe3a452907bdcfcf228915b13948b.tar.bz2
gentoo-2-38007ddcca5fe3a452907bdcfcf228915b13948b.zip
Respect CFLAGS/LDFLAGS, fix documentation, bug #429936
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/ct-ng/ChangeLog6
-rw-r--r--sys-devel/ct-ng/ct-ng-1.15.3.ebuild13
-rw-r--r--sys-devel/ct-ng/files/ct-ng-kconfig-respect-flags.patch14
3 files changed, 28 insertions, 5 deletions
diff --git a/sys-devel/ct-ng/ChangeLog b/sys-devel/ct-ng/ChangeLog
index e113cc9fb345..271e372d69f0 100644
--- a/sys-devel/ct-ng/ChangeLog
+++ b/sys-devel/ct-ng/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/ct-ng
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.38 2012/08/07 15:13:02 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.39 2012/08/07 16:28:38 blueness Exp $
+
+ 07 Aug 2012; Anthony G. Basile <blueness@gentoo.org> ct-ng-1.15.3.ebuild,
+ +files/ct-ng-kconfig-respect-flags.patch:
+ Respect CFLAGS/LDFLAGS, fix documentation, bug #429936
07 Aug 2012; Anthony G. Basile <blueness@gentoo.org> -ct-ng-1.15.2.ebuild:
Remove older unstable in 1.15 branch
diff --git a/sys-devel/ct-ng/ct-ng-1.15.3.ebuild b/sys-devel/ct-ng/ct-ng-1.15.3.ebuild
index 9a724a2c2696..2425e9da3c98 100644
--- a/sys-devel/ct-ng/ct-ng-1.15.3.ebuild
+++ b/sys-devel/ct-ng/ct-ng-1.15.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ct-ng-1.15.3.ebuild,v 1.1 2012/07/18 16:42:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ct-ng-1.15.3.ebuild,v 1.2 2012/08/07 16:28:38 blueness Exp $
EAPI="4"
-inherit bash-completion-r1 autotools
+inherit autotools bash-completion-r1 eutils
DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
HOMEPAGE="http://ymorin.is-a-geek.org/projects/crosstool"
@@ -15,7 +15,7 @@ SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion"
+IUSE="bash-completion doc"
RDEPEND="net-misc/curl
dev-util/gperf
@@ -23,13 +23,18 @@ RDEPEND="net-misc/curl
dev-vcs/subversion"
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-kconfig-respect-flags.patch
+
#Upstream provides ${S}/bootstrap which runs autoconf -Wall --force
#We'll use eautoconf to be portage friendly
eautoconf -Wall --force
}
src_install() {
- emake DESTDIR="${D%/}" install || die "install failed"
+ emake DESTDIR="${D%/}" install
dobashcomp ${PN}.comp
dodoc README TODO
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/"${PN}.${PVR}"/* \
+ "${D}"/usr/share/doc/"${PF}"
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
}
diff --git a/sys-devel/ct-ng/files/ct-ng-kconfig-respect-flags.patch b/sys-devel/ct-ng/files/ct-ng-kconfig-respect-flags.patch
new file mode 100644
index 000000000000..e6b48142a6df
--- /dev/null
+++ b/sys-devel/ct-ng/files/ct-ng-kconfig-respect-flags.patch
@@ -0,0 +1,14 @@
+diff -Naur crosstool-ng-1.15.3.orig//kconfig/Makefile crosstool-ng-1.15.3/kconfig/Makefile
+--- crosstool-ng-1.15.3.orig//kconfig/Makefile 2012-07-17 16:39:55.000000000 -0400
++++ crosstool-ng-1.15.3/kconfig/Makefile 2012-08-07 12:06:59.000000000 -0400
+@@ -6,8 +6,8 @@
+ @true # Just be silent, you fscking son of a fscking beach...
+
+ # Build flags
+-CFLAGS = -DCONFIG_=\"CT_\" -DPACKAGE="\"crosstool-NG $(VERSION)\""
+-LDFLAGS =
++CFLAGS += -DCONFIG_=\"CT_\" -DPACKAGE="\"crosstool-NG $(VERSION)\""
++#LDFLAGS =
+
+ # Compiler flags to use gettext
+ ifeq ($(gettext),)