summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-02-27 21:54:21 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-02-27 21:54:21 +0000
commit50894e6222dbcf1081ca3d999eaffd1f369dd3f1 (patch)
tree1afe799d81a302e33987a9095613131feb77fc9f /sys-devel
parentUpdate llvm 3.6.0 mask for final release (diff)
downloadgentoo-2-50894e6222dbcf1081ca3d999eaffd1f369dd3f1.tar.gz
gentoo-2-50894e6222dbcf1081ca3d999eaffd1f369dd3f1.tar.bz2
gentoo-2-50894e6222dbcf1081ca3d999eaffd1f369dd3f1.zip
Version bump
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/dragonegg/ChangeLog7
-rw-r--r--sys-devel/dragonegg/dragonegg-3.6.0.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-devel/dragonegg/ChangeLog b/sys-devel/dragonegg/ChangeLog
index 66793608501e..964e948ef4d3 100644
--- a/sys-devel/dragonegg/ChangeLog
+++ b/sys-devel/dragonegg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/dragonegg
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/ChangeLog,v 1.22 2015/02/18 21:33:18 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/ChangeLog,v 1.23 2015/02/27 21:54:21 voyageur Exp $
+
+*dragonegg-3.6.0 (27 Feb 2015)
+
+ 27 Feb 2015; Bernard Cafarelli <voyageur@gentoo.org> +dragonegg-3.6.0.ebuild:
+ Version bump
18 Feb 2015; Bernard Cafarelli <voyageur@gentoo.org> -dragonegg-3.5.0.ebuild,
dragonegg-3.5.1.ebuild, dragonegg-9999.ebuild:
diff --git a/sys-devel/dragonegg/dragonegg-3.6.0.ebuild b/sys-devel/dragonegg/dragonegg-3.6.0.ebuild
new file mode 100644
index 000000000000..24728a505221
--- /dev/null
+++ b/sys-devel/dragonegg/dragonegg-3.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/dragonegg-3.6.0.ebuild,v 1.1 2015/02/27 21:54:21 voyageur Exp $
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="GCC plugin that uses LLVM for optimization and code generation"
+HOMEPAGE="http://dragonegg.llvm.org/"
+SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz
+ test? ( http://llvm.org/releases/${PV}/llvm-${PV}.src.tar.xz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="test"
+
+DEPEND=">=sys-devel/gcc-4.5:*
+ =sys-devel/llvm-${PV}*"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}.src
+
+pkg_pretend() {
+ # Bug #511640: gcc 4.9 removed a required header
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-version) > 4.8 || $(gcc-version) < 4.5 ]] && \
+ die 'The active compiler needs to be gcc 4.[5-8])'
+ fi
+}
+
+src_compile() {
+ # GCC: compiler to use plugin with
+ emake CC="$(tc-getCC)" GCC="$(tc-getCC)" CXX="$(tc-getCXX)" VERBOSE=1
+}
+
+src_test() {
+ # GCC languages are determined via locale-dependant gcc -v output
+ export LC_ALL=C
+
+ emake LIT_DIR="${WORKDIR}"/llvm-${PV}.src/utils/lit check
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)
+ doexe dragonegg.so
+
+ dodoc README
+}
+
+pkg_postinst() {
+ elog "To use dragonegg, run gcc as usual, with an extra command line argument:"
+ elog " -fplugin=/usr/$(get_libdir)/dragonegg.so"
+ elog "If you change the active gcc profile, or update gcc to a new version,"
+ elog "you will have to remerge this package to update the plugin"
+}