summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-04 08:50:49 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-04 08:50:49 +0000
commit51117f87686a1dcdac9bcd75a2dde0286ec854c9 (patch)
tree478f05e41c97a6d7ac5c60811fae040a834bb4de /sys-devel
parentBump for 447216 (diff)
downloadgentoo-2-51117f87686a1dcdac9bcd75a2dde0286ec854c9.tar.gz
gentoo-2-51117f87686a1dcdac9bcd75a2dde0286ec854c9.tar.bz2
gentoo-2-51117f87686a1dcdac9bcd75a2dde0286ec854c9.zip
Use supported Python implementation during build. Fixes bug #455260.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog6
-rw-r--r--sys-devel/clang/clang-3.2.ebuild7
-rw-r--r--sys-devel/clang/clang-9999.ebuild7
3 files changed, 13 insertions, 7 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index f018a4d5da42..efb97086913a 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.84 2013/02/02 23:28:27 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.85 2013/02/04 08:50:49 mgorny Exp $
+
+ 04 Feb 2013; Michał Górny <mgorny@gentoo.org> clang-3.2.ebuild,
+ clang-9999.ebuild:
+ Use supported Python implementation during build. Fixes bug #455260.
02 Feb 2013; Michał Górny <mgorny@gentoo.org> clang-3.2.ebuild,
clang-9999.ebuild:
diff --git a/sys-devel/clang/clang-3.2.ebuild b/sys-devel/clang/clang-3.2.ebuild
index 0ac8114b43f4..8db232e2a870 100644
--- a/sys-devel/clang/clang-3.2.ebuild
+++ b/sys-devel/clang/clang-3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.2.ebuild,v 1.4 2013/02/02 23:28:27 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.2.ebuild,v 1.5 2013/02/04 08:50:49 mgorny Exp $
EAPI=5
@@ -110,6 +110,9 @@ src_configure() {
CONF_FLAGS="${CONF_FLAGS} --enable-pic"
fi
+ # build with a suitable Python version
+ python_export_best
+
# clang prefers clang over gcc, so we may need to force that
tc-export CC CXX
econf ${CONF_FLAGS}
@@ -124,8 +127,6 @@ src_test() {
echo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- python_export_best
-
if ! emake -j1 VERBOSE=1 test; then
has test $FEATURES && die "Make test failed. See above for details."
has test $FEATURES || eerror "Make test failed. See above for details."
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 5d3c1a6a7e23..aa1e71c2f9f7 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.34 2013/02/02 23:28:27 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.35 2013/02/04 08:50:49 mgorny Exp $
EAPI=5
@@ -98,6 +98,9 @@ src_configure() {
CONF_FLAGS="${CONF_FLAGS} --enable-pic"
fi
+ # build with a suitable Python version
+ python_export_best
+
# clang prefers clang over gcc, so we may need to force that
tc-export CC CXX
econf ${CONF_FLAGS}
@@ -112,8 +115,6 @@ src_test() {
echo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- python_export_best
-
if ! emake -j1 VERBOSE=1 test; then
has test $FEATURES && die "Make test failed. See above for details."
has test $FEATURES || eerror "Make test failed. See above for details."