summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-03-04 15:44:48 +0000
committerFabian Groffen <grobian@gentoo.org>2012-03-04 15:44:48 +0000
commit8118aaf7caee543d0b34e9e7fc0b15e9b0a9130d (patch)
treeefe36ca6994109be873bc741fe8bc3b27c853daa /sys-devel
parentStable on alpha, bug #395735 (diff)
downloadgentoo-2-8118aaf7caee543d0b34e9e7fc0b15e9b0a9130d.tar.gz
gentoo-2-8118aaf7caee543d0b34e9e7fc0b15e9b0a9130d.tar.bz2
gentoo-2-8118aaf7caee543d0b34e9e7fc0b15e9b0a9130d.zip
Avoid the need for vers_string program that seems no longer to be installed with recent Xcode on Lion
(Portage version: 2.2.01.20271-prefix/cvs/Darwin i386)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils-apple/ChangeLog6
-rw-r--r--sys-devel/binutils-apple/binutils-apple-4.2.ebuild23
2 files changed, 27 insertions, 2 deletions
diff --git a/sys-devel/binutils-apple/ChangeLog b/sys-devel/binutils-apple/ChangeLog
index 1d8cfed1bcf9..52a1a6175ff3 100644
--- a/sys-devel/binutils-apple/ChangeLog
+++ b/sys-devel/binutils-apple/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/binutils-apple
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.28 2012/02/19 19:37:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.29 2012/03/04 15:44:48 grobian Exp $
+
+ 04 Mar 2012; Fabian Groffen <grobian@gentoo.org> binutils-apple-4.2.ebuild:
+ Avoid the need for vers_string program that seems no longer to be installed
+ with recent Xcode on Lion
19 Feb 2012; Fabian Groffen <grobian@gentoo.org> binutils-apple-4.2.ebuild:
Use append-cppflags instead of too generic append-flags to avoid F77 and FC
diff --git a/sys-devel/binutils-apple/binutils-apple-4.2.ebuild b/sys-devel/binutils-apple/binutils-apple-4.2.ebuild
index e838cf42fa7d..7df09000ce38 100644
--- a/sys-devel/binutils-apple/binutils-apple-4.2.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-4.2.ebuild,v 1.5 2012/02/19 19:37:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-4.2.ebuild,v 1.6 2012/03/04 15:44:48 grobian Exp $
EAPI="3"
@@ -109,6 +109,27 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-4.0-no-oss-dir.patch
epatch "${FILESDIR}"/${PN}-4.2-lto.patch
+ local program
+ for program in ar efitools gprof libmacho misc otool ; do
+ VER_STR="@(#)PROGRAM:${program} PROJECT:${CCTOOLS} (Gentoo ${PN}-${PVR}) DEVELOPER:${PORTAGE_ROOT_USER} BUILT:$(date)"
+ cat > ${program}/vers.c <<- _EOF
+ #include <sys/cdefs.h>
+ __IDSTRING(SGS_VERS,"${VER_STR}\n");
+ _EOF
+ [[ ${program} != "libmacho" ]] && \
+ echo '__IDSTRING(VERS_NUM,"apple");' >> ${program}/vers.c
+ done
+
+ VER_STR="${CCTOOLS} (Gentoo ${PN}-${PVR})"
+ echo "const char apple_version[] = \"${VER_STR}\";" \
+ >> as/apple_version.c || die
+ echo "const char apple_version[] = \"${VER_STR})\";" \
+ >> efitools/vers.c || die
+ echo "const char apple_version[] = \"${VER_STR})\";" \
+ >> ld/ld_vers.c || die
+ echo "const char apple_version[] = \"${VER_STR})\";" \
+ >> misc/vers.c || die
+
# clean up test suite
cd "${S}"/${LD64}
# epatch "${FILESDIR}"/${PN}-3.1.1-testsuite.patch