summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-06-11 17:05:20 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-06-11 17:05:20 +0000
commit86fb133dff405c637b44ed0955b6bc4f5a525865 (patch)
treeaf42cd1ec29c6588b4d04a04b360cb0ccac847dd /sys-devel
parentRemove old. (diff)
downloadgentoo-2-86fb133dff405c637b44ed0955b6bc4f5a525865.tar.gz
gentoo-2-86fb133dff405c637b44ed0955b6bc4f5a525865.tar.bz2
gentoo-2-86fb133dff405c637b44ed0955b6bc4f5a525865.zip
Documentation build can be made optional again, add back pax markings
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog5
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild16
2 files changed, 13 insertions, 8 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 0b84df678869..aa90795585b8 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.246 2015/06/09 21:17:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.247 2015/06/11 17:05:20 voyageur Exp $
+
+ 11 Jun 2015; Bernard Cafarelli <voyageur@gentoo.org> llvm-9999.ebuild:
+ Documentation build can be made optional again, add back pax markings
09 Jun 2015; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
Enable EH & RTTI for better compatibility
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 70ab432b600c..91a95c110d54 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.112 2015/06/09 21:17:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.113 2015/06/11 17:05:20 voyageur Exp $
EAPI=5
@@ -43,7 +43,6 @@ COMMON_DEPEND="
# configparser-3.2 breaks the build (3.3 or none at all are fine)
DEPEND="${COMMON_DEPEND}
dev-lang/perl
- dev-python/sphinx
>=sys-devel/make-3.81
>=sys-devel/flex-2.5.4
>=sys-devel/bison-1.875d
@@ -53,6 +52,7 @@ DEPEND="${COMMON_DEPEND}
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
kernel_Darwin? ( sys-libs/libcxx )
clang? ( xml? ( virtual/pkgconfig ) )
+ doc? ( dev-python/sphinx )
libffi? ( virtual/pkgconfig )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
@@ -243,11 +243,10 @@ multilib_src_configure() {
if multilib_is_native_abi; then
mycmakeargs+=(
- -DLLVM_BUILD_DOCS=ON
+ $(cmake-utils_use doc LLVM_BUILD_DOCS)
+ $(cmake-utils_use doc LLVM_ENABLE_SPHINX)
+ $(cmake-utils_use doc SPHINX_OUTPUT_HTML)
-DLLVM_ENABLE_DOXYGEN=OFF
- -DLLVM_ENABLE_SPHINX=ON
- -DSPHINX_OUTPUT_HTML=$(usex doc)
-
-DLLVM_INSTALL_HTML="${EPREFIX}/usr/share/doc/${PF}/html"
)
@@ -296,6 +295,10 @@ multilib_src_configure() {
multilib_src_compile() {
cmake-utils_src_compile
+ pax-mark m "${BUILD_DIR}"/bin/llvm-rtdyld
+ pax-mark m "${BUILD_DIR}"/bin/lli
+ pax-mark m "${BUILD_DIR}"/bin/lli-child-target
+
if use test; then
pax-mark m "${BUILD_DIR}"/unittests/ExecutionEngine/Orc/OrcJITTests
pax-mark m "${BUILD_DIR}"/unittests/ExecutionEngine/MCJIT/MCJITTests
@@ -340,7 +343,6 @@ src_install() {
)
fi
-
multilib-minimal_src_install
}