summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-05-27 12:02:40 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-05-27 12:02:40 +0000
commit94bddfa9d69122ee5f5570b38507a38cac208b4a (patch)
tree503d08a1dd28d5120b857ea0c8669910a10875f7 /sys-devel
parentVersion bump, mostly MIPS and R600 bug fixes (diff)
downloadgentoo-2-94bddfa9d69122ee5f5570b38507a38cac208b4a.tar.gz
gentoo-2-94bddfa9d69122ee5f5570b38507a38cac208b4a.tar.bz2
gentoo-2-94bddfa9d69122ee5f5570b38507a38cac208b4a.zip
Version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog8
-rw-r--r--sys-devel/clang/clang-3.6.1-r100.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index c3ae342744f6..fff5ede13187 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.123 2015/04/08 18:25:48 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.124 2015/05/27 12:02:40 voyageur Exp $
+
+*clang-3.6.1-r100 (27 May 2015)
+
+ 27 May 2015; Bernard Cafarelli <voyageur@gentoo.org>
+ +clang-3.6.1-r100.ebuild:
+ Version bump
08 Apr 2015; Michał Górny <mgorny@gentoo.org> clang-3.2.ebuild,
clang-9999.ebuild:
diff --git a/sys-devel/clang/clang-3.6.1-r100.ebuild b/sys-devel/clang/clang-3.6.1-r100.ebuild
new file mode 100644
index 000000000000..7d5e0228ba70
--- /dev/null
+++ b/sys-devel/clang/clang-3.6.1-r100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.6.1-r100.ebuild,v 1.1 2015/05/27 12:02:40 voyageur Exp $
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.6"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug multitarget python +static-analyzer"
+
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer,${MULTILIB_USEDEP}]"
+
+# Please keep this package around since it's quite likely that we'll
+# return to separate LLVM & clang ebuilds when the cmake build system
+# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}