summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-27 02:23:00 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-27 02:23:00 +0000
commitb6786072bb99ae35621bc93ccde214379faff915 (patch)
treee4082401e90002e5257ff4b64c4839467187a4c3 /sys-devel
parentFixed sparc keyword problem, sorry folks :( (Manifest recommit) (diff)
downloadgentoo-2-b6786072bb99ae35621bc93ccde214379faff915.tar.gz
gentoo-2-b6786072bb99ae35621bc93ccde214379faff915.tar.bz2
gentoo-2-b6786072bb99ae35621bc93ccde214379faff915.zip
saner defaults for march
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-3.4.0.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/gcc/gcc-3.4.0.ebuild b/sys-devel/gcc/gcc-3.4.0.ebuild
index c84e6ec45ce8..e53d03a0c0d8 100644
--- a/sys-devel/gcc/gcc-3.4.0.ebuild
+++ b/sys-devel/gcc/gcc-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0.ebuild,v 1.4 2004/04/26 19:40:03 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0.ebuild,v 1.5 2004/04/27 02:23:00 lv Exp $
IUSE="static nls bootstrap java build X multilib gcj hardened f77 objc uclibc"
@@ -386,11 +386,11 @@ src_compile() {
# Default arch support
use amd64 && myconf="${myconf} --with-cpu=k8 --with-arch=k8"
- use ppc64 && myconf="${myconf} --with-cpu=g5 --with-arch=g5"
- use s390 && myconf="${myconf} --with-cpu=z990 --with-arch=g5"
+ use ppc64 && myconf="${myconf} --with-arch=powerpc64"
+ use s390 && myconf="${myconf} --with-arch=g5"
use x86 && myconf="${myconf} --with-cpu=pentium4 --with-arch=i586"
- use mips && myconf="${myconf} --with-cpu=r4600 --with-arch=mips3"
- use ppc && myconf="${myconf} --with-cpu=g4 --with-arch=g3"
+ use mips && myconf="${myconf} --with-arch=mips3"
+ use ppc && myconf="${myconf} --with-arch=g3"
# In general gcc does not like optimization, and add -O2 where
# it is safe. This is especially true for gcc 3.3 + 3.4