summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-01 10:13:55 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-01 10:13:55 +0000
commitd5ec695a55fcee6e2c5815f40e32a99159db9b0b (patch)
tree61040f517db2f7e33c67d72170ee7d8127dcb416 /sys-devel
parent*** empty log message *** (diff)
downloadgentoo-2-d5ec695a55fcee6e2c5815f40e32a99159db9b0b.tar.gz
gentoo-2-d5ec695a55fcee6e2c5815f40e32a99159db9b0b.tar.bz2
gentoo-2-d5ec695a55fcee6e2c5815f40e32a99159db9b0b.zip
*** empty log message ***
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild8
-rw-r--r--sys-devel/gcc/gcc-2.95.3.ebuild10
-rw-r--r--sys-devel/gettext/gettext-0.10.35-r2.ebuild4
3 files changed, 16 insertions, 6 deletions
diff --git a/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild b/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild
index 9820b214586b..f4c6fd6cafbb 100644
--- a/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild
+++ b/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild,v 1.3 2001/05/01 10:08:50 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild,v 1.4 2001/05/01 10:13:38 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -15,8 +15,12 @@ fi
src_compile() {
local myconf
- if [ -z "`use nls`" ]
+ if [ "`use nls`" ]
then
+ if [ "`use build`" ] ; then
+ myconf="--with-included-gettext"
+ fi
+ else
myconf="--disable-nls"
fi
try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} ${myconf}
diff --git a/sys-devel/gcc/gcc-2.95.3.ebuild b/sys-devel/gcc/gcc-2.95.3.ebuild
index 2f15b10462fb..0fdc58a5fce9 100644
--- a/sys-devel/gcc/gcc-2.95.3.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3.ebuild,v 1.2 2001/05/01 10:08:50 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3.ebuild,v 1.3 2001/05/01 10:13:55 achim Exp $
SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.gz"
@@ -59,11 +59,15 @@ src_compile() {
then
myconf="--enable-shared"
else
- myconf="--enable-languages=c,c++"
+ myconf="--enable-languages=c"
fi
if [ "`use nls`" ]
then
- myconf="${myconf} --enable-nls"
+ if [ "`use build`" ] ; then
+ myconf="${myconf} --with-included-gettext --enable-nls"
+ else
+ myconf="${myconf} --enable-nls"
+ fi
else
myconf="${myconf} --disable-nls"
fi
diff --git a/sys-devel/gettext/gettext-0.10.35-r2.ebuild b/sys-devel/gettext/gettext-0.10.35-r2.ebuild
index 7898a49c2102..c5c222064921 100644
--- a/sys-devel/gettext/gettext-0.10.35-r2.ebuild
+++ b/sys-devel/gettext/gettext-0.10.35-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.10.35-r2.ebuild,v 1.3 2001/03/06 05:27:28 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.10.35-r2.ebuild,v 1.4 2001/05/01 10:09:09 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,7 +10,9 @@ SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gettext/${A}
ftp://prep.ai.mit.edu/gnu/gettext/${A}"
HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
+if [ -z "`use build`" ] ; then
DEPEND="virtual/glibc"
+fi
src_compile() {
local myconf