summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-03-19 02:21:14 +0000
committerMike Frysinger <vapier@gentoo.org>2010-03-19 02:21:14 +0000
commite116deb410105a5bafad5f4dca40bbfd28d72e69 (patch)
treec8e14d9f9b5ef09f55fd9227d8db546493a4139f /sys-devel
parentVersion bump. Bug fixes, optimizations, code cleanups (diff)
downloadgentoo-2-e116deb410105a5bafad5f4dca40bbfd28d72e69.tar.gz
gentoo-2-e116deb410105a5bafad5f4dca40bbfd28d72e69.tar.bz2
gentoo-2-e116deb410105a5bafad5f4dca40bbfd28d72e69.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/ChangeLog7
-rw-r--r--sys-devel/gdb/gdb-7.1.ebuild103
2 files changed, 109 insertions, 1 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index 703ec40bbf07..c29983c36cb2 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gdb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.163 2010/01/26 16:57:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.164 2010/03/19 02:21:14 vapier Exp $
+
+*gdb-7.1 (19 Mar 2010)
+
+ 19 Mar 2010; Mike Frysinger <vapier@gentoo.org> +gdb-7.1.ebuild:
+ Version bump.
26 Jan 2010; Jeroen Roovers <jer@gentoo.org> gdb-7.0.ebuild:
Stable for HPPA (bug #296389).
diff --git a/sys-devel/gdb/gdb-7.1.ebuild b/sys-devel/gdb/gdb-7.1.ebuild
new file mode 100644
index 000000000000..b3e286247d11
--- /dev/null
+++ b/sys-devel/gdb/gdb-7.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.1.ebuild,v 1.1 2010/03/19 02:21:14 vapier Exp $
+
+inherit flag-o-matic eutils
+
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
+
+PATCH_VER="1"
+DESCRIPTION="GNU debugger"
+HOMEPAGE="http://sources.redhat.com/gdb/"
+SRC_URI="http://ftp.gnu.org/gnu/gdb/${P}.tar.bz2
+ ftp://sources.redhat.com/pub/gdb/releases/${P}.tar.bz2
+ ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.lzma}"
+
+LICENSE="GPL-2 LGPL-2"
+is_cross \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="expat multitarget nls python test vanilla"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2
+ sys-libs/readline
+ expat? ( dev-libs/expat )
+ python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ || ( app-arch/xz-utils app-arch/lzma-utils )
+ test? ( dev-util/dejagnu )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use vanilla || [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
+ strip-linguas -u bfd/po opcodes/po
+}
+
+gdb_branding() {
+ printf "Gentoo ${PV} "
+ if [[ -n ${PATCH_VER} ]] ; then
+ printf "p${PATCH_VER}"
+ else
+ printf "vanilla"
+ fi
+}
+
+src_compile() {
+ strip-unsupported-flags
+ econf \
+ --with-pkgversion="$(gdb_branding)" \
+ --with-bugurl='http://bugs.gentoo.org/' \
+ --disable-werror \
+ $(has_version '=sys-libs/readline-5*:0' && echo --with-system-readline) \
+ $(is_cross && echo --with-sysroot=/usr/${CTARGET}) \
+ $(use_with expat) \
+ $(use_enable nls) \
+ $(use multitarget && echo --enable-targets=all) \
+ $(use_with python) \
+ || die
+ emake || die
+}
+
+src_test() {
+ emake check || ewarn "tests failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ libdir=/nukeme/pretty/pretty/please includedir=/nukeme/pretty/pretty/please \
+ install || die
+ rm -r "${D}"/nukeme || die
+
+ # Don't install docs when building a cross-gdb
+ if [[ ${CTARGET} != ${CHOST} ]] ; then
+ rm -r "${D}"/usr/share
+ return 0
+ fi
+
+ dodoc README
+ docinto gdb
+ dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
+ gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
+ docinto sim
+ dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
+
+ dodoc "${WORKDIR}"/extra/gdbinit.sample
+
+ # Remove shared info pages
+ rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+}
+
+pkg_postinst() {
+ # portage sucks and doesnt unmerge files in /etc
+ rm -vf "${ROOT}"/etc/skel/.gdbinit
+}