summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-04-04 05:28:56 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-04-04 05:28:56 +0000
commitf40bc95ef41f613848137a88dc2f368590654689 (patch)
tree37aacae6ab51afe724c93dbadef1b6771ed64f02 /sys-devel
parentMask GCC 4.8. (diff)
downloadgentoo-2-f40bc95ef41f613848137a88dc2f368590654689.tar.gz
gentoo-2-f40bc95ef41f613848137a88dc2f368590654689.tar.bz2
gentoo-2-f40bc95ef41f613848137a88dc2f368590654689.zip
Version bump (bug #462736).
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog7
-rw-r--r--sys-devel/gcc/gcc-4.8.0.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 428fb4392466..22dc7b18ebbd 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.940 2013/03/12 11:49:56 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.941 2013/04/04 05:28:56 dirtyepic Exp $
+
+*gcc-4.8.0 (04 Apr 2013)
+
+ 04 Apr 2013; Ryan Hill <dirtyepic@gentoo.org> +gcc-4.8.0.ebuild:
+ Version bump (bug #462736).
12 Mar 2013; Agostino Sarubbo <ago@gentoo.org> gcc-4.6.3.ebuild:
Move back to ~sparc with the acknowledge of the sparc team, because of bug
diff --git a/sys-devel/gcc/gcc-4.8.0.ebuild b/sys-devel/gcc/gcc-4.8.0.ebuild
new file mode 100644
index 000000000000..076e9e62314a
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.8.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.0.ebuild,v 1.1 2013/04/04 05:28:56 dirtyepic Exp $
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.5.5"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 ppc ppc64"
+SSP_STABLE="amd64 x86 ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 ppc ppc64 arm"
+#end Hardened stuff
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection"
+
+LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.2"
+
+KEYWORDS=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_unpack() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ # drop the x32 stuff once 4.7 goes stable
+# if [[ ${CTARGET} != x86_64* ]] || ! has x32 $(get_all_abis TARGET) ; then
+# EPATCH_EXCLUDE+=" 90_all_gcc-4.7-x32.patch"
+# fi
+
+ toolchain_src_unpack
+
+ use vanilla && return 0
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+}
+
+pkg_setup() {
+ toolchain_pkg_setup
+
+ ewarn
+ ewarn "LTO support is still experimental and unstable. Any bug reports"
+ ewarn "about LTO that do not include an upstream patch will be closed as"
+ ewarn "invalid."
+ ewarn
+}
+
+pkg_postinst() {
+ elog
+ elog "Packages failing to build with GCC 4.8 are tracked at"
+ elog "https://bugs.gentoo.org/461954"
+ elog
+}