summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2006-07-18 19:14:32 +0000
committerJavier Villavicencio <the_paya@gentoo.org>2006-07-18 19:14:32 +0000
commitc8393dd3812cdbeba93a2172a29a8ce816ff466b (patch)
tree0a509f335ed141ab6c935b59025656a7472a4368 /sys-freebsd/freebsd-libexec
parentwe now create a gtkrc file with the fallback theme set to gnome. fixes #133241 (diff)
downloadgentoo-2-c8393dd3812cdbeba93a2172a29a8ce816ff466b.tar.gz
gentoo-2-c8393dd3812cdbeba93a2172a29a8ce816ff466b.tar.bz2
gentoo-2-c8393dd3812cdbeba93a2172a29a8ce816ff466b.zip
Fixes compilation with gcc-4.1.1.
(Portage version: 2.1.1_pre3)
Diffstat (limited to 'sys-freebsd/freebsd-libexec')
-rw-r--r--sys-freebsd/freebsd-libexec/ChangeLog6
-rw-r--r--sys-freebsd/freebsd-libexec/files/freebsd-libexec-nossp.patch2
-rw-r--r--sys-freebsd/freebsd-libexec/freebsd-libexec-6.1.ebuild8
3 files changed, 13 insertions, 3 deletions
diff --git a/sys-freebsd/freebsd-libexec/ChangeLog b/sys-freebsd/freebsd-libexec/ChangeLog
index eb49f2635284..67721755a145 100644
--- a/sys-freebsd/freebsd-libexec/ChangeLog
+++ b/sys-freebsd/freebsd-libexec/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-freebsd/freebsd-libexec
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/ChangeLog,v 1.8 2006/05/09 07:36:59 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/ChangeLog,v 1.9 2006/07/18 19:14:32 the_paya Exp $
+
+ 18 Jul 2006; Javier Villavicencio <the_paya@gentoo.org>
+ files/freebsd-libexec-nossp.patch, freebsd-libexec-6.1.ebuild:
+ Fixes compilation with gcc-4.1.1.
*freebsd-libexec-6.1 (09 May 2006)
diff --git a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-nossp.patch b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-nossp.patch
index 44d555a06f9e..541254680964 100644
--- a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-nossp.patch
+++ b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-nossp.patch
@@ -6,7 +6,7 @@ Index: fbsd-6.1/libexec/rtld-elf/Makefile
MAN= rtld.1
CSTD?= gnu99
CFLAGS+= -Wall -DFREEBSD_ELF -DIN_RTLD
-+CFLAGS+= -fno-stack-protector -fno-stack-protector-all
++CFLAGS+= ${NOSSP_FLAGS}
CFLAGS+= -I${.CURDIR}/${MACHINE_ARCH} -I${.CURDIR}
LDFLAGS+= -nostdlib -e .rtld_start
INSTALLFLAGS= -C -b
diff --git a/sys-freebsd/freebsd-libexec/freebsd-libexec-6.1.ebuild b/sys-freebsd/freebsd-libexec/freebsd-libexec-6.1.ebuild
index a5f6a0c0a5b3..f4abbeafaad4 100644
--- a/sys-freebsd/freebsd-libexec/freebsd-libexec-6.1.ebuild
+++ b/sys-freebsd/freebsd-libexec/freebsd-libexec-6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/freebsd-libexec-6.1.ebuild,v 1.1 2006/05/09 07:36:59 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/freebsd-libexec-6.1.ebuild,v 1.2 2006/07/18 19:14:32 the_paya Exp $
inherit bsdmk freebsd pam
@@ -36,6 +36,12 @@ pkg_setup() {
mymakeopts="${mymakeopts} NO_SENDMAIL= NO_PF= "
}
+src_compile() {
+ NOSSP_FLAGS="$(test-flags -fno-stack-protector -fno-stack-protector-all)"
+ export NOSSP_FLAGS
+ freebsd_src_compile
+}
+
PATCHES="${FILESDIR}/${PN}-setXid.patch
${FILESDIR}/${PN}-5.3_rc1-ypxfr-makefile.patch
${FILESDIR}/${PN}-nossp.patch