summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-07-06 05:57:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-07-06 05:57:27 +0000
commit227b4d85f51f2c30e3bb69c1a28d2bd538404033 (patch)
tree168a5b57e6ad16b15a1a7278d899d12561b1ea78 /sys-freebsd
parentadd 8.2 profiles (diff)
downloadgentoo-2-227b4d85f51f2c30e3bb69c1a28d2bd538404033.tar.gz
gentoo-2-227b4d85f51f2c30e3bb69c1a28d2bd538404033.tar.bz2
gentoo-2-227b4d85f51f2c30e3bb69c1a28d2bd538404033.zip
bump to 8.2
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-contrib/ChangeLog10
-rw-r--r--sys-freebsd/freebsd-contrib/freebsd-contrib-8.2.ebuild56
2 files changed, 64 insertions, 2 deletions
diff --git a/sys-freebsd/freebsd-contrib/ChangeLog b/sys-freebsd/freebsd-contrib/ChangeLog
index 9854382832b3..a144eda28785 100644
--- a/sys-freebsd/freebsd-contrib/ChangeLog
+++ b/sys-freebsd/freebsd-contrib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-contrib
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.27 2010/03/19 11:50:58 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.28 2011/07/06 05:57:27 aballier Exp $
+
+*freebsd-contrib-8.2 (06 Jul 2011)
+
+ 06 Jul 2011; Alexis Ballier <aballier@gentoo.org>
+ +freebsd-contrib-8.2.ebuild:
+ bump to 8.2
*freebsd-contrib-8.0 (19 Mar 2010)
diff --git a/sys-freebsd/freebsd-contrib/freebsd-contrib-8.2.ebuild b/sys-freebsd/freebsd-contrib/freebsd-contrib-8.2.ebuild
new file mode 100644
index 000000000000..28e1577fef35
--- /dev/null
+++ b/sys-freebsd/freebsd-contrib/freebsd-contrib-8.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/freebsd-contrib-8.2.ebuild,v 1.1 2011/07/06 05:57:27 aballier Exp $
+
+inherit bsdmk freebsd flag-o-matic
+
+DESCRIPTION="Contributed sources for FreeBSD."
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+LICENSE="BSD GPL-2 as-is"
+
+IUSE=""
+
+SRC_URI="mirror://gentoo/${GNU}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-sources-${RV}*
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+S="${WORKDIR}/gnu"
+
+src_unpack() {
+ echo ">>> Unpacking needed parts of ${GNU}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${GNU}.tar.bz2" gnu/lib/libdialog gnu/usr.bin/sort gnu/usr.bin/patch
+ echo ">>> Unpacking needed parts of ${CONTRIB}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${CONTRIB}.tar.bz2" contrib/gnu-sort
+
+ freebsd_do_patches
+ freebsd_rename_libraries
+}
+
+src_compile() {
+ cd "${S}/lib/libdialog"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/sort"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/patch"
+ freebsd_src_compile
+}
+
+src_install() {
+ use profile || mymakeopts="${mymakeopts} NO_PROFILE= "
+ mymakeopts="${mymakeopts} NO_MANCOMPRESS= NO_INFOCOMPRESS= "
+
+ cd "${S}/lib/libdialog"
+ mkinstall || die "libdialog install failed"
+
+ cd "${S}/usr.bin/sort"
+ mkinstall BINDIR="/bin/" || die "libdialog install failed"
+
+ cd "${S}/usr.bin/patch"
+ mkinstall BINDIR="/usr/bin/" || die "libdialog install failed"
+}