summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-05-09 09:29:08 +0000
committerRoy Marples <uberlord@gentoo.org>2007-05-09 09:29:08 +0000
commit3b6538a94be8679ee5cef48129f192c7e6cc4721 (patch)
treefc7cc8dced1661c881d15e7211cc3d83a5894482 /sys-freebsd
parentFix header. (diff)
downloadgentoo-2-3b6538a94be8679ee5cef48129f192c7e6cc4721.tar.gz
gentoo-2-3b6538a94be8679ee5cef48129f192c7e6cc4721.tar.bz2
gentoo-2-3b6538a94be8679ee5cef48129f192c7e6cc4721.zip
Added a patch to stop DEBUG forcing -O if no COPTFLAGS defined to fix a kernel
panic on boot with sparc64. (Portage version: 2.1.2.7)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-sources/ChangeLog7
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-6.2-debug-O2.patch28
-rw-r--r--sys-freebsd/freebsd-sources/freebsd-sources-6.2.ebuild3
3 files changed, 36 insertions, 2 deletions
diff --git a/sys-freebsd/freebsd-sources/ChangeLog b/sys-freebsd/freebsd-sources/ChangeLog
index 6dad92c01e2c..1b6eccf1f033 100644
--- a/sys-freebsd/freebsd-sources/ChangeLog
+++ b/sys-freebsd/freebsd-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-freebsd/freebsd-sources
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.35 2007/01/15 21:40:03 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.36 2007/05/09 09:29:08 uberlord Exp $
+
+ 09 May 2007; Roy Marples <uberlord@gentoo.org>
+ +files/freebsd-sources-6.2-debug-O2.patch, freebsd-sources-6.2.ebuild:
+ Added a patch to stop DEBUG forcing -O if no COPTFLAGS defined to fix a kernel
+ panic on boot with sparc64.
*freebsd-sources-6.2 (15 Jan 2007)
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-6.2-debug-O2.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-6.2-debug-O2.patch
new file mode 100644
index 000000000000..88a476b92233
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-6.2-debug-O2.patch
@@ -0,0 +1,28 @@
+My UltraSPARC U5 panics on boot about a memory alignment error when compiled
+with gcc4 and -O. Compiling with -O2 fixes this, and it should not adversly
+affect debugging.
+
+NOTE: This does not fix the memory alignment panic when loading kernel modules.
+
+Roy Marples (uberlord@gentoo.org)
+
+diff -ur a/conf/kern.pre.mk b/conf/kern.pre.mk
+--- a/conf/kern.pre.mk 2007-05-06 21:36:18 +0100
++++ b/conf/kern.pre.mk 2007-05-09 09:58:37 +0100
+@@ -19,15 +19,10 @@
+ .if ${CC} == "icc"
+ COPTFLAGS?= -O
+ .else
+-. if defined(DEBUG)
+-_MINUS_O= -O
+-. else
+-_MINUS_O= -O2
+-. endif
+ . if ${MACHINE_ARCH} == "amd64"
+ COPTFLAGS?=-O2 -frename-registers -pipe
+ . else
+-COPTFLAGS?=${_MINUS_O} -pipe
++COPTFLAGS?=-O2 -pipe
+ . endif
+ . if !empty(COPTFLAGS:M-O[23s]) && empty(COPTFLAGS:M-fno-strict-aliasing)
+ COPTFLAGS+= -fno-strict-aliasing
diff --git a/sys-freebsd/freebsd-sources/freebsd-sources-6.2.ebuild b/sys-freebsd/freebsd-sources/freebsd-sources-6.2.ebuild
index e6401b47db76..96628b9fc78f 100644
--- a/sys-freebsd/freebsd-sources/freebsd-sources-6.2.ebuild
+++ b/sys-freebsd/freebsd-sources/freebsd-sources-6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-6.2.ebuild,v 1.1 2007/01/15 21:40:03 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-6.2.ebuild,v 1.2 2007/05/09 09:29:08 uberlord Exp $
inherit bsdmk freebsd flag-o-matic
@@ -40,6 +40,7 @@ src_unpack() {
epatch "${FILESDIR}/${PN}-6.2-gcc41.patch"
epatch "${FILESDIR}/${PN}-6.2-sparc64.patch"
epatch "${FILESDIR}/${PN}-6.1-ntfs.patch"
+ epatch "${FILESDIR}/${PN}-6.2-debug-O2.patch"
# Disable SSP for the kernel
grep -Zlr -- -ffreestanding "${S}" | xargs -0 sed -i -e \