summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-20 18:25:54 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-20 18:25:54 +0000
commit0dfb9f8aab2b045101b91dac66fd1f88d716ba14 (patch)
tree064b5e8b7f0a2d1da7bf25672d4d00ca4d9f5f1c /sys-fs/aufs2
parentppc64 stable wrt #340118 (diff)
downloadgentoo-2-0dfb9f8aab2b045101b91dac66fd1f88d716ba14.tar.gz
gentoo-2-0dfb9f8aab2b045101b91dac66fd1f88d716ba14.tar.bz2
gentoo-2-0dfb9f8aab2b045101b91dac66fd1f88d716ba14.zip
Version Bump, Addud support for fuse and hfs, always build readdir() into libaufs
(Portage version: 2.2.0_alpha18/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/aufs2')
-rw-r--r--sys-fs/aufs2/ChangeLog15
-rw-r--r--sys-fs/aufs2/aufs2-0_p20110120.ebuild118
-rw-r--r--sys-fs/aufs2/files/aufs2-base-31.patch2
-rw-r--r--sys-fs/aufs2/files/aufs2-base-32.patch2
-rw-r--r--sys-fs/aufs2/files/aufs2-base-33.patch2
-rw-r--r--sys-fs/aufs2/files/aufs2-base-34.patch2
-rw-r--r--sys-fs/aufs2/files/aufs2-base-37.patch78
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-31.patch46
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-32.patch46
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-33.patch46
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-34.patch46
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-37.patch289
-rw-r--r--sys-fs/aufs2/metadata.xml2
13 files changed, 682 insertions, 12 deletions
diff --git a/sys-fs/aufs2/ChangeLog b/sys-fs/aufs2/ChangeLog
index 859fbe1fdc05..10d8458d3d15 100644
--- a/sys-fs/aufs2/ChangeLog
+++ b/sys-fs/aufs2/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-fs/aufs2
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.29 2010/12/01 17:35:07 tommy Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.30 2011/01/20 18:25:54 jlec Exp $
+
+*aufs2-0_p20110120 (20 Jan 2011)
+
+ 20 Jan 2011; Justin Lecher <jlec@gentoo.org> +aufs2-0_p20110120.ebuild,
+ files/aufs2-base-31.patch, files/aufs2-standalone-31.patch,
+ files/aufs2-base-32.patch, files/aufs2-standalone-32.patch,
+ files/aufs2-base-33.patch, files/aufs2-standalone-33.patch,
+ files/aufs2-base-34.patch, files/aufs2-standalone-34.patch,
+ +files/aufs2-base-37.patch, +files/aufs2-standalone-37.patch, metadata.xml:
+ Version Bump, Addud support for fuse and hfs, always build readdir() into
+ libaufs
01 Dec 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
files/aufs2-base-35.patch, files/aufs2-standalone-35.patch:
diff --git a/sys-fs/aufs2/aufs2-0_p20110120.ebuild b/sys-fs/aufs2/aufs2-0_p20110120.ebuild
new file mode 100644
index 000000000000..4ce63562d740
--- /dev/null
+++ b/sys-fs/aufs2/aufs2-0_p20110120.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20110120.ebuild,v 1.1 2011/01/20 18:25:54 jlec Exp $
+
+EAPI="2"
+
+inherit linux-mod multilib toolchain-funcs
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fuse inotify hardened hfs kernel-patch nfs ramfs"
+
+DEPEND="dev-vcs/git"
+RDEPEND="!sys-fs/aufs"
+
+S=${WORKDIR}/${PN}-standalone
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ CONFIG_CHECK="${CONFIG_CHECK} ~EXPERIMENTAL"
+ use inotify && CONFIG_CHECK="${CONFIG_CHECK} ~FSNOTIFY"
+ use nfs && CONFIG_CHECK="${CONFIG_CHECK} ~EXPORTFS"
+ use fuse && CONFIG_CHECK="${CONFIG_CHECK} ~FUSE_FS"
+ use hfs && CONFIG_CHECK="${CONFIG_CHECK} ~HFSPLUS_FS"
+
+ # this is needed so merging a binpkg aufs2 is possible w/out a kernel unpacked on the system
+ [ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return
+
+ get_version
+ kernel_is lt 2 6 31 && die "kernel too old"
+ kernel_is gt 2 6 37 && die "kernel too new"
+
+ linux-mod_pkg_setup
+ if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null && \
+ patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null ); then
+ if use kernel-patch; then
+ cd ${KV_DIR}
+ ewarn "Patching your kernel..."
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null
+ epatch "${FILESDIR}"/aufs2-{base,standalone}-${KV_PATCH}.patch
+ elog "You need to compile your kernel with the applied patch"
+ elog "to be able to load and use the aufs kernel module"
+ else
+ eerror "You need to apply a patch to your kernel to compile and run the aufs2 module"
+ eerror "Either enable the kernel-patch useflag to do it with this ebuild"
+ eerror "or apply ${FILESDIR}/aufs2-base-${KV_PATCH}.patch and"
+ eerror "${FILESDIR}/aufs2-standalone-${KV_PATCH}.patch by hand"
+ die "missing kernel patch, please apply it first"
+ fi
+ fi
+ export PKG_SETUP_HAS_BEEN_RAN=1
+}
+
+src_prepare() {
+ local branch=origin/aufs2.1-${KV_PATCH}
+ git checkout -q $branch || die
+ if ! use debug; then
+ sed -i "s:DEBUG = y:DEBUG =:g" config.mk || die
+ fi
+ if use inotify; then
+ sed -i -e "s:AUFS_HNOTIFY =:AUFS_HNOTIFY = y:g" \
+ -e "s:AUFS_HFSNOTIFY =:AUFS_HFSNOTIFY = y:g" config.mk || die
+ fi
+ if use ramfs; then
+ sed -i "s:RAMFS =:RAMFS = y:g" config.mk || die
+ fi
+
+ sed -i "s:AUFS_RDU =:AUFS_RDU = y:g" config.mk || die
+
+ if use fuse; then
+ sed \
+ -e "s:AUFS_BR_FUSE =:AUFS_BR_FUSE = y:g" \
+ -e "s:AUFS_POLL =:AUFS_POLL = y:g" \
+ -i config.mk || die
+ fi
+
+ if use hfs; then
+ sed -i "s:AUFS_BR_FUSE =:AUFS_BR_FUSE = y:g" config.mk || die
+ fi
+
+ if use hardened ; then
+ epatch "${FILESDIR}"/pax.patch
+ fi
+
+ sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
+ sed -i "s:__user::g" include/linux/aufs_type.h || die
+ cd "${WORKDIR}"/${PN}-util
+ git checkout -q origin/aufs2.1
+ sed -i "/LDFLAGS += -static -s/d" Makefile || die
+ sed -i -e "s:m 644 -s:m 644:g" -e "s:/usr/lib:/usr/$(get_libdir):g" libau/Makefile || die
+}
+
+src_compile() {
+ local myargs="" ARCH=x86
+ use nfs && myargs="CONFIG_EXPORTFS=y CONFIG_AUFS_EXPORT=y "
+ use nfs && use amd64 && myargs+="CONFIG_AUFS_INO_T_64=y"
+ emake CC=$(tc-getCC) CONFIG_AUFS_FS=m ${myargs} KDIR=${KV_DIR} || die
+ cd "${WORKDIR}"/${PN}-util
+ emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_DIR} C_INCLUDE_PATH="${S}"/include || die
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README || die
+ docinto design
+ dodoc design/*.txt || die
+ cd "${WORKDIR}"/${PN}-util
+ emake DESTDIR="${D}" KDIR=${KV_DIR} install || die
+ docinto
+ newdoc README README-utils || die
+}
diff --git a/sys-fs/aufs2/files/aufs2-base-31.patch b/sys-fs/aufs2/files/aufs2-base-31.patch
index 7b26e3e44ac3..2d938a49ffca 100644
--- a/sys-fs/aufs2/files/aufs2-base-31.patch
+++ b/sys-fs/aufs2/files/aufs2-base-31.patch
@@ -1,4 +1,4 @@
-aufs2 base patch for linux-2.6.31
+aufs2.1 base patch for linux-2.6.31
diff --git a/fs/namei.c b/fs/namei.c
index 1f13751..b49c2af 100644
diff --git a/sys-fs/aufs2/files/aufs2-base-32.patch b/sys-fs/aufs2/files/aufs2-base-32.patch
index b8db42f2ac1c..ef1215539d93 100644
--- a/sys-fs/aufs2/files/aufs2-base-32.patch
+++ b/sys-fs/aufs2/files/aufs2-base-32.patch
@@ -1,4 +1,4 @@
-aufs2 base patch for linux-2.6.32
+aufs2.1 base patch for linux-2.6.32
diff --git a/fs/namei.c b/fs/namei.c
index d11f404..7d28f56 100644
diff --git a/sys-fs/aufs2/files/aufs2-base-33.patch b/sys-fs/aufs2/files/aufs2-base-33.patch
index 2ec0d397433f..fbb1f77249f1 100644
--- a/sys-fs/aufs2/files/aufs2-base-33.patch
+++ b/sys-fs/aufs2/files/aufs2-base-33.patch
@@ -1,4 +1,4 @@
-aufs2 base patch for linux-2.6.33
+aufs2.1 base patch for linux-2.6.33
diff --git a/fs/namei.c b/fs/namei.c
index a4855af..1d12d37 100644
diff --git a/sys-fs/aufs2/files/aufs2-base-34.patch b/sys-fs/aufs2/files/aufs2-base-34.patch
index 57e37f64ed1d..f586b13de731 100644
--- a/sys-fs/aufs2/files/aufs2-base-34.patch
+++ b/sys-fs/aufs2/files/aufs2-base-34.patch
@@ -1,4 +1,4 @@
-aufs2 base patch for linux-2.6.34
+aufs2.1 base patch for linux-2.6.34
diff --git a/fs/namei.c b/fs/namei.c
index b86b96f..c43d6b8 100644
diff --git a/sys-fs/aufs2/files/aufs2-base-37.patch b/sys-fs/aufs2/files/aufs2-base-37.patch
new file mode 100644
index 000000000000..5beda6d478f2
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-base-37.patch
@@ -0,0 +1,78 @@
+aufs2.1 base patch for linux-2.6.37
+
+diff --git a/fs/namei.c b/fs/namei.c
+index 4ff7ca5..a8c583f 100644
+--- a/fs/namei.c
++++ b/fs/namei.c
+@@ -1161,12 +1161,12 @@ out:
+ * needs parent already locked. Doesn't follow mounts.
+ * SMP-safe.
+ */
+-static struct dentry *lookup_hash(struct nameidata *nd)
++struct dentry *lookup_hash(struct nameidata *nd)
+ {
+ return __lookup_hash(&nd->last, nd->path.dentry, nd);
+ }
+
+-static int __lookup_one_len(const char *name, struct qstr *this,
++int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len)
+ {
+ unsigned long hash;
+diff --git a/fs/splice.c b/fs/splice.c
+index ce2f025..ff0ae69 100644
+--- a/fs/splice.c
++++ b/fs/splice.c
+@@ -1092,8 +1092,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
+ /*
+ * Attempt to initiate a splice from pipe to file.
+ */
+-static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+- loff_t *ppos, size_t len, unsigned int flags)
++long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags)
+ {
+ ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
+ loff_t *, size_t, unsigned int);
+@@ -1120,9 +1120,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+ /*
+ * Attempt to initiate a splice from a file to a pipe.
+ */
+-static long do_splice_to(struct file *in, loff_t *ppos,
+- struct pipe_inode_info *pipe, size_t len,
+- unsigned int flags)
++long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags)
+ {
+ ssize_t (*splice_read)(struct file *, loff_t *,
+ struct pipe_inode_info *, size_t, unsigned int);
+diff --git a/include/linux/namei.h b/include/linux/namei.h
+index 05b441d..91bc74e 100644
+--- a/include/linux/namei.h
++++ b/include/linux/namei.h
+@@ -73,6 +73,9 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
+ extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry *dentry,
+ int (*open)(struct inode *, struct file *));
+
++extern struct dentry *lookup_hash(struct nameidata *nd);
++extern int __lookup_one_len(const char *name, struct qstr *this,
++ struct dentry *base, int len);
+ extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
+
+ extern int follow_down(struct path *);
+diff --git a/include/linux/splice.h b/include/linux/splice.h
+index 997c3b4..be9a153 100644
+--- a/include/linux/splice.h
++++ b/include/linux/splice.h
+@@ -89,4 +89,10 @@ extern int splice_grow_spd(struct pipe_inode_info *, struct splice_pipe_desc *);
+ extern void splice_shrink_spd(struct pipe_inode_info *,
+ struct splice_pipe_desc *);
+
++extern long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags);
++extern long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags);
++
+ #endif
diff --git a/sys-fs/aufs2/files/aufs2-standalone-31.patch b/sys-fs/aufs2/files/aufs2-standalone-31.patch
index 44f8e59ebf91..d2d5d94b0b7e 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-31.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-31.patch
@@ -1,5 +1,37 @@
-aufs2 standalone patch for linux-2.6.31
+aufs2.1 standalone patch for linux-2.6.31
+diff --git a/fs/file_table.c b/fs/file_table.c
+index 334ce39..c024dda 100644
+--- a/fs/file_table.c
++++ b/fs/file_table.c
+@@ -32,6 +32,7 @@ struct files_stat_struct files_stat = {
+
+ /* public. Not pretty! */
+ __cacheline_aligned_in_smp DEFINE_SPINLOCK(files_lock);
++EXPORT_SYMBOL(files_lock);
+
+ /* SLAB cache for file structures */
+ static struct kmem_cache *filp_cachep __read_mostly;
+@@ -374,6 +375,7 @@ void file_kill(struct file *file)
+ file_list_unlock();
+ }
+ }
++EXPORT_SYMBOL(file_kill);
+
+ int fs_may_remount_ro(struct super_block *sb)
+ {
+diff --git a/fs/inode.c b/fs/inode.c
+index ae7b67e..8ad34b1 100644
+--- a/fs/inode.c
++++ b/fs/inode.c
+@@ -85,6 +85,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
+ * the i_state of an inode while it is in use..
+ */
+ DEFINE_SPINLOCK(inode_lock);
++EXPORT_SYMBOL(inode_lock);
+
+ /*
+ * iprune_mutex provides exclusion between the kswapd or try_to_free_pages
diff --git a/fs/namei.c b/fs/namei.c
index b49c2af..4521c70 100644
--- a/fs/namei.c
@@ -141,6 +173,18 @@ index 0cb8873..0e7b0b9 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
+diff --git a/lib/debug_locks.c b/lib/debug_locks.c
+index bc3b117..9f981cf 100644
+--- a/lib/debug_locks.c
++++ b/lib/debug_locks.c
+@@ -23,6 +23,7 @@
+ * shut up after that.
+ */
+ int debug_locks = 1;
++EXPORT_SYMBOL(debug_locks);
+
+ /*
+ * The locking-testsuite uses <debug_locks_silent> to get a
diff --git a/security/commoncap.c b/security/commoncap.c
index e3097c0..96f9a66 100644
--- a/security/commoncap.c
diff --git a/sys-fs/aufs2/files/aufs2-standalone-32.patch b/sys-fs/aufs2/files/aufs2-standalone-32.patch
index 5409830688ec..ee479188767f 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-32.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-32.patch
@@ -1,5 +1,37 @@
-aufs2 standalone patch for linux-2.6.32
+aufs2.1 standalone patch for linux-2.6.32
+diff --git a/fs/file_table.c b/fs/file_table.c
+index 8eb4404..9e6d946 100644
+--- a/fs/file_table.c
++++ b/fs/file_table.c
+@@ -32,6 +32,7 @@ struct files_stat_struct files_stat = {
+
+ /* public. Not pretty! */
+ __cacheline_aligned_in_smp DEFINE_SPINLOCK(files_lock);
++EXPORT_SYMBOL(files_lock);
+
+ /* SLAB cache for file structures */
+ static struct kmem_cache *filp_cachep __read_mostly;
+@@ -374,6 +375,7 @@ void file_kill(struct file *file)
+ file_list_unlock();
+ }
+ }
++EXPORT_SYMBOL(file_kill);
+
+ int fs_may_remount_ro(struct super_block *sb)
+ {
+diff --git a/fs/inode.c b/fs/inode.c
+index 4d8e3be..d6fa35c 100644
+--- a/fs/inode.c
++++ b/fs/inode.c
+@@ -86,6 +86,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
+ * the i_state of an inode while it is in use..
+ */
+ DEFINE_SPINLOCK(inode_lock);
++EXPORT_SYMBOL(inode_lock);
+
+ /*
+ * iprune_sem provides exclusion between the kswapd or try_to_free_pages
diff --git a/fs/namei.c b/fs/namei.c
index 7d28f56..0f6117c 100644
--- a/fs/namei.c
@@ -141,6 +173,18 @@ index 77184f0..8479d95 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
+diff --git a/lib/debug_locks.c b/lib/debug_locks.c
+index bc3b117..9f981cf 100644
+--- a/lib/debug_locks.c
++++ b/lib/debug_locks.c
+@@ -23,6 +23,7 @@
+ * shut up after that.
+ */
+ int debug_locks = 1;
++EXPORT_SYMBOL(debug_locks);
+
+ /*
+ * The locking-testsuite uses <debug_locks_silent> to get a
diff --git a/security/commoncap.c b/security/commoncap.c
index fe30751..813108d 100644
--- a/security/commoncap.c
diff --git a/sys-fs/aufs2/files/aufs2-standalone-33.patch b/sys-fs/aufs2/files/aufs2-standalone-33.patch
index c945ba15edcd..d54855183df5 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-33.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-33.patch
@@ -1,5 +1,37 @@
-aufs2 standalone patch for linux-2.6.33
+aufs2.1 standalone patch for linux-2.6.33
+diff --git a/fs/file_table.c b/fs/file_table.c
+index b98404b..d57f6a2 100644
+--- a/fs/file_table.c
++++ b/fs/file_table.c
+@@ -34,6 +34,7 @@ struct files_stat_struct files_stat = {
+
+ /* public. Not pretty! */
+ __cacheline_aligned_in_smp DEFINE_SPINLOCK(files_lock);
++EXPORT_SYMBOL(files_lock);
+
+ /* SLAB cache for file structures */
+ static struct kmem_cache *filp_cachep __read_mostly;
+@@ -347,6 +348,7 @@ void file_kill(struct file *file)
+ file_list_unlock();
+ }
+ }
++EXPORT_SYMBOL(file_kill);
+
+ int fs_may_remount_ro(struct super_block *sb)
+ {
+diff --git a/fs/inode.c b/fs/inode.c
+index 03dfeb2..7bcf82a 100644
+--- a/fs/inode.c
++++ b/fs/inode.c
+@@ -85,6 +85,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
+ * the i_state of an inode while it is in use..
+ */
+ DEFINE_SPINLOCK(inode_lock);
++EXPORT_SYMBOL(inode_lock);
+
+ /*
+ * iprune_sem provides exclusion between the kswapd or try_to_free_pages
diff --git a/fs/namei.c b/fs/namei.c
index 1d12d37..7cb8e5d 100644
--- a/fs/namei.c
@@ -141,6 +173,18 @@ index b13a9a2..3931ee0 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
+diff --git a/lib/debug_locks.c b/lib/debug_locks.c
+index bc3b117..9f981cf 100644
+--- a/lib/debug_locks.c
++++ b/lib/debug_locks.c
+@@ -23,6 +23,7 @@
+ * shut up after that.
+ */
+ int debug_locks = 1;
++EXPORT_SYMBOL(debug_locks);
+
+ /*
+ * The locking-testsuite uses <debug_locks_silent> to get a
diff --git a/security/commoncap.c b/security/commoncap.c
index f800fdb..ea457bc 100644
--- a/security/commoncap.c
diff --git a/sys-fs/aufs2/files/aufs2-standalone-34.patch b/sys-fs/aufs2/files/aufs2-standalone-34.patch
index c219578b5a21..ebaa2c6b84b3 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-34.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-34.patch
@@ -1,5 +1,37 @@
-aufs2 standalone patch for linux-2.6.34
+aufs2.1 standalone patch for linux-2.6.34
+diff --git a/fs/file_table.c b/fs/file_table.c
+index 32d12b7..6284a6c 100644
+--- a/fs/file_table.c
++++ b/fs/file_table.c
+@@ -34,6 +34,7 @@ struct files_stat_struct files_stat = {
+
+ /* public. Not pretty! */
+ __cacheline_aligned_in_smp DEFINE_SPINLOCK(files_lock);
++EXPORT_SYMBOL(files_lock);
+
+ /* SLAB cache for file structures */
+ static struct kmem_cache *filp_cachep __read_mostly;
+@@ -347,6 +348,7 @@ void file_kill(struct file *file)
+ file_list_unlock();
+ }
+ }
++EXPORT_SYMBOL(file_kill);
+
+ int fs_may_remount_ro(struct super_block *sb)
+ {
+diff --git a/fs/inode.c b/fs/inode.c
+index 407bf39..9f6d598 100644
+--- a/fs/inode.c
++++ b/fs/inode.c
+@@ -84,6 +84,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
+ * the i_state of an inode while it is in use..
+ */
+ DEFINE_SPINLOCK(inode_lock);
++EXPORT_SYMBOL(inode_lock);
+
+ /*
+ * iprune_sem provides exclusion between the kswapd or try_to_free_pages
diff --git a/fs/namei.c b/fs/namei.c
index c43d6b8..538d40a 100644
--- a/fs/namei.c
@@ -29,10 +61,18 @@ index c43d6b8..538d40a 100644
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
-index f20cb57..7cc1b42 100644
+index f20cb57..5a28470 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
-@@ -1282,6 +1282,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
+@@ -39,6 +39,7 @@
+
+ /* spinlock for vfsmount related operations, inplace of dcache_lock */
+ __cacheline_aligned_in_smp DEFINE_SPINLOCK(vfsmount_lock);
++EXPORT_SYMBOL(vfsmount_lock);
+
+ static int event;
+ static DEFINE_IDA(mnt_id_ida);
+@@ -1282,6 +1283,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
diff --git a/sys-fs/aufs2/files/aufs2-standalone-37.patch b/sys-fs/aufs2/files/aufs2-standalone-37.patch
new file mode 100644
index 000000000000..fa2b70e01906
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-standalone-37.patch
@@ -0,0 +1,289 @@
+aufs2.1 standalone patch for linux-2.6.37
+
+diff --git a/fs/file_table.c b/fs/file_table.c
+index c3dee38..f529e4d 100644
+--- a/fs/file_table.c
++++ b/fs/file_table.c
+@@ -393,6 +393,8 @@ void file_sb_list_del(struct file *file)
+ }
+ }
+
++EXPORT_SYMBOL(file_sb_list_del);
++
+ #ifdef CONFIG_SMP
+
+ /*
+diff --git a/fs/inode.c b/fs/inode.c
+index ae2727a..2c8071a 100644
+--- a/fs/inode.c
++++ b/fs/inode.c
+@@ -82,6 +82,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
+ * the i_state of an inode while it is in use..
+ */
+ DEFINE_SPINLOCK(inode_lock);
++EXPORT_SYMBOL(inode_lock);
+
+ /*
+ * iprune_sem provides exclusion between the kswapd or try_to_free_pages
+diff --git a/fs/namei.c b/fs/namei.c
+index a8c583f..b020c45 100644
+--- a/fs/namei.c
++++ b/fs/namei.c
+@@ -347,6 +347,7 @@ int deny_write_access(struct file * file)
+
+ return 0;
+ }
++EXPORT_SYMBOL(deny_write_access);
+
+ /**
+ * path_get - get a reference to a path
+@@ -1165,6 +1166,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
+ {
+ return __lookup_hash(&nd->last, nd->path.dentry, nd);
+ }
++EXPORT_SYMBOL(lookup_hash);
+
+ int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len)
+@@ -1187,6 +1189,7 @@ int __lookup_one_len(const char *name, struct qstr *this,
+ this->hash = end_name_hash(hash);
+ return 0;
+ }
++EXPORT_SYMBOL(__lookup_one_len);
+
+ /**
+ * lookup_one_len - filesystem helper to lookup single pathname component
+diff --git a/fs/namespace.c b/fs/namespace.c
+index 3dbfc07..3998762 100644
+--- a/fs/namespace.c
++++ b/fs/namespace.c
+@@ -1321,6 +1321,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
+ }
+ return 0;
+ }
++EXPORT_SYMBOL(iterate_mounts);
+
+ static void cleanup_group_ids(struct vfsmount *mnt, struct vfsmount *end)
+ {
+diff --git a/fs/notify/group.c b/fs/notify/group.c
+index d309f38..f0e9568 100644
+--- a/fs/notify/group.c
++++ b/fs/notify/group.c
+@@ -22,6 +22,7 @@
+ #include <linux/srcu.h>
+ #include <linux/rculist.h>
+ #include <linux/wait.h>
++#include <linux/module.h>
+
+ #include <linux/fsnotify_backend.h>
+ #include "fsnotify.h"
+@@ -70,6 +71,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
+ if (atomic_dec_and_test(&group->refcnt))
+ fsnotify_destroy_group(group);
+ }
++EXPORT_SYMBOL(fsnotify_put_group);
+
+ /*
+ * Create a new fsnotify_group and hold a reference for the group returned.
+@@ -102,3 +104,4 @@ struct fsnotify_group *fsnotify_alloc_group(const struct fsnotify_ops *ops)
+
+ return group;
+ }
++EXPORT_SYMBOL(fsnotify_alloc_group);
+diff --git a/fs/notify/mark.c b/fs/notify/mark.c
+index 325185e..adede09 100644
+--- a/fs/notify/mark.c
++++ b/fs/notify/mark.c
+@@ -113,6 +113,7 @@ void fsnotify_put_mark(struct fsnotify_mark *mark)
+ if (atomic_dec_and_test(&mark->refcnt))
+ mark->free_mark(mark);
+ }
++EXPORT_SYMBOL(fsnotify_put_mark);
+
+ /*
+ * Any time a mark is getting freed we end up here.
+@@ -190,6 +191,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark)
+ if (unlikely(atomic_dec_and_test(&group->num_marks)))
+ fsnotify_final_destroy_group(group);
+ }
++EXPORT_SYMBOL(fsnotify_destroy_mark);
+
+ void fsnotify_set_mark_mask_locked(struct fsnotify_mark *mark, __u32 mask)
+ {
+@@ -277,6 +279,7 @@ err:
+
+ return ret;
+ }
++EXPORT_SYMBOL(fsnotify_add_mark);
+
+ /*
+ * clear any marks in a group in which mark->flags & flags is true
+@@ -332,6 +335,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
+ atomic_set(&mark->refcnt, 1);
+ mark->free_mark = free_mark;
+ }
++EXPORT_SYMBOL(fsnotify_init_mark);
+
+ static int fsnotify_mark_destroy(void *ignored)
+ {
+diff --git a/fs/open.c b/fs/open.c
+index 4197b9e..912817a 100644
+--- a/fs/open.c
++++ b/fs/open.c
+@@ -60,6 +60,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
+ mutex_unlock(&dentry->d_inode->i_mutex);
+ return ret;
+ }
++EXPORT_SYMBOL(do_truncate);
+
+ static long do_sys_truncate(const char __user *pathname, loff_t length)
+ {
+diff --git a/fs/splice.c b/fs/splice.c
+index ff0ae69..1c9e9b0 100644
+--- a/fs/splice.c
++++ b/fs/splice.c
+@@ -1116,6 +1116,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+
+ return splice_write(pipe, out, ppos, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_from);
+
+ /*
+ * Attempt to initiate a splice from a file to a pipe.
+@@ -1142,6 +1143,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
+
+ return splice_read(in, ppos, pipe, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_to);
+
+ /**
+ * splice_direct_to_actor - splices data directly between two non-pipes
+diff --git a/security/commoncap.c b/security/commoncap.c
+index 64c2ed9..e58b5d8 100644
+--- a/security/commoncap.c
++++ b/security/commoncap.c
+@@ -929,3 +929,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
+ }
+ return ret;
+ }
++EXPORT_SYMBOL(cap_file_mmap);
+diff --git a/security/device_cgroup.c b/security/device_cgroup.c
+index 8d9c48f..29108aa 100644
+--- a/security/device_cgroup.c
++++ b/security/device_cgroup.c
+@@ -515,6 +515,7 @@ found:
+
+ return -EPERM;
+ }
++EXPORT_SYMBOL(devcgroup_inode_permission);
+
+ int devcgroup_inode_mknod(int mode, dev_t dev)
+ {
+diff --git a/security/security.c b/security/security.c
+index 1b798d3..3b7d2ca 100644
+--- a/security/security.c
++++ b/security/security.c
+@@ -360,6 +360,7 @@ int security_path_mkdir(struct path *dir, struct dentry *dentry, int mode)
+ return 0;
+ return security_ops->path_mkdir(dir, dentry, mode);
+ }
++EXPORT_SYMBOL(security_path_mkdir);
+
+ int security_path_rmdir(struct path *dir, struct dentry *dentry)
+ {
+@@ -367,6 +368,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
+ return 0;
+ return security_ops->path_rmdir(dir, dentry);
+ }
++EXPORT_SYMBOL(security_path_rmdir);
+
+ int security_path_unlink(struct path *dir, struct dentry *dentry)
+ {
+@@ -374,6 +376,7 @@ int security_path_unlink(struct path *dir, struct dentry *dentry)
+ return 0;
+ return security_ops->path_unlink(dir, dentry);
+ }
++EXPORT_SYMBOL(security_path_unlink);
+
+ int security_path_symlink(struct path *dir, struct dentry *dentry,
+ const char *old_name)
+@@ -382,6 +385,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
+ return 0;
+ return security_ops->path_symlink(dir, dentry, old_name);
+ }
++EXPORT_SYMBOL(security_path_symlink);
+
+ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+ struct dentry *new_dentry)
+@@ -390,6 +394,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+ return 0;
+ return security_ops->path_link(old_dentry, new_dir, new_dentry);
+ }
++EXPORT_SYMBOL(security_path_link);
+
+ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
+ struct path *new_dir, struct dentry *new_dentry)
+@@ -400,6 +405,7 @@ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
+ return security_ops->path_rename(old_dir, old_dentry, new_dir,
+ new_dentry);
+ }
++EXPORT_SYMBOL(security_path_rename);
+
+ int security_path_truncate(struct path *path)
+ {
+@@ -407,6 +413,7 @@ int security_path_truncate(struct path *path)
+ return 0;
+ return security_ops->path_truncate(path);
+ }
++EXPORT_SYMBOL(security_path_truncate);
+
+ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
+ mode_t mode)
+@@ -415,6 +422,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
+ return 0;
+ return security_ops->path_chmod(dentry, mnt, mode);
+ }
++EXPORT_SYMBOL(security_path_chmod);
+
+ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
+ {
+@@ -422,6 +430,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
+ return 0;
+ return security_ops->path_chown(path, uid, gid);
+ }
++EXPORT_SYMBOL(security_path_chown);
+
+ int security_path_chroot(struct path *path)
+ {
+@@ -498,6 +507,7 @@ int security_inode_readlink(struct dentry *dentry)
+ return 0;
+ return security_ops->inode_readlink(dentry);
+ }
++EXPORT_SYMBOL(security_inode_readlink);
+
+ int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
+ {
+@@ -512,6 +522,7 @@ int security_inode_permission(struct inode *inode, int mask)
+ return 0;
+ return security_ops->inode_permission(inode, mask);
+ }
++EXPORT_SYMBOL(security_inode_permission);
+
+ int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
+ {
+@@ -611,6 +622,7 @@ int security_file_permission(struct file *file, int mask)
+
+ return fsnotify_perm(file, mask);
+ }
++EXPORT_SYMBOL(security_file_permission);
+
+ int security_file_alloc(struct file *file)
+ {
+@@ -638,6 +650,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
+ return ret;
+ return ima_file_mmap(file, prot);
+ }
++EXPORT_SYMBOL(security_file_mmap);
+
+ int security_file_mprotect(struct vm_area_struct *vma, unsigned long reqprot,
+ unsigned long prot)
diff --git a/sys-fs/aufs2/metadata.xml b/sys-fs/aufs2/metadata.xml
index 3cc038886cb1..d70d1c71d803 100644
--- a/sys-fs/aufs2/metadata.xml
+++ b/sys-fs/aufs2/metadata.xml
@@ -14,5 +14,7 @@
<flag name='kernel-patch'>Patch the current kernel for aufs2 support</flag>
<flag name='nfs'>Enable support for nfs export</flag>
<flag name='ramfs'>Enable initramfs/rootfs support</flag>
+ <flag name='fuse'>Enable fuse support</flag>
+ <flag name='hfs'>Enable hfs support</flag>
</use>
</pkgmetadata>