summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-06 08:33:14 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-06 08:33:14 +0000
commit0f6db98755a6af57f3c8ce23db04fdeb45d402ac (patch)
treefe62b4f90a535b94e8f0b37092a02aa7b6500835 /sys-fs/aufs2
parentVersion bump (diff)
downloadgentoo-2-0f6db98755a6af57f3c8ce23db04fdeb45d402ac.tar.gz
gentoo-2-0f6db98755a6af57f3c8ce23db04fdeb45d402ac.tar.bz2
gentoo-2-0f6db98755a6af57f3c8ce23db04fdeb45d402ac.zip
Fixed wrong setting for HFS support, #357303; rewrite config setter
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/aufs2')
-rw-r--r--sys-fs/aufs2/ChangeLog8
-rw-r--r--sys-fs/aufs2/aufs2-0_p20110120-r1.ebuild116
-rw-r--r--sys-fs/aufs2/aufs2-0_p20110120.ebuild4
3 files changed, 125 insertions, 3 deletions
diff --git a/sys-fs/aufs2/ChangeLog b/sys-fs/aufs2/ChangeLog
index 15a6529f4293..29b6135e7d79 100644
--- a/sys-fs/aufs2/ChangeLog
+++ b/sys-fs/aufs2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/aufs2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.33 2011/02/27 13:09:23 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.34 2011/03/06 08:33:14 jlec Exp $
+
+*aufs2-0_p20110120-r1 (06 Mar 2011)
+
+ 06 Mar 2011; Justin Lecher <jlec@gentoo.org> aufs2-0_p20110120.ebuild,
+ +aufs2-0_p20110120-r1.ebuild:
+ Fixed wrong setting for HFS support, #357303; rewrite config setter
27 Feb 2011; Justin Lecher <jlec@gentoo.org> aufs2-0_p20100809.ebuild,
aufs2-0_p20101122.ebuild, aufs2-0_p20110120.ebuild, metadata.xml:
diff --git a/sys-fs/aufs2/aufs2-0_p20110120-r1.ebuild b/sys-fs/aufs2/aufs2-0_p20110120-r1.ebuild
new file mode 100644
index 000000000000..c715edecec92
--- /dev/null
+++ b/sys-fs/aufs2/aufs2-0_p20110120-r1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20110120-r1.ebuild,v 1.1 2011/03/06 08:33:14 jlec Exp $
+
+EAPI="4"
+
+inherit linux-mod multilib toolchain-funcs
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fuse hardened hfs inotify kernel-patch nfs ramfs"
+
+DEPEND="dev-vcs/git"
+RDEPEND="!sys-fs/aufs"
+
+S="${WORKDIR}"/${PN}-standalone
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ CONFIG_CHECK="${CONFIG_CHECK} ~EXPERIMENTAL"
+ use inotify && CONFIG_CHECK="${CONFIG_CHECK} ~FSNOTIFY"
+ use nfs && CONFIG_CHECK="${CONFIG_CHECK} ~EXPORTFS"
+ use fuse && CONFIG_CHECK="${CONFIG_CHECK} ~FUSE_FS"
+ use hfs && CONFIG_CHECK="${CONFIG_CHECK} ~HFSPLUS_FS"
+
+ # this is needed so merging a binpkg aufs2 is possible w/out a kernel unpacked on the system
+ [ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return
+
+ get_version
+ kernel_is lt 2 6 31 && die "kernel too old"
+ kernel_is gt 2 6 37 && die "kernel too new"
+
+ linux-mod_pkg_setup
+ if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null && \
+ patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null ); then
+ if use kernel-patch; then
+ cd ${KV_DIR}
+ ewarn "Patching your kernel..."
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null
+ epatch "${FILESDIR}"/aufs2-{base,standalone}-${KV_PATCH}.patch
+ ewarn "You need to compile your kernel with the applied patch"
+ ewarn "to be able to load and use the aufs kernel module"
+ else
+ eerror "You need to apply a patch to your kernel to compile and run the aufs2 module"
+ eerror "Either enable the kernel-patch useflag to do it with this ebuild"
+ eerror "or apply ${FILESDIR}/aufs2-base-${KV_PATCH}.patch and"
+ eerror "${FILESDIR}/aufs2-standalone-${KV_PATCH}.patch by hand"
+ die "missing kernel patch, please apply it first"
+ fi
+ fi
+ export PKG_SETUP_HAS_BEEN_RAN=1
+}
+
+set_config() {
+ for option in $*; do
+ grep -q "^CONFIG_AUFS_${option} =" config.mk || die "${option} is not a valid config option"
+ sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
+ done
+}
+
+src_prepare() {
+ local branch=origin/aufs2.1-${KV_PATCH}
+ git checkout -q $branch || die
+
+ # All config options to off
+ sed "s:= y:=:g" -i config.mk || die
+
+ set_config RDU BRANCH_MAX_127 SBILIST
+
+ use debug && set_config DEBUG
+ use fuse && set_config BR_FUSE POLL
+ use hfs && set_config BR_HFSPLUS
+ use inotify && set_config HNOTIFY HFSNOTIFY
+ use nfs && set_config EXPORT
+ use nfs && use amd64 && set_config INO_T_64
+ use ramfs && set_config BR_RAMFS
+
+ if use hardened ; then
+ epatch "${FILESDIR}"/pax.patch
+ fi
+
+ sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
+ sed -i "s:__user::g" include/linux/aufs_type.h || die
+
+ cd "${WORKDIR}"/${PN}-util
+ git checkout -q origin/aufs2.1
+ sed -i "/LDFLAGS += -static -s/d" Makefile || die
+ sed -i -e "s:m 644 -s:m 644:g" -e "s:/usr/lib:/usr/$(get_libdir):g" libau/Makefile || die
+}
+
+src_compile() {
+ local ARCH=x86
+
+ emake CC=$(tc-getCC) CONFIG_AUFS_FS=m KDIR=${KV_DIR} || die
+
+ cd "${WORKDIR}"/${PN}-util
+ emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_DIR} C_INCLUDE_PATH="${S}"/include || die
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README || die
+ docinto design
+ dodoc design/*.txt || die
+ cd "${WORKDIR}"/${PN}-util
+ emake DESTDIR="${D}" KDIR=${KV_DIR} install || die
+ docinto
+ newdoc README README-utils || die
+}
diff --git a/sys-fs/aufs2/aufs2-0_p20110120.ebuild b/sys-fs/aufs2/aufs2-0_p20110120.ebuild
index 809cf97bcbfd..ed0085aaec3a 100644
--- a/sys-fs/aufs2/aufs2-0_p20110120.ebuild
+++ b/sys-fs/aufs2/aufs2-0_p20110120.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20110120.ebuild,v 1.3 2011/02/27 13:09:23 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20110120.ebuild,v 1.4 2011/03/06 08:33:14 jlec Exp $
EAPI="2"
@@ -84,7 +84,7 @@ src_prepare() {
fi
if use hfs; then
- sed -i "s:AUFS_BR_FUSE =:AUFS_BR_FUSE = y:g" config.mk || die
+ sed -i "s:AUFS_BR_HFSPLUS =:AUFS_BR_HFSPLUS = y:g" config.mk || die
fi
if use hardened ; then