summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-02-27 13:09:23 +0000
committerJustin Lecher <jlec@gentoo.org>2011-02-27 13:09:23 +0000
commit930dc3088517bcf3c3081159fcaab5b29235ab4b (patch)
tree619e8c3cf12c944a0c3adc8c9425a4a6067d4054 /sys-fs/aufs2
parentAdd a patch to pass libs as last argument to the linker when linking, fixes o... (diff)
downloadgentoo-2-930dc3088517bcf3c3081159fcaab5b29235ab4b.tar.gz
gentoo-2-930dc3088517bcf3c3081159fcaab5b29235ab4b.tar.bz2
gentoo-2-930dc3088517bcf3c3081159fcaab5b29235ab4b.zip
Increase Warning level for rebuilding kernel with patches, #356267; Changed to me as the primary maintainer
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/aufs2')
-rw-r--r--sys-fs/aufs2/ChangeLog7
-rw-r--r--sys-fs/aufs2/aufs2-0_p20100809.ebuild8
-rw-r--r--sys-fs/aufs2/aufs2-0_p20101122.ebuild8
-rw-r--r--sys-fs/aufs2/aufs2-0_p20110120.ebuild6
-rw-r--r--sys-fs/aufs2/metadata.xml4
5 files changed, 19 insertions, 14 deletions
diff --git a/sys-fs/aufs2/ChangeLog b/sys-fs/aufs2/ChangeLog
index 75ecec59cae9..15a6529f4293 100644
--- a/sys-fs/aufs2/ChangeLog
+++ b/sys-fs/aufs2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/aufs2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.32 2011/01/21 07:37:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.33 2011/02/27 13:09:23 jlec Exp $
+
+ 27 Feb 2011; Justin Lecher <jlec@gentoo.org> aufs2-0_p20100809.ebuild,
+ aufs2-0_p20101122.ebuild, aufs2-0_p20110120.ebuild, metadata.xml:
+ Increase Warning level for rebuilding kernel with patches, #356267; Changed
+ to me as the primary maintainer
21 Jan 2011; Justin Lecher <jlec@gentoo.org> aufs2-0_p20110120.ebuild:
Mirror the distfiles
diff --git a/sys-fs/aufs2/aufs2-0_p20100809.ebuild b/sys-fs/aufs2/aufs2-0_p20100809.ebuild
index 889fced12fbc..11ee52ab27cd 100644
--- a/sys-fs/aufs2/aufs2-0_p20100809.ebuild
+++ b/sys-fs/aufs2/aufs2-0_p20100809.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20100809.ebuild,v 1.2 2010/08/11 21:11:37 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20100809.ebuild,v 1.3 2011/02/27 13:09:23 jlec Exp $
EAPI="2"
@@ -38,8 +38,8 @@ pkg_setup() {
patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null
patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null
epatch "${FILESDIR}"/aufs2-{base,standalone}-${KV_PATCH}.patch
- elog "You need to compile your kernel with the applied patch"
- elog "to be able to load and use the aufs kernel module"
+ ewarn "You need to compile your kernel with the applied patch"
+ ewarn "to be able to load and use the aufs kernel module"
else
eerror "You need to apply a patch to your kernel to compile and run the aufs2 module"
eerror "Either enable the kernel-patch useflag to do it with this ebuild"
diff --git a/sys-fs/aufs2/aufs2-0_p20101122.ebuild b/sys-fs/aufs2/aufs2-0_p20101122.ebuild
index 5a25565a221d..c4578f2bee8a 100644
--- a/sys-fs/aufs2/aufs2-0_p20101122.ebuild
+++ b/sys-fs/aufs2/aufs2-0_p20101122.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20101122.ebuild,v 1.1 2010/11/30 21:25:04 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20101122.ebuild,v 1.2 2011/02/27 13:09:23 jlec Exp $
EAPI="2"
@@ -39,8 +39,8 @@ pkg_setup() {
patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null
patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null
epatch "${FILESDIR}"/aufs2-{base,standalone}-${KV_PATCH}.patch
- elog "You need to compile your kernel with the applied patch"
- elog "to be able to load and use the aufs kernel module"
+ ewarn "You need to compile your kernel with the applied patch"
+ ewarn "to be able to load and use the aufs kernel module"
else
eerror "You need to apply a patch to your kernel to compile and run the aufs2 module"
eerror "Either enable the kernel-patch useflag to do it with this ebuild"
diff --git a/sys-fs/aufs2/aufs2-0_p20110120.ebuild b/sys-fs/aufs2/aufs2-0_p20110120.ebuild
index 520b40e20d6d..809cf97bcbfd 100644
--- a/sys-fs/aufs2/aufs2-0_p20110120.ebuild
+++ b/sys-fs/aufs2/aufs2-0_p20110120.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20110120.ebuild,v 1.2 2011/01/21 07:37:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20110120.ebuild,v 1.3 2011/02/27 13:09:23 jlec Exp $
EAPI="2"
@@ -47,8 +47,8 @@ pkg_setup() {
patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null
patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null
epatch "${FILESDIR}"/aufs2-{base,standalone}-${KV_PATCH}.patch
- elog "You need to compile your kernel with the applied patch"
- elog "to be able to load and use the aufs kernel module"
+ ewarn "You need to compile your kernel with the applied patch"
+ ewarn "to be able to load and use the aufs kernel module"
else
eerror "You need to apply a patch to your kernel to compile and run the aufs2 module"
eerror "Either enable the kernel-patch useflag to do it with this ebuild"
diff --git a/sys-fs/aufs2/metadata.xml b/sys-fs/aufs2/metadata.xml
index d70d1c71d803..1e6c9230d346 100644
--- a/sys-fs/aufs2/metadata.xml
+++ b/sys-fs/aufs2/metadata.xml
@@ -3,10 +3,10 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>tommy@gentoo.org</email>
+ <email>jlec@gentoo.org</email>
</maintainer>
<maintainer>
- <email>jlec@gentoo.org</email>
+ <email>tommy@gentoo.org</email>
</maintainer>
<use>
<flag name='debug'>Enable additional debugging support</flag>