summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-30 20:26:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-30 20:26:16 +0000
commit30f5eb467227599582ab6890a9f99853d891738f (patch)
tree6351c236366011d949c3b435b89b7e9e1dfd8776 /sys-fs/bleachbit
parentchanged to gentoo mirror for dead berlios mirror; no new project page yet (diff)
downloadgentoo-2-30f5eb467227599582ab6890a9f99853d891738f.tar.gz
gentoo-2-30f5eb467227599582ab6890a9f99853d891738f.tar.bz2
gentoo-2-30f5eb467227599582ab6890a9f99853d891738f.zip
Install missing cleaners wrt #388999 by Erlend Davidson
(Portage version: 2.2.0_alpha71_p73/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/bleachbit')
-rw-r--r--sys-fs/bleachbit/ChangeLog8
-rw-r--r--sys-fs/bleachbit/bleachbit-0.9.0-r1.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-fs/bleachbit/ChangeLog b/sys-fs/bleachbit/ChangeLog
index c52bf123ff34..0d7c775dc744 100644
--- a/sys-fs/bleachbit/ChangeLog
+++ b/sys-fs/bleachbit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/bleachbit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/bleachbit/ChangeLog,v 1.2 2011/10/16 13:59:51 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/bleachbit/ChangeLog,v 1.3 2011/10/30 20:26:16 ssuominen Exp $
+
+*bleachbit-0.9.0-r1 (30 Oct 2011)
+
+ 30 Oct 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +bleachbit-0.9.0-r1.ebuild:
+ Install missing cleaners wrt #388999 by Erlend Davidson
16 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> bleachbit-0.9.0.ebuild:
Missing PYTHON_USE_WITH="sqlite" and USE="nls" support.
diff --git a/sys-fs/bleachbit/bleachbit-0.9.0-r1.ebuild b/sys-fs/bleachbit/bleachbit-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..c625edd8d9e2
--- /dev/null
+++ b/sys-fs/bleachbit/bleachbit-0.9.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/bleachbit/bleachbit-0.9.0-r1.ebuild,v 1.1 2011/10/30 20:26:16 ssuominen Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="http://bleachbit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-python/pygtk-2"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+DOCS="README"
+
+src_prepare() {
+ python_convert_shebangs 2 ${PN}.py
+
+ # warning: key "Encoding" in group "Desktop Entry" is deprecated
+ sed -i -e '/Encoding/d' ${PN}.desktop || die
+
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+ use nls && emake -C po
+}
+
+src_install() {
+ distutils_src_install
+ use nls && emake -C po DESTDIR="${D}" install
+
+ # http://bugs.gentoo.org/388999
+ insinto /usr/share/${PN}/cleaners
+ doins cleaners/*.xml
+
+ newbin ${PN}.py ${PN}
+
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+}