summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-04 17:08:37 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-04 17:08:37 +0000
commit0ed2be004fe8f708d142f82e0fb8d51356ed813b (patch)
tree4af842a75ccff7159483aaed110d389cc6bb8295 /sys-fs/e2fsprogs
parentdont add sys-devel/libtool to DEPEND if the package is sys-devel/libtool #253... (diff)
downloadgentoo-2-0ed2be004fe8f708d142f82e0fb8d51356ed813b.tar.gz
gentoo-2-0ed2be004fe8f708d142f82e0fb8d51356ed813b.tar.bz2
gentoo-2-0ed2be004fe8f708d142f82e0fb8d51356ed813b.zip
Add fix from upstream for slow tune2fs usage #253162 by candrews.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/ChangeLog8
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.41.3-r1.ebuild132
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.41.3-tune2fs-opt.patch99
3 files changed, 238 insertions, 1 deletions
diff --git a/sys-fs/e2fsprogs/ChangeLog b/sys-fs/e2fsprogs/ChangeLog
index 487e59183fd8..ab2329f55d23 100644
--- a/sys-fs/e2fsprogs/ChangeLog
+++ b/sys-fs/e2fsprogs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/e2fsprogs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.174 2009/01/01 15:47:52 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.175 2009/01/04 17:08:36 vapier Exp $
+
+*e2fsprogs-1.41.3-r1 (04 Jan 2009)
+
+ 04 Jan 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/e2fsprogs-1.41.3-tune2fs-opt.patch, +e2fsprogs-1.41.3-r1.ebuild:
+ Add fix from upstream for slow tune2fs usage #253162 by candrews.
01 Jan 2009; Guy Martin <gmsoft@gentoo.org> e2fsprogs-1.41.3.ebuild:
hppa stable, #251808
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.41.3-r1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.41.3-r1.ebuild
new file mode 100644
index 000000000000..eeda521e7f01
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.41.3-r1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.41.3-r1.ebuild,v 1.1 2009/01/04 17:08:36 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls elibc_FreeBSD"
+
+RDEPEND="~sys-libs/${PN}-libs-${PV}
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-apps/texinfo"
+
+pkg_setup() {
+ if [[ ! -e ${ROOT}/etc/mtab ]] ; then
+ # add some crap to deal with missing /etc/mtab #217719
+ ewarn "No /etc/mtab file, creating one temporarily"
+ echo "${PN} crap for src_test" > "${ROOT}"/etc/mtab
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
+ epatch "${FILESDIR}"/${PN}-1.41.2-makefile.patch
+ epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
+ epatch "${FILESDIR}"/${P}-tune2fs-opt.patch #253162
+ # blargh ... trick e2fsprogs into using e2fsprogs-libs
+ rm -rf doc
+ sed -i -r \
+ -e 's:@LIBINTL@:@LTLIBINTL@:' \
+ -e '/^LIB(BLKID|COM_ERR|SS|UUID)/s:[$][(]LIB[)]/lib([^@]*)@LIB_EXT@:-l\1:' \
+ -e '/^DEPLIB(BLKID|COM_ERR|SS|UUID)/s:=.*:=:' \
+ MCONFIG.in || die "muck libs" #122368
+ sed -i -r \
+ -e '/^LIB_SUBDIRS/s:lib/(blkid|et|ss|uuid)::g' \
+ Makefile.in || die "remove subdirs"
+ touch lib/ss/ss_err.h
+}
+
+src_compile() {
+ # Keep the package from doing silly things
+ addwrite /var/cache/fonts
+ export LDCONFIG=:
+ export CC=$(tc-getCC)
+ export STRIP=:
+
+ # We want to use the "bsd" libraries while building on Darwin, but while
+ # building on other Gentoo/*BSD we prefer elf-naming scheme.
+ local libtype
+ case ${CHOST} in
+ *-darwin*) libtype=bsd;;
+ *) libtype=elf;;
+ esac
+
+ econf \
+ --bindir=/bin \
+ --sbindir=/sbin \
+ --enable-${libtype}-shlibs \
+ --with-ldopts="${LDFLAGS}" \
+ $(use_enable !elibc_uclibc tls) \
+ --without-included-gettext \
+ $(use_enable nls) \
+ $(use_enable userland_GNU fsck) \
+ || die
+ if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
+ die "Preventing included intl cruft from building"
+ fi
+ emake COMPILE_ET=compile_et MK_CMDS=mk_cmds || die
+
+ # Build the FreeBSD helper
+ if use elibc_FreeBSD ; then
+ cp "${FILESDIR}"/fsck_ext2fs.c .
+ emake fsck_ext2fs || die
+ fi
+}
+
+pkg_preinst() {
+ if [[ -r ${ROOT}/etc/mtab ]] ; then
+ if [[ $(<"${ROOT}"/etc/mtab) == "${PN} crap for src_test" ]] ; then
+ rm -f "${ROOT}"/etc/mtab
+ fi
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install-libs || die
+ dodoc README RELEASE-NOTES
+
+ # Move shared libraries to /lib/, install static libraries to /usr/lib/,
+ # and install linker scripts to /usr/lib/.
+ dodir /$(get_libdir)
+ local lib slib
+ for lib in "${D}"/usr/$(get_libdir)/*.a ; do
+ slib=${lib##*/}
+ mv "${lib%.a}"$(get_libname)* "${D}"/$(get_libdir)/ || die "moving lib ${slib}"
+ gen_usr_ldscript ${slib%.a}$(get_libname)
+ done
+
+ # move 'useless' stuff to /usr/
+ dosbin "${D}"/sbin/mklost+found
+ rm -f "${D}"/sbin/mklost+found
+
+ if use elibc_FreeBSD ; then
+ # Install helpers for us
+ into /
+ dosbin "${S}"/fsck_ext2fs || die
+ doman "${FILESDIR}"/fsck_ext2fs.8
+
+ # these manpages are already provided by FreeBSD libc
+ # and filefrag is linux only
+ rm -f \
+ "${D}"/sbin/filefrag \
+ "${D}"/usr/share/man/man8/filefrag.8 \
+ "${D}"/bin/uuidgen \
+ "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
+ "${D}"/usr/share/man/man1/uuidgen.1 || die
+ fi
+}
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.3-tune2fs-opt.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.3-tune2fs-opt.patch
new file mode 100644
index 000000000000..35e8a57fa3a4
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.3-tune2fs-opt.patch
@@ -0,0 +1,99 @@
+http://bugs.gentoo.org/253162
+
+From 27c6de45a4187a348ec0960472d4a113ee6ea425 Mon Sep 17 00:00:00 2001
+From: Theodore Ts'o <tytso@mit.edu>
+Date: Sat, 15 Nov 2008 00:32:39 -0500
+Subject: [PATCH] tune2fs: Fix inefficient O(n**2) algorithms when expanding the inode size
+
+When running "tune2fs -I 256" on moderate to large filesystems, the
+time required to run tune2fs can take many hours (20+ before some
+users gave up in disgust). This was due to some O(n**2) and O(n*m)
+algorithms in move_block() and inode_scan_and_fix(), respectively.
+
+Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
+---
+ misc/tune2fs.c | 25 +++++++++++++------------
+ 1 files changed, 13 insertions(+), 12 deletions(-)
+
+diff --git a/misc/tune2fs.c b/misc/tune2fs.c
+index b29b344..e72518a 100644
+--- a/misc/tune2fs.c
++++ b/misc/tune2fs.c
+@@ -1011,13 +1011,13 @@ static int move_block(ext2_filsys fs, ext2fs_block_bitmap bmap)
+ if (retval)
+ return retval;
+
+- for (blk = fs->super->s_first_data_block;
+- blk < fs->super->s_blocks_count; blk++) {
++ for (new_blk = blk = fs->super->s_first_data_block;
++ blk < fs->super->s_blocks_count; blk++) {
+
+ if (!ext2fs_test_block_bitmap(bmap, blk))
+ continue;
+
+- retval = ext2fs_new_block(fs, blk, NULL, &new_blk);
++ retval = ext2fs_new_block(fs, new_blk, NULL, &new_blk);
+ if (retval)
+ goto err_out;
+
+@@ -1068,12 +1068,14 @@ static int process_block(ext2_filsys fs EXT2FS_ATTR((unused)),
+ e2_blkcnt_t blockcnt EXT2FS_ATTR((unused)),
+ blk_t ref_block EXT2FS_ATTR((unused)),
+ int ref_offset EXT2FS_ATTR((unused)),
+- void *priv_data EXT2FS_ATTR((unused)))
++ void *priv_data)
+ {
+ int ret = 0;
+ blk_t new_blk;
++ ext2fs_block_bitmap bmap = (ext2fs_block_bitmap) priv_data;
+
+-
++ if (!ext2fs_test_block_bitmap(bmap, *block_nr))
++ return 0;
+ new_blk = transalate_block(*block_nr);
+ if (new_blk) {
+ *block_nr = new_blk;
+@@ -1086,7 +1088,7 @@ static int process_block(ext2_filsys fs EXT2FS_ATTR((unused)),
+ return ret;
+ }
+
+-static int inode_scan_and_fix(ext2_filsys fs)
++static int inode_scan_and_fix(ext2_filsys fs, ext2fs_block_bitmap bmap)
+ {
+ errcode_t retval = 0;
+ ext2_ino_t ino;
+@@ -1122,8 +1124,8 @@ static int inode_scan_and_fix(ext2_filsys fs)
+ * Do we need to fix this ??
+ */
+
+- if (inode.i_file_acl) {
+-
++ if (inode.i_file_acl &&
++ ext2fs_test_block_bitmap(bmap, inode.i_file_acl)) {
+ blk = transalate_block(inode.i_file_acl);
+ if (!blk)
+ continue;
+@@ -1142,9 +1144,8 @@ static int inode_scan_and_fix(ext2_filsys fs)
+ if (!ext2fs_inode_has_valid_blocks(&inode))
+ continue;
+
+- retval = ext2fs_block_iterate2(fs, ino, 0,
+- block_buf, process_block,
+- 0);
++ retval = ext2fs_block_iterate2(fs, ino, 0, block_buf,
++ process_block, bmap);
+ if (retval)
+ goto err_out;
+
+@@ -1344,7 +1345,7 @@ static int resize_inode(ext2_filsys fs, unsigned long new_size)
+ if (retval)
+ goto err_out;
+
+- retval = inode_scan_and_fix(fs);
++ retval = inode_scan_and_fix(fs, bmap);
+ if (retval)
+ goto err_out;
+
+--
+1.6.0.6
+