summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-04-08 17:28:28 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-04-08 17:28:28 +0000
commit431d574ff3e525efcfefd18ce4ac6f0b320b2c20 (patch)
treeee39941962474bbe3587fcaf60bae3a50bf04b62 /sys-fs/ecryptfs-utils
parentVersion bump. (diff)
downloadgentoo-2-431d574ff3e525efcfefd18ce4ac6f0b320b2c20.tar.gz
gentoo-2-431d574ff3e525efcfefd18ce4ac6f0b320b2c20.tar.bz2
gentoo-2-431d574ff3e525efcfefd18ce4ac6f0b320b2c20.zip
Version bump
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'sys-fs/ecryptfs-utils')
-rw-r--r--sys-fs/ecryptfs-utils/ChangeLog7
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-42.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-fs/ecryptfs-utils/ChangeLog b/sys-fs/ecryptfs-utils/ChangeLog
index 5002b13b01d4..a805b878bc66 100644
--- a/sys-fs/ecryptfs-utils/ChangeLog
+++ b/sys-fs/ecryptfs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ecryptfs-utils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.20 2008/03/14 09:32:39 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.21 2008/04/08 17:28:28 alonbl Exp $
+
+*ecryptfs-utils-42 (08 Apr 2008)
+
+ 08 Apr 2008; Alon Bar-Lev <alonbl@gentoo.org> +ecryptfs-utils-42.ebuild:
+ Version bump
14 Mar 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing Charlie Shepherd (masterdriverz, #153940) from metadata.xml. Fixing
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-42.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-42.ebuild
new file mode 100644
index 000000000000..985e9516fc1e
--- /dev/null
+++ b/sys-fs/ecryptfs-utils/ecryptfs-utils-42.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-42.ebuild,v 1.1 2008/04/08 17:28:28 alonbl Exp $
+
+inherit pam
+
+DESCRIPTION="eCryptfs userspace utilities"
+HOMEPAGE="http://www.ecryptfs.org/"
+SRC_URI="mirror://sourceforge/ecryptfs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="suid pam gtk openssl pkcs11 gpg doc"
+
+RDEPEND=">=sys-apps/keyutils-1.0
+ >=dev-libs/libgcrypt-1.2.0
+ pam? ( sys-libs/pam )
+ openssl? ( >=dev-libs/openssl-0.9.7 )
+ pkcs11? (
+ >=dev-libs/openssl-0.9.7
+ >=dev-libs/pkcs11-helper-1.04
+ )
+ gpg? ( app-crypt/gpgme )
+ gtk? ( x11-libs/gtk+ )"
+# perl required for man generation
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ dev-lang/perl"
+
+src_compile() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --with-pamdir=$(getpam_mod_dir) \
+ $(use_enable pam) \
+ $(use_enable openssl) \
+ $(use_enable pkcs11 pkcs11-helper) \
+ $(use_enable gpg) \
+ $(use_enable gtk gui) \
+ $(use_enable doc docs) \
+ || die
+ emake || die
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die
+ use suid && fperms u+s /sbin/mount.ecryptfs
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}