summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-09-01 11:19:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-09-01 11:19:06 +0000
commit452f3c3fcfbe27107e8173f1383568801bac9472 (patch)
treec62466d63fef682537e4a3c2388d7efe85d12c05 /sys-fs/ecryptfs-utils
parentChange version scheme (diff)
downloadgentoo-2-452f3c3fcfbe27107e8173f1383568801bac9472.tar.gz
gentoo-2-452f3c3fcfbe27107e8173f1383568801bac9472.tar.bz2
gentoo-2-452f3c3fcfbe27107e8173f1383568801bac9472.zip
Version bump to release 91: includes my changes and a couple of security-sensitive fixes.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ecryptfs-utils')
-rw-r--r--sys-fs/ecryptfs-utils/ChangeLog11
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-83.ebuild133
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-85.ebuild133
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-91.ebuild (renamed from sys-fs/ecryptfs-utils/ecryptfs-utils-90.ebuild)5
-rw-r--r--sys-fs/ecryptfs-utils/files/ecryptfs-utils-90-nss-pkgconfig.patch27
5 files changed, 12 insertions, 297 deletions
diff --git a/sys-fs/ecryptfs-utils/ChangeLog b/sys-fs/ecryptfs-utils/ChangeLog
index 57039f28c188..d2accd1dd0d4 100644
--- a/sys-fs/ecryptfs-utils/ChangeLog
+++ b/sys-fs/ecryptfs-utils/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-fs/ecryptfs-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.35 2011/08/31 01:33:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.36 2011/09/01 11:19:06 flameeyes Exp $
+
+*ecryptfs-utils-91 (01 Sep 2011)
+
+ 01 Sep 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ -ecryptfs-utils-83.ebuild, -ecryptfs-utils-85.ebuild,
+ -ecryptfs-utils-90.ebuild, -files/ecryptfs-utils-90-nss-pkgconfig.patch,
+ +ecryptfs-utils-91.ebuild:
+ Version bump to release 91: includes my changes and a couple of
+ security-sensitive fixes.
31 Aug 2011; Diego E. Pettenò <flameeyes@gentoo.org>
ecryptfs-utils-90.ebuild:
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-83.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-83.ebuild
deleted file mode 100644
index 366276317369..000000000000
--- a/sys-fs/ecryptfs-utils/ecryptfs-utils-83.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-83.ebuild,v 1.3 2011/03/29 07:57:50 angelos Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-inherit flag-o-matic pam python
-
-DESCRIPTION="eCryptfs userspace utilities"
-HOMEPAGE="http://launchpad.net/ecryptfs"
-SRC_URI="http://launchpad.net/ecryptfs/trunk/${PV}/+download/${PN}_${PV}.orig.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc gpg gtk openssl pam pkcs11 python suid tpm"
-
-RDEPEND=">=sys-apps/keyutils-1.0
- >=dev-libs/libgcrypt-1.2.0
- dev-libs/nss
- gpg? ( app-crypt/gpgme )
- gtk? ( x11-libs/gtk+:2 )
- openssl? ( >=dev-libs/openssl-0.9.7 )
- pam? ( sys-libs/pam )
- pkcs11? (
- >=dev-libs/openssl-0.9.7
- >=dev-libs/pkcs11-helper-1.04
- )
- tpm? ( app-crypt/trousers )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.9.0
- sys-devel/gettext
- dev-util/intltool
- python? ( dev-lang/swig )"
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- echo "#!/bin/sh" > py-compile
-
- # Python bindings are built/installed manually.
- sed -e "/SUBDIRS =/s/ libecryptfs-swig//" -i src/Makefile.{am,in} || die "sed failed"
-}
-
-src_configure() {
- append-flags -D_FILE_OFFSET_BITS=64
-
- econf \
- --docdir="/usr/share/doc/${PF}" \
- --enable-nss \
- --with-pamdir=$(getpam_mod_dir) \
- $(use_enable doc docs) \
- $(use_enable gpg) \
- $(use_enable gtk gui) \
- $(use_enable openssl) \
- $(use_enable pam) \
- $(use_enable pkcs11 pkcs11-helper) \
- $(use_enable python pywrap) \
- $(use_enable tpm tspi)
-}
-
-src_compile() {
- default
-
- if use python; then
- python_copy_sources src/libecryptfs-swig
- building() {
- emake \
- PYTHON="$(PYTHON)" \
- PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
- PYTHON_LDFLAGS="-L$(python_get_libdir) $(python_get_library -l)" \
- PYTHON_SITE_PKG="$(python_get_sitedir)" \
- PYTHON_VERSION="$(python_get_version)" \
- SWIG_PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)"
- }
- python_execute_function -s --source-dir src/libecryptfs-swig building
- fi
-}
-
-src_install(){
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- PYTHON="$(PYTHON)" \
- PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
- PYTHON_LDFLAGS="-L$(python_get_libdir) $(python_get_library -l)" \
- PYTHON_SITE_PKG="$(python_get_sitedir)" \
- PYTHON_VERSION="$(python_get_version)" \
- SWIG_PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)" \
- install || return 1
- echo "ecryptfs-utils" > "${ED}$(python_get_sitedir)/ecryptfs-utils.pth"
- }
- python_execute_function -s --source-dir src/libecryptfs-swig installation
-
- python_clean_installation_image
- fi
-
- use suid && fperms u+s /sbin/mount.ecryptfs_private
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize ecryptfs-utils
- fi
-
- if use suid; then
- ewarn
- ewarn "You have chosen to install ${PN} with the binary setuid root. This"
- ewarn "means that if there are any undetected vulnerabilities in the binary,"
- ewarn "then local users may be able to gain root access on your machine."
- ewarn
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup ecryptfs-utils
- fi
-}
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-85.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-85.ebuild
deleted file mode 100644
index 3901bffe8c56..000000000000
--- a/sys-fs/ecryptfs-utils/ecryptfs-utils-85.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-85.ebuild,v 1.2 2011/03/29 07:57:50 angelos Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
-
-inherit flag-o-matic pam python
-
-DESCRIPTION="eCryptfs userspace utilities"
-HOMEPAGE="http://launchpad.net/ecryptfs"
-SRC_URI="http://launchpad.net/ecryptfs/trunk/${PV}/+download/${PN}_${PV}.orig.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc gpg gtk openssl pam pkcs11 python suid tpm"
-
-RDEPEND=">=sys-apps/keyutils-1.0
- >=dev-libs/libgcrypt-1.2.0
- dev-libs/nss
- gpg? ( app-crypt/gpgme )
- gtk? ( x11-libs/gtk+:2 )
- openssl? ( >=dev-libs/openssl-0.9.7 )
- pam? ( sys-libs/pam )
- pkcs11? (
- >=dev-libs/openssl-0.9.7
- >=dev-libs/pkcs11-helper-1.04
- )
- tpm? ( app-crypt/trousers )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.9.0
- sys-devel/gettext
- dev-util/intltool
- python? ( dev-lang/swig )"
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- echo "#!/bin/sh" > py-compile
-
- # Python bindings are built/installed manually.
- sed -e "/SUBDIRS =/s/ libecryptfs-swig//" -i src/Makefile.{am,in} || die "sed failed"
-}
-
-src_configure() {
- append-flags -D_FILE_OFFSET_BITS=64
-
- econf \
- --docdir="/usr/share/doc/${PF}" \
- --enable-nss \
- --with-pamdir=$(getpam_mod_dir) \
- $(use_enable doc docs) \
- $(use_enable gpg) \
- $(use_enable gtk gui) \
- $(use_enable openssl) \
- $(use_enable pam) \
- $(use_enable pkcs11 pkcs11-helper) \
- $(use_enable python pywrap) \
- $(use_enable tpm tspi)
-}
-
-src_compile() {
- default
-
- if use python; then
- python_copy_sources src/libecryptfs-swig
- building() {
- emake \
- PYTHON="$(PYTHON)" \
- PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
- PYTHON_LDFLAGS="-L$(python_get_libdir) $(python_get_library -l)" \
- PYTHON_SITE_PKG="$(python_get_sitedir)" \
- PYTHON_VERSION="$(python_get_version)" \
- SWIG_PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)"
- }
- python_execute_function -s --source-dir src/libecryptfs-swig building
- fi
-}
-
-src_install(){
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- PYTHON="$(PYTHON)" \
- PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
- PYTHON_LDFLAGS="-L$(python_get_libdir) $(python_get_library -l)" \
- PYTHON_SITE_PKG="$(python_get_sitedir)" \
- PYTHON_VERSION="$(python_get_version)" \
- SWIG_PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)" \
- install || return 1
- echo "ecryptfs-utils" > "${ED}$(python_get_sitedir)/ecryptfs-utils.pth"
- }
- python_execute_function -s --source-dir src/libecryptfs-swig installation
-
- python_clean_installation_image
- fi
-
- use suid && fperms u+s /sbin/mount.ecryptfs_private
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize ecryptfs-utils
- fi
-
- if use suid; then
- ewarn
- ewarn "You have chosen to install ${PN} with the binary setuid root. This"
- ewarn "means that if there are any undetected vulnerabilities in the binary,"
- ewarn "then local users may be able to gain root access on your machine."
- ewarn
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup ecryptfs-utils
- fi
-}
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-90.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-91.ebuild
index ca345c1a4f3b..9f204c573213 100644
--- a/sys-fs/ecryptfs-utils/ecryptfs-utils-90.ebuild
+++ b/sys-fs/ecryptfs-utils/ecryptfs-utils-91.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-90.ebuild,v 1.3 2011/08/31 01:33:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-91.ebuild,v 1.1 2011/09/01 11:19:06 flameeyes Exp $
EAPI="3"
PYTHON_DEPEND="python? 2:2.5"
@@ -49,9 +49,8 @@ src_prepare() {
echo "#!/bin/sh" > py-compile
# Python bindings are built/installed manually.
- sed -e "/SUBDIRS =/s/ libecryptfs-swig//" -i src/Makefile.{am,in} || die "sed failed"
+ sed -e "/SUBDIRS =/s/ libecryptfs-swig//" -i src/Makefile.am || die "sed failed"
- epatch "${FILESDIR}"/${P}-nss-pkgconfig.patch
eautoreconf
}
diff --git a/sys-fs/ecryptfs-utils/files/ecryptfs-utils-90-nss-pkgconfig.patch b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-90-nss-pkgconfig.patch
deleted file mode 100644
index b132729ff616..000000000000
--- a/sys-fs/ecryptfs-utils/files/ecryptfs-utils-90-nss-pkgconfig.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: ecryptfs-utils-90/configure.ac
-===================================================================
---- ecryptfs-utils-90.orig/configure.ac
-+++ ecryptfs-utils-90/configure.ac
-@@ -228,16 +228,12 @@ else
- fi
-
- #Verify nss
--NSS_LIBS=`nss-config --libs`
--if test "x${NSS_LIBS}" != "x" ; then
-- NSS_CFLAGS=`nss-config --cflags`
-- NSPR_CFLAGS=`nspr-config --cflags`
-- NSS_CFLAGS="${NSS_CFLAGS} -DENABLE_NSS ${NSPR_CFLAGS}"
-- have_nss="yes"
--else
-- NSS_CFLAGS=""
-- have_nss="no"
--fi
-+PKG_CHECK_MODULES(
-+ [NSS],
-+ [nss],
-+ [have_nss="yes"
-+ NSS_CFLAGS="${NSS_CFLAGS} -DENABLE_NSS"],
-+ [have_nss="no"])
-
- if test "${enable_nss}" = "detect" ; then
- if test "$have_nss" == "yes" ; then