summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-10-02 18:17:48 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-10-02 18:17:48 +0000
commit551025d2ed4c4c367dbda46a4aa473bcbe96a871 (patch)
tree3bc07a6c54c3d4d260b580010f50187eb3a323f2 /sys-fs/fuse
parentstable x86, bug 194519 (diff)
downloadgentoo-2-551025d2ed4c4c367dbda46a4aa473bcbe96a871.tar.gz
gentoo-2-551025d2ed4c4c367dbda46a4aa473bcbe96a871.tar.bz2
gentoo-2-551025d2ed4c4c367dbda46a4aa473bcbe96a871.zip
Add 2.6.23 check for bug 194436
(Portage version: 2.1.3.11)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog6
-rw-r--r--sys-fs/fuse/files/digest-fuse-2.6.33
-rw-r--r--sys-fs/fuse/fuse-2.6.3.ebuild79
-rw-r--r--sys-fs/fuse/fuse-2.6.4-r1.ebuild6
-rw-r--r--sys-fs/fuse/fuse-2.7.0.ebuild6
5 files changed, 15 insertions, 85 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 71314c197a15..f4594488fea3 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.103 2007/09/25 19:35:42 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.104 2007/10/02 18:17:47 genstef Exp $
+
+ 02 Oct 2007; Stefan Schweizer <genstef@gentoo.org> -fuse-2.6.3.ebuild,
+ fuse-2.6.4-r1.ebuild, fuse-2.7.0.ebuild:
+ Add 2.6.23 check for bug 194436
25 Sep 2007; Christoph Mende <angelos@gentoo.org> fuse-2.7.0.ebuild:
Stable on amd64 wrt bug #193329
diff --git a/sys-fs/fuse/files/digest-fuse-2.6.3 b/sys-fs/fuse/files/digest-fuse-2.6.3
deleted file mode 100644
index be1acdd63dc3..000000000000
--- a/sys-fs/fuse/files/digest-fuse-2.6.3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 3f4f5d07d12dedc0a3fd23472171fe94 fuse-2.6.3.tar.gz 473147
-RMD160 df05bc42cb4c97f9e54048662f64a8cac5713f18 fuse-2.6.3.tar.gz 473147
-SHA256 804d7fae424c97dc3790ad12d798e7b27dc6c12e4116f8bd69ca0130773d3f9d fuse-2.6.3.tar.gz 473147
diff --git a/sys-fs/fuse/fuse-2.6.3.ebuild b/sys-fs/fuse/fuse-2.6.3.ebuild
deleted file mode 100644
index 1f2e25fb43f0..000000000000
--- a/sys-fs/fuse/fuse-2.6.3.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.3.ebuild,v 1.8 2007/04/24 18:55:18 dertobi123 Exp $
-
-inherit linux-mod eutils libtool
-
-MY_P=${P/_/-}
-DESCRIPTION="An interface for filesystems implemented in userspace."
-HOMEPAGE="http://fuse.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="kernel_linux kernel_FreeBSD"
-S=${WORKDIR}/${MY_P}
-PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-
-pkg_setup() {
- if use kernel_linux ; then
- MODULE_NAMES="fuse(fs:${S}/kernel)"
- CONFIG_CHECK="@FUSE_FS:fuse"
- FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
- We will continue, but we wont build the module this time."
-
- linux-mod_pkg_setup
- kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
- older version from viewcvs"
-
- BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
- BUILD_TARGETS="all"
- ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
- elibtoolize
-}
-
-src_compile() {
- econf \
- --disable-kernel-module \
- --disable-example \
- || die "econf failed for fuse userland"
- emake || die "emake failed"
-
- if use kernel_linux ; then
- cd "${S}"
- sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
- convert_to_m kernel/Makefile.in
- linux-mod_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog Filesystems README README-2.4 \
- README.NFS NEWS doc/how-fuse-works
- docinto example
- dodoc example/*
-
- if use kernel_linux ; then
- linux-mod_src_install
- newinitd ${FILESDIR}/fuse.init fuse
- else
- insinto /usr/include/fuse
- doins include/fuse_kernel.h
- newinitd ${FILESDIR}/fuse-fbsd.init fuse
- fi
-
- rm -rf "${D}/dev"
-}
-
-pkg_postinst() {
- use kernel_linux && linux-mod_pkg_postinst
-}
diff --git a/sys-fs/fuse/fuse-2.6.4-r1.ebuild b/sys-fs/fuse/fuse-2.6.4-r1.ebuild
index 9f862566063e..2598776c3204 100644
--- a/sys-fs/fuse/fuse-2.6.4-r1.ebuild
+++ b/sys-fs/fuse/fuse-2.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.4-r1.ebuild,v 1.9 2007/06/17 11:52:17 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.4-r1.ebuild,v 1.10 2007/10/02 18:17:47 genstef Exp $
inherit linux-mod eutils libtool
@@ -21,6 +21,10 @@ pkg_setup() {
FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
We will continue, but we wont build the module this time."
+ if kernel_is ge 2 6 23; then
+ CONFIG_CHECK="FUSE_FS"
+ FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
+ fi
linux-mod_pkg_setup
kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
older version from viewcvs"
diff --git a/sys-fs/fuse/fuse-2.7.0.ebuild b/sys-fs/fuse/fuse-2.7.0.ebuild
index a86903991486..cc4963527ff1 100644
--- a/sys-fs/fuse/fuse-2.7.0.ebuild
+++ b/sys-fs/fuse/fuse-2.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.0.ebuild,v 1.5 2007/09/25 19:35:42 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.0.ebuild,v 1.6 2007/10/02 18:17:47 genstef Exp $
inherit linux-mod eutils libtool
@@ -21,6 +21,10 @@ pkg_setup() {
FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
We will continue, but we wont build the module this time."
+ if kernel_is ge 2 6 23; then
+ CONFIG_CHECK="FUSE_FS"
+ FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
+ fi
linux-mod_pkg_setup
kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
older version from viewcvs"