summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-05-20 07:39:24 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-05-20 07:39:24 +0000
commit5c13a1c676a0a401638693847a9f86a863c42e76 (patch)
treee973c156a6e082e981cca7f45edf61c4d67713b1 /sys-fs/fuse
parentadded ~amd64, bug 177102 (diff)
downloadgentoo-2-5c13a1c676a0a401638693847a9f86a863c42e76.tar.gz
gentoo-2-5c13a1c676a0a401638693847a9f86a863c42e76.tar.bz2
gentoo-2-5c13a1c676a0a401638693847a9f86a863c42e76.zip
make 2.6.22 ready thanks to Francois Chenier <belgix@kern.com.au> in bug 179085
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog6
-rw-r--r--sys-fs/fuse/files/fuse-2.6.22.patch49
-rw-r--r--sys-fs/fuse/fuse-2.6.4-r1.ebuild3
3 files changed, 56 insertions, 2 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index e1cb44f4050e..cae317519d7e 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.90 2007/05/12 02:15:15 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.91 2007/05/20 07:39:24 genstef Exp $
+
+ 20 May 2007; Stefan Schweizer <genstef@gentoo.org>
+ +files/fuse-2.6.22.patch, fuse-2.6.4-r1.ebuild:
+ make 2.6.22 ready thanks to Francois Chenier <belgix@kern.com.au> in bug 179085
12 May 2007; Daniel Drake <dsd@gentoo.org> metadata.xml:
Move from kernel to kernel-misc herd
diff --git a/sys-fs/fuse/files/fuse-2.6.22.patch b/sys-fs/fuse/files/fuse-2.6.22.patch
new file mode 100644
index 000000000000..fbb9cdff3d4f
--- /dev/null
+++ b/sys-fs/fuse/files/fuse-2.6.22.patch
@@ -0,0 +1,49 @@
+--- /var/tmp/portage/sys-fs/fuse-2.6.4-r1/work/fuse-2.6.4/kernel/file.c 2007-05-19 19:54:45.000000000 +0930
++++ /var/tmp/portage/sys-fs/fuse-2.6.4-r1/work/fuse-2.6.4/kernel/file.c 2007-05-19 19:58:40.000000000 +0930
+@@ -781,7 +781,8 @@
+
+ if (cmd == F_GETLK) {
+ if (fc->no_lock) {
+-#ifdef KERNEL_2_6_17_PLUS
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 17) && \
++ LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 22)
+ if (!posix_test_lock(file, fl, fl))
+ fl->fl_type = F_UNLCK;
+ #else
+--- /var/tmp/portage/sys-fs/fuse-2.6.4-r1/work/fuse-2.6.4/kernel/inode.c 2007-05-20 09:13:34.000000000 +0930
++++ /var/tmp/portage/sys-fs/fuse-2.6.4-r1/work/fuse-2.6.4/kernel/inode.c 2007-05-20 09:18:33.000000000 +0930
+@@ -809,9 +809,13 @@
+ {
+ struct inode * inode = foo;
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 22)
++ inode_init_once(inode);
++#else
+ if ((flags & (SLAB_CTOR_VERIFY|SLAB_CTOR_CONSTRUCTOR)) ==
+ SLAB_CTOR_CONSTRUCTOR)
+ inode_init_once(inode);
++#endif
+ }
+
+ static int __init fuse_fs_init(void)
+@@ -860,12 +864,20 @@
+ if (err)
+ return err;
+ #endif
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 22)
++ kobj_set_kset_s(&fuse_subsys, fs_subsys);
++#else
+ kset_set_kset_s(&fuse_subsys, fs_subsys);
++#endif
+ err = subsystem_register(&fuse_subsys);
+ if (err)
+ goto out_err;
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 22)
++ kobj_set_kset_s(&connections_subsys, fuse_subsys);
++#else
+ kset_set_kset_s(&connections_subsys, fuse_subsys);
++#endif
+ err = subsystem_register(&connections_subsys);
+ if (err)
+ goto out_fuse_unregister;
diff --git a/sys-fs/fuse/fuse-2.6.4-r1.ebuild b/sys-fs/fuse/fuse-2.6.4-r1.ebuild
index d1027c3d26fd..dc37e776b207 100644
--- a/sys-fs/fuse/fuse-2.6.4-r1.ebuild
+++ b/sys-fs/fuse/fuse-2.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.4-r1.ebuild,v 1.3 2007/05/03 02:21:13 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.4-r1.ebuild,v 1.4 2007/05/20 07:39:24 genstef Exp $
inherit linux-mod eutils libtool
@@ -36,6 +36,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
+ epatch "${FILESDIR}"/fuse-2.6.22.patch
sed -i -e "s:die {:die() {:" util/mount.fuse
elibtoolize
}