summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-03-23 21:46:08 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-03-23 21:46:08 +0000
commita533dcadf8891f63d22f85629eacb712cf5a2e25 (patch)
treec0b9a5977dbae513a601eddb159751ef0dbe192e /sys-fs/fuse
parentFix lax escaping of BUILD_PARAMS so that ebuild works again after recent modi... (diff)
downloadgentoo-2-a533dcadf8891f63d22f85629eacb712cf5a2e25.tar.gz
gentoo-2-a533dcadf8891f63d22f85629eacb712cf5a2e25.tar.bz2
gentoo-2-a533dcadf8891f63d22f85629eacb712cf5a2e25.zip
Fix lax escaping in BUILD_PARAMS so that ebuild works again after recent modifications to linux-mod.eclass.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog7
-rw-r--r--sys-fs/fuse/fuse-2.6.4-r1.ebuild8
-rw-r--r--sys-fs/fuse/fuse-2.7.0.ebuild8
-rw-r--r--sys-fs/fuse/fuse-2.7.1.ebuild8
-rw-r--r--sys-fs/fuse/fuse-2.7.2.ebuild6
5 files changed, 21 insertions, 16 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index a9697a9940d8..9ccd34eec726 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.111 2008/03/11 19:54:29 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.112 2008/03/23 21:46:08 robbat2 Exp $
+
+ 23 Mar 2008; Robin H. Johnson <robbat2@gentoo.org> fuse-2.6.4-r1.ebuild,
+ fuse-2.7.0.ebuild, fuse-2.7.1.ebuild, fuse-2.7.2.ebuild:
+ Fix lax escaping in BUILD_PARAMS so that ebuild works again after recent
+ modifications to linux-mod.eclass.
11 Mar 2008; Stefan Schweizer <genstef@gentoo.org> fuse-2.7.2.ebuild:
Add default config for Henning Schild <henning@wh9.tu-dresden.de> in bug 201105
diff --git a/sys-fs/fuse/fuse-2.6.4-r1.ebuild b/sys-fs/fuse/fuse-2.6.4-r1.ebuild
index 8f8ad3491a98..914dbbe920aa 100644
--- a/sys-fs/fuse/fuse-2.6.4-r1.ebuild
+++ b/sys-fs/fuse/fuse-2.6.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.4-r1.ebuild,v 1.11 2007/10/09 22:20:15 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.4-r1.ebuild,v 1.12 2008/03/23 21:46:08 robbat2 Exp $
inherit linux-mod eutils libtool
@@ -30,8 +30,8 @@ pkg_setup() {
kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
older version from viewcvs"
- BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
+ BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR} \
+ fusemoduledir=\"${ROOT}\"/lib/modules/${KV_FULL/\ }/fs"
BUILD_TARGETS="all"
ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
fi
diff --git a/sys-fs/fuse/fuse-2.7.0.ebuild b/sys-fs/fuse/fuse-2.7.0.ebuild
index c5f449898ba2..d784dac435fc 100644
--- a/sys-fs/fuse/fuse-2.7.0.ebuild
+++ b/sys-fs/fuse/fuse-2.7.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.0.ebuild,v 1.9 2007/10/13 10:35:39 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.0.ebuild,v 1.10 2008/03/23 21:46:08 robbat2 Exp $
inherit linux-mod eutils libtool
@@ -30,8 +30,8 @@ pkg_setup() {
kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
older version from viewcvs"
- BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
+ BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR} \
+ fusemoduledir=\"${ROOT}\"/lib/modules/${KV_FULL/\ }/fs"
BUILD_TARGETS="all"
ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
fi
diff --git a/sys-fs/fuse/fuse-2.7.1.ebuild b/sys-fs/fuse/fuse-2.7.1.ebuild
index eb84645158fa..ac1c29e0ab96 100644
--- a/sys-fs/fuse/fuse-2.7.1.ebuild
+++ b/sys-fs/fuse/fuse-2.7.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.1.ebuild,v 1.2 2007/12/18 10:09:00 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.1.ebuild,v 1.3 2008/03/23 21:46:08 robbat2 Exp $
inherit linux-mod eutils libtool
@@ -30,8 +30,8 @@ pkg_setup() {
kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
older version from viewcvs"
- BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
+ BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR} \
+ fusemoduledir=\"${ROOT}\"/lib/modules/${KV_FULL/\ }/fs"
BUILD_TARGETS="all"
ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
fi
diff --git a/sys-fs/fuse/fuse-2.7.2.ebuild b/sys-fs/fuse/fuse-2.7.2.ebuild
index f8055977935d..ba36b9e4612c 100644
--- a/sys-fs/fuse/fuse-2.7.2.ebuild
+++ b/sys-fs/fuse/fuse-2.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.2.ebuild,v 1.2 2008/03/11 19:54:29 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.2.ebuild,v 1.3 2008/03/23 21:46:08 robbat2 Exp $
inherit linux-mod eutils libtool
@@ -30,8 +30,8 @@ pkg_setup() {
kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
older version from viewcvs"
- BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
+ BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR} \
+ fusemoduledir=\"${ROOT}\"/lib/modules/${KV_FULL/\ }/fs"
BUILD_TARGETS="all"
ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
fi