summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-10-28 04:16:34 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-10-28 04:16:34 +0000
commite79bed969b18e5ac120c5eb0e9091785808c7533 (patch)
tree676c4f4e68d55faa8a66ed8db8665f4be7ed8316 /sys-fs/fuse
parentMask sysvinit for selinux patch update. (diff)
downloadgentoo-2-e79bed969b18e5ac120c5eb0e9091785808c7533.tar.gz
gentoo-2-e79bed969b18e5ac120c5eb0e9091785808c7533.tar.bz2
gentoo-2-e79bed969b18e5ac120c5eb0e9091785808c7533.zip
USE=modules support for sys-fs/fuse.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog5
-rw-r--r--sys-fs/fuse/fuse-2.7.4-r1.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index fd49b3e5dc36..7282ed53eb34 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.123 2009/10/06 11:59:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.124 2009/10/28 04:16:34 robbat2 Exp $
+
+ 28 Oct 2009; Robin H. Johnson <robbat2@gentoo.org> fuse-2.7.4-r1.ebuild:
+ USE=modules support for sys-fs/fuse.
*fuse-2.7.4-r1 (06 Oct 2009)
diff --git a/sys-fs/fuse/fuse-2.7.4-r1.ebuild b/sys-fs/fuse/fuse-2.7.4-r1.ebuild
index 4016acf7dda8..65c0c63f64ef 100644
--- a/sys-fs/fuse/fuse-2.7.4-r1.ebuild
+++ b/sys-fs/fuse/fuse-2.7.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.4-r1.ebuild,v 1.1 2009/10/06 11:59:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.4-r1.ebuild,v 1.2 2009/10/28 04:16:34 robbat2 Exp $
inherit linux-mod eutils libtool
@@ -12,14 +12,14 @@ SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="kernel_linux kernel_FreeBSD"
+IUSE="kernel_linux kernel_FreeBSD modules"
PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
S=${WORKDIR}/${MY_P}
pkg_setup() {
- if use kernel_linux ; then
+ if use modules && use kernel_linux ; then
if kernel_is ge 2 6 25; then
CONFIG_CHECK="FUSE_FS"
FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
@@ -54,7 +54,7 @@ src_compile() {
|| die "econf failed for fuse userland"
emake || die "emake failed"
- if use kernel_linux ; then
+ if use modules && use kernel_linux ; then
cd "${S}"
sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
convert_to_m kernel/Makefile.in
@@ -71,7 +71,7 @@ src_install() {
docinto example
dodoc example/*
- if use kernel_linux ; then
+ if use modules && use kernel_linux ; then
linux-mod_src_install
newinitd "${FILESDIR}"/fuse.init fuse
else
@@ -97,5 +97,5 @@ EOF
}
pkg_postinst() {
- use kernel_linux && linux-mod_pkg_postinst
+ use modules && use kernel_linux && linux-mod_pkg_postinst
}