summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-29 12:20:56 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-29 12:20:56 +0000
commitfe7cb458f8487f3feb518f56c3a2582f0a5197a6 (patch)
treeb2bd0674751a13fa129cc4112c0c0677e1458ef5 /sys-fs/lufs
parentCredit Cosimo Salvatore Dilettis <diablo82@gmail.com> (diff)
downloadgentoo-2-fe7cb458f8487f3feb518f56c3a2582f0a5197a6.tar.gz
gentoo-2-fe7cb458f8487f3feb518f56c3a2582f0a5197a6.tar.bz2
gentoo-2-fe7cb458f8487f3feb518f56c3a2582f0a5197a6.zip
Fix for gcc-4.3 bug #225413, thanks to Marek Miller <mlm@shells.pl>.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'sys-fs/lufs')
-rw-r--r--sys-fs/lufs/ChangeLog8
-rw-r--r--sys-fs/lufs/files/lufs-0.9.7-gcc43.patch33
-rw-r--r--sys-fs/lufs/lufs-0.9.7-r3.ebuild24
3 files changed, 52 insertions, 13 deletions
diff --git a/sys-fs/lufs/ChangeLog b/sys-fs/lufs/ChangeLog
index 25865946f54c..2b350022985b 100644
--- a/sys-fs/lufs/ChangeLog
+++ b/sys-fs/lufs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/lufs
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/ChangeLog,v 1.26 2007/01/04 18:25:13 flameeyes Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/ChangeLog,v 1.27 2008/06/29 12:20:55 loki_val Exp $
+
+ 29 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/lufs-0.9.7-gcc43.patch, lufs-0.9.7-r3.ebuild:
+ Fix for gcc-4.3 bug #225413, thanks to Marek Miller <mlm@shells.pl>.
04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> lufs-0.9.7-r3.ebuild:
Fix broken autotools handling.
diff --git a/sys-fs/lufs/files/lufs-0.9.7-gcc43.patch b/sys-fs/lufs/files/lufs-0.9.7-gcc43.patch
new file mode 100644
index 000000000000..3736ba62b017
--- /dev/null
+++ b/sys-fs/lufs/files/lufs-0.9.7-gcc43.patch
@@ -0,0 +1,33 @@
+--- filesystems/ftpfs/ftplib.cpp.orig 2008-06-08 20:01:35.000000000 +0200
++++ filesystems/ftpfs/ftplib.cpp 2008-06-08 20:01:53.000000000 +0200
+@@ -20,6 +20,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <cstring>
+ #include <unistd.h>
+ #include <netdb.h>
+ #include <stdio.h>
+--- filesystems/ftpfs/ftpfs.h.orig 2008-06-08 20:04:33.000000000 +0200
++++ filesystems/ftpfs/ftpfs.h 2008-06-08 20:05:07.000000000 +0200
+@@ -23,6 +23,8 @@
+ #ifndef _FTPFS_H_
+ #define _FTPFS_H_
+
++#include <cstdlib>
++#include <cstring>
+ using namespace std;
+
+ struct directory;
+--- filesystems/sshfs/sftplib.h.orig 2008-06-08 20:08:55.000000000 +0200
++++ filesystems/sshfs/sftplib.h 2008-06-08 20:09:43.000000000 +0200
+@@ -28,6 +28,9 @@
+
+ #include <string>
+
++#include <cstring>
++#include <cstdlib>
++
+ using namespace std;
+
+ #define MAXDATA 32768
diff --git a/sys-fs/lufs/lufs-0.9.7-r3.ebuild b/sys-fs/lufs/lufs-0.9.7-r3.ebuild
index 799318a77334..2fee4141c9fa 100644
--- a/sys-fs/lufs/lufs-0.9.7-r3.ebuild
+++ b/sys-fs/lufs/lufs-0.9.7-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/lufs-0.9.7-r3.ebuild,v 1.9 2007/01/04 18:25:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/lufs-0.9.7-r3.ebuild,v 1.10 2008/06/29 12:20:55 loki_val Exp $
WANT_AUTOMAKE="latest"
WANT_AUTOCONF="latest"
@@ -15,18 +15,20 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc ~amd64"
IUSE="debug"
-DEPEND="sys-fs/lufis
- sys-devel/automake
- sys-devel/autoconf"
+RDEPEND="sys-fs/lufis"
+DEPEND="${RDEPEND}
+ sys-devel/automake
+ sys-devel/autoconf"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/${P}-fPIC.patch
- epatch ${FILESDIR}/lufs-automount-port.diff
- epatch ${FILESDIR}/${P}-enable-gnome-2.patch
- epatch ${FILESDIR}/lufs-no-kernel.patch
+ epatch "${FILESDIR}"/${P}-fPIC.patch
+ epatch "${FILESDIR}"/lufs-automount-port.diff
+ epatch "${FILESDIR}"/${P}-enable-gnome-2.patch
+ epatch "${FILESDIR}"/lufs-no-kernel.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
filesystems="ftpfs localfs sshfs"
useq amd64 && filesystems="ftpfs localfs"
@@ -53,7 +55,7 @@ src_install() {
for i in ${filesystems}
do
cd ${i}
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
cd ..
done
}