summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-30 02:33:49 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-30 02:33:49 +0000
commit864b475f349b74bc63de2a3799856845c5569610 (patch)
tree9975dbc459d05aaf88e24a8a6d5ab5ab1fdc5349 /sys-fs/quota
parentStable on alpha, bug 71595. (Manifest recommit) (diff)
downloadgentoo-2-864b475f349b74bc63de2a3799856845c5569610.tar.gz
gentoo-2-864b475f349b74bc63de2a3799856845c5569610.tar.bz2
gentoo-2-864b475f349b74bc63de2a3799856845c5569610.zip
Dont install files owned by glibc #70938 by Jakub Moc and make sure we respect USE=-nls #44539 by Johan Petersson.
Diffstat (limited to 'sys-fs/quota')
-rw-r--r--sys-fs/quota/ChangeLog6
-rw-r--r--sys-fs/quota/quota-3.12.ebuild23
2 files changed, 19 insertions, 10 deletions
diff --git a/sys-fs/quota/ChangeLog b/sys-fs/quota/ChangeLog
index e690050ee4e1..d420cbe8b95c 100644
--- a/sys-fs/quota/ChangeLog
+++ b/sys-fs/quota/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/quota
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.2 2004/10/03 20:46:07 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.3 2004/11/30 02:33:49 vapier Exp $
+
+ 29 Nov 2004; Mike Frysinger <vapier@gentoo.org> quota-3.12.ebuild:
+ Dont install files owned by glibc #70938 by Jakub Moc and make sure we
+ respect USE=-nls #44539 by Johan Petersson.
*quota-3.12 (03 Oct 2004)
diff --git a/sys-fs/quota/quota-3.12.ebuild b/sys-fs/quota/quota-3.12.ebuild
index c6be2604072f..7f648ee0073b 100644
--- a/sys-fs/quota/quota-3.12.ebuild
+++ b/sys-fs/quota/quota-3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.12.ebuild,v 1.1 2004/10/03 10:28:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.12.ebuild,v 1.2 2004/11/30 02:33:49 vapier Exp $
inherit eutils
@@ -13,8 +13,10 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
IUSE="nls tcpd"
-DEPEND="virtual/libc
+RDEPEND="virtual/libc
tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
S=${WORKDIR}/quota-tools
@@ -29,20 +31,23 @@ src_unpack() {
sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
}
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
src_install() {
dodir {sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,3,8}}
- make ROOTDIR=${D} install || die
-# install -m 644 warnquota.conf ${D}/etc
+ make ROOTDIR="${D}" install || die
+ rm -r "${D}"/usr/include #70938
+
insinto /etc
insopts -m0644
doins warnquota.conf quotatab
- dodoc doc/*
- exeinto /etc/init.d
- newexe ${FILESDIR}/quota.rc6 quota
+ dodoc doc/*
- # NLS bloat reduction
- use nls || rm -rf ${D}/usr/share/locale
+ newinitd ${FILESDIR}/quota.rc6 quota
}
pkg_postinst() {