summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-06-05 21:09:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-06-05 21:09:22 +0000
commitc0d0048c9941665e20b7a075a9d6ac745eeadfca (patch)
tree9268f168a8fc6607f17d9a568015a05ee46cee66 /sys-fs/udev/udev-149.ebuild
parentVersion bump, keyworded amd64 (diff)
downloadgentoo-2-c0d0048c9941665e20b7a075a9d6ac745eeadfca.tar.gz
gentoo-2-c0d0048c9941665e20b7a075a9d6ac745eeadfca.tar.bz2
gentoo-2-c0d0048c9941665e20b7a075a9d6ac745eeadfca.zip
Linux-3.0 support for udev version checks.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/udev/udev-149.ebuild')
-rw-r--r--sys-fs/udev/udev-149.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-fs/udev/udev-149.ebuild b/sys-fs/udev/udev-149.ebuild
index 5e5ebfeedfe3..009b566b98ef 100644
--- a/sys-fs/udev/udev-149.ebuild
+++ b/sys-fs/udev/udev-149.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-149.ebuild,v 1.17 2011/04/15 21:55:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-149.ebuild,v 1.18 2011/06/05 21:09:22 robbat2 Exp $
EAPI="1"
@@ -63,9 +63,13 @@ fi
# required kernel options
CONFIG_CHECK="~INOTIFY_USER ~SIGNALFD ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2"
+# Return values:
+# 2 - reliable
+# 1 - unreliable
+# 0 - too old
udev_check_KV() {
local ok=0
- if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]]
+ if [[ ${KV_MAJOR} == 2 && ${KV_MINOR} == 6 ]] || [[ ${KV_MAJOR} == 3 ]]
then
if kernel_is -ge 2 6 ${KV_PATCH_reliable} ; then
ok=2