summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-11-19 21:20:02 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-11-19 21:20:02 +0000
commit0215e2d0acbe1e8c4e94dd9a242a2bf85133842d (patch)
tree0221f556e646273bd8c114d3b0f7d0e1c5b16b74 /sys-fs/udev
parent~mips keyworded, bug #189262 (diff)
downloadgentoo-2-0215e2d0acbe1e8c4e94dd9a242a2bf85133842d.tar.gz
gentoo-2-0215e2d0acbe1e8c4e94dd9a242a2bf85133842d.tar.bz2
gentoo-2-0215e2d0acbe1e8c4e94dd9a242a2bf85133842d.zip
No longer change Makefiles and call eautoreconf just to change install location. Now just move the files after make install. Also drop libtool parameter change in makefile.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r1 i686)
Diffstat (limited to 'sys-fs/udev')
-rw-r--r--sys-fs/udev/ChangeLog7
-rw-r--r--sys-fs/udev/udev-133.ebuild17
2 files changed, 14 insertions, 10 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index 787a0903de99..5d73ef355e8d 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.417 2008/11/19 19:41:22 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.418 2008/11/19 21:20:02 zzam Exp $
+
+ 19 Nov 2008; Matthias Schwarzott <zzam@gentoo.org> udev-133.ebuild:
+ No longer change Makefiles and call eautoreconf just to change install
+ location. Now just move the files after make install. Also drop libtool
+ parameter change in makefile.
*udev-133 (19 Nov 2008)
diff --git a/sys-fs/udev/udev-133.ebuild b/sys-fs/udev/udev-133.ebuild
index 04c59dc620ba..4bc9e21f1ce3 100644
--- a/sys-fs/udev/udev-133.ebuild
+++ b/sys-fs/udev/udev-133.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-133.ebuild,v 1.1 2008/11/19 19:41:22 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-133.ebuild,v 1.2 2008/11/19 21:20:02 zzam Exp $
-inherit eutils flag-o-matic multilib toolchain-funcs versionator autotools
+inherit eutils flag-o-matic multilib toolchain-funcs versionator
DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
@@ -87,13 +87,7 @@ src_unpack() {
extras/rule_generator/write_*_rules \
udev/udev-util.c \
udev/udev-rules.c \
- udev/udevd.c \
- $(find -name "Makefile.*") || die "sed failed"
-
- # fix version of volume_id lib
- sed -e 's/-version-info/-version-number/' -i extras/volume_id/lib/Makefile.am
-
- eautoreconf
+ udev/udevd.c || die "sed failed"
}
src_compile() {
@@ -115,6 +109,11 @@ src_compile() {
src_install() {
into /
emake DESTDIR="${D}" install || die "make install failed"
+ if [[ "$(get_libdir)" != "lib" ]]; then
+ mkdir -p "${D}/$(get_libdir)"
+ mv "${D}"/lib/* "${D}/$(get_libdir)/"
+ rmdir "${D}"/lib
+ fi
exeinto "${udev_helper_dir}"
newexe "${FILESDIR}"/net-130-r1.sh net.sh || die "net.sh not installed properly"