summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMalcolm Lashley <malc@gentoo.org>2005-08-17 17:59:42 +0000
committerMalcolm Lashley <malc@gentoo.org>2005-08-17 17:59:42 +0000
commitac42fc44a95050acb3f74922e947fbefcafc6709 (patch)
tree4ea10d7c913085a09fd47aebf8508ba662491ced /sys-fs/unionfs
parentUpdated the multilib patch for 2.8, bug 101289 (diff)
downloadgentoo-2-ac42fc44a95050acb3f74922e947fbefcafc6709.tar.gz
gentoo-2-ac42fc44a95050acb3f74922e947fbefcafc6709.tar.bz2
gentoo-2-ac42fc44a95050acb3f74922e947fbefcafc6709.zip
#102782 fix broken patch, add non-broken amd64 patch :)
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-fs/unionfs')
-rw-r--r--sys-fs/unionfs/ChangeLog7
-rw-r--r--sys-fs/unionfs/Manifest11
-rw-r--r--sys-fs/unionfs/files/unionfs-1.0.13-amd64.patch21
-rw-r--r--sys-fs/unionfs/unionfs-1.0.13.ebuild5
4 files changed, 35 insertions, 9 deletions
diff --git a/sys-fs/unionfs/ChangeLog b/sys-fs/unionfs/ChangeLog
index dd982f3e6bb2..2d5024f2385d 100644
--- a/sys-fs/unionfs/ChangeLog
+++ b/sys-fs/unionfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/unionfs
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.14 2005/08/11 08:59:26 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.15 2005/08/17 17:59:42 malc Exp $
+
+ 17 Aug 2005; Malcolm Lashley <malc@gentoo.org>
+ +files/unionfs-1.0.13-amd64.patch, unionfs-1.0.13.ebuild:
+ #102782 - remove patch which is no longer required, add new general patch to
+ fix typecasting in debug statements on amd64
*unionfs-1.0.13 (11 Aug 2005)
diff --git a/sys-fs/unionfs/Manifest b/sys-fs/unionfs/Manifest
index 60cc9798817c..a9f6bbb5ee8f 100644
--- a/sys-fs/unionfs/Manifest
+++ b/sys-fs/unionfs/Manifest
@@ -1,10 +1,11 @@
-MD5 1ff5f88f02335771fec32a90579f38a6 unionfs-1.0.12a.ebuild 1358
-MD5 376c326368cd6cadf7e6b0ded8e03eb8 unionfs-1.0.11.ebuild 1341
-MD5 cba4a50c147dbfa64c95661011664193 unionfs-1.0.13.ebuild 1377
MD5 dd20e8d2489c0a72a70b7269cb7eb0e7 ChangeLog 2827
MD5 6e89ba8198764bfd079a0cfa18dca593 metadata.xml 264
-MD5 a437f2bf3da231ea3a2a2835949d3a37 files/digest-unionfs-1.0.12a 67
+MD5 069eabb152618ab69b86dd2e9012ac29 unionfs-1.0.13.ebuild 1353
+MD5 1ff5f88f02335771fec32a90579f38a6 unionfs-1.0.12a.ebuild 1358
+MD5 376c326368cd6cadf7e6b0ded8e03eb8 unionfs-1.0.11.ebuild 1341
+MD5 733bc242378499ba766283fa6441f5cb files/unionfs-1.0.13-amd64.patch 685
+MD5 c2f37c6131dd9b96868aa3762fa444be files/digest-unionfs-1.0.13 66
MD5 f0868138a13d17e35615d074edc5f5d3 files/unionfs-1.0.13-delbranch-fix.patch 356
+MD5 a437f2bf3da231ea3a2a2835949d3a37 files/digest-unionfs-1.0.12a 67
MD5 2410ef6f38ddf9737cbb13bfe0325c9a files/digest-unionfs-1.0.11 66
-MD5 c2f37c6131dd9b96868aa3762fa444be files/digest-unionfs-1.0.13 66
MD5 f9a155123bfab53c81cb6c454492b797 files/unionfs-1.0.11-amd64.patch 586
diff --git a/sys-fs/unionfs/files/unionfs-1.0.13-amd64.patch b/sys-fs/unionfs/files/unionfs-1.0.13-amd64.patch
new file mode 100644
index 000000000000..f88b76e03164
--- /dev/null
+++ b/sys-fs/unionfs/files/unionfs-1.0.13-amd64.patch
@@ -0,0 +1,21 @@
+diff -Naur unionfs-1.0.13_orig/unionimap.c unionfs-1.0.13/unionimap.c
+--- unionfs-1.0.13_orig/unionimap.c 2005-07-22 18:16:48.000000000 +0100
++++ unionfs-1.0.13/unionimap.c 2005-08-17 18:01:10.000000000 +0100
+@@ -244,7 +244,7 @@
+ "Lower-Level");
+ while (read(file, (void *)&entry, sizeof(struct fmapent))) {
+ fprintf(stdout, "%-11lu %-8d %-22llu\n", inode++,
+- entry.fsnum, entry.inode);
++ entry.fsnum, (long long unsigned int) entry.inode);
+ }
+ }
+ out:
+@@ -293,7 +293,7 @@
+ unsigned long lowerlevel = 0;
+ if (inode) {
+ fprintf(stdout, "%-11lu %-22llu\n",
+- lowerlevel++, inode);
++ lowerlevel++, (long long unsigned int) inode);
+ }
+ }
+ }
diff --git a/sys-fs/unionfs/unionfs-1.0.13.ebuild b/sys-fs/unionfs/unionfs-1.0.13.ebuild
index 7eeca81e07a7..c4a1a26711aa 100644
--- a/sys-fs/unionfs/unionfs-1.0.13.ebuild
+++ b/sys-fs/unionfs/unionfs-1.0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.0.13.ebuild,v 1.1 2005/08/11 08:59:26 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.0.13.ebuild,v 1.2 2005/08/17 17:59:42 malc Exp $
inherit eutils linux-mod
@@ -26,8 +26,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-delbranch-fix.patch
-
- use amd64 && epatch ${FILESDIR}/unionfs-1.0.11-amd64.patch
+ epatch ${FILESDIR}/${P}-amd64.patch
if ! use debug; then
echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}