summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-01-07 19:19:39 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-01-07 19:19:39 +0000
commitb047974e5eb681f31a440c24bc6179f8a967d6ea (patch)
tree10b68734965d07b7a70057b3613650fad4f440a6 /sys-fs/unionfs
parentFixed built_with_use_error() internal function name, closing bug #160651. Rem... (diff)
downloadgentoo-2-b047974e5eb681f31a440c24bc6179f8a967d6ea.tar.gz
gentoo-2-b047974e5eb681f31a440c24bc6179f8a967d6ea.tar.bz2
gentoo-2-b047974e5eb681f31a440c24bc6179f8a967d6ea.zip
Bump for a 2.6.19-compatible snapshot.
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'sys-fs/unionfs')
-rw-r--r--sys-fs/unionfs/ChangeLog10
-rw-r--r--sys-fs/unionfs/files/digest-unionfs-1.5_pre2007010423083
-rw-r--r--sys-fs/unionfs/unionfs-1.5_pre200701042308.ebuild86
3 files changed, 97 insertions, 2 deletions
diff --git a/sys-fs/unionfs/ChangeLog b/sys-fs/unionfs/ChangeLog
index c9f6b4cf279c..40ce7fdfd4b2 100644
--- a/sys-fs/unionfs/ChangeLog
+++ b/sys-fs/unionfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/unionfs
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.28 2006/11/22 19:53:22 dberkholz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.29 2007/01/07 19:19:39 dberkholz Exp $
+
+*unionfs-1.5_pre200701042308 (07 Jan 2007)
+
+ 07 Jan 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +unionfs-1.5_pre200701042308.ebuild:
+ Bump for a 2.6.19-compatible snapshot.
*unionfs-1.4 (22 Nov 2006)
diff --git a/sys-fs/unionfs/files/digest-unionfs-1.5_pre200701042308 b/sys-fs/unionfs/files/digest-unionfs-1.5_pre200701042308
new file mode 100644
index 000000000000..348a90279dfa
--- /dev/null
+++ b/sys-fs/unionfs/files/digest-unionfs-1.5_pre200701042308
@@ -0,0 +1,3 @@
+MD5 89d736859e5547db1384229160ad5410 unionfs-1.5pre-cvs200701042308.tar.gz 163418
+RMD160 6d54be6db26a562dd943df2de9cf0e0138c45c6f unionfs-1.5pre-cvs200701042308.tar.gz 163418
+SHA256 d1925eee22517df72828a7c75890c20a54335e135f6ed04ea43f8771c9b1c271 unionfs-1.5pre-cvs200701042308.tar.gz 163418
diff --git a/sys-fs/unionfs/unionfs-1.5_pre200701042308.ebuild b/sys-fs/unionfs/unionfs-1.5_pre200701042308.ebuild
new file mode 100644
index 000000000000..3be6ffb46a85
--- /dev/null
+++ b/sys-fs/unionfs/unionfs-1.5_pre200701042308.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.5_pre200701042308.ebuild,v 1.1 2007/01/07 19:19:39 dberkholz Exp $
+
+inherit eutils linux-mod
+
+MY_PV="${PV/_pre/pre-cvs}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
+HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
+if [[ ${PV} = *pre* ]]; then
+ SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/snapshots/${MY_P}.tar.gz"
+else
+ SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/${MY_P}.tar.gz"
+fi
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="acl debug nfs"
+
+S="${WORKDIR}/${MY_P}"
+
+local_version_info() {
+ ewarn
+ ewarn "you need the proper kernel version!"
+ ewarn
+ einfo "kernel: 2.4.x (x>19) Version: 1.0.14"
+ einfo "kernel: 2.6.x (x<9) Version: Not Supported"
+ einfo "kernel: 2.6.9 - 2.6.15 Version: 1.1.5"
+ einfo "kernel: 2.6.16 Version: 1.2"
+ einfo "kernel: 2.6.17 Version: 1.3"
+ einfo "kernel: 2.6.18 Version: 1.4"
+ einfo "kernel: 2.6.19 Version: 1.5"
+}
+
+pkg_setup() {
+ # kernel version check
+ if ! kernel_is eq 2 6 19; then
+ local_version_info
+ die
+ fi
+
+ linux-mod_pkg_setup
+
+ MODULE_NAMES="unionfs(kernel/fs/${PN}:)"
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
+}
+
+src_unpack() {
+ local user_Makefile=fistdev.mk EXTRACFLAGS=""
+
+ unpack ${A}
+ cd ${S}
+
+ if ! use debug; then
+ echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
+ EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_NDEBUG"
+ fi
+
+ if use acl; then
+ EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR" # -DFIST_SETXATTR_CONSTVOID"
+ elif use nfs; then
+ EXTRACFLAGS="${EXTRACFLAGS} -DNFS_SECURITY_HOLE"
+ fi
+
+ echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
+ einfo EXTRACFLAGS: ${EXTRACFLAGS}
+
+ echo "UNIONFS_OPT_CFLAG=${CFLAGS}" >> ${user_Makefile}
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc INSTALL NEWS README ChangeLog patch-kernel.sh
+
+ emake \
+ PREFIX="${D}" \
+ MANDIR="${D}/usr/share/man" \
+ install-utils # Makefile is bugged
+ #doman man/unionfs.4 man/unionctl.8 man/uniondbg.8 man/unionimap.8
+ #into / # ${D}/sbin: usr could be unionfs mounted: bug #129960
+ #dosbin utils/unionctl utils/uniondbg utils/unionimap
+}
+