summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2013-07-14 12:16:09 +0000
committerRichard Yao <ryao@gentoo.org>2013-07-14 12:16:09 +0000
commite745317f72522e27025c67aa4614856f6a0ff3e1 (patch)
tree9b82aeed6f16a78f4535ddacdb725ffc423024bb /sys-fs/zfs
parentuse subslot operator for boost (diff)
downloadgentoo-2-e745317f72522e27025c67aa4614856f6a0ff3e1.tar.gz
gentoo-2-e745317f72522e27025c67aa4614856f6a0ff3e1.tar.bz2
gentoo-2-e745317f72522e27025c67aa4614856f6a0ff3e1.zip
Add modification to systemd init file: use RemainAfterExit=yes instead of true
(Portage version: 2.2.0_alpha187/cvs/Linux x86_64, signed Manifest commit with key 0xBEE84C64)
Diffstat (limited to 'sys-fs/zfs')
-rw-r--r--sys-fs/zfs/ChangeLog9
-rw-r--r--sys-fs/zfs/files/zfs.service.in2
-rw-r--r--sys-fs/zfs/zfs-0.6.1-r1.ebuild132
-rw-r--r--sys-fs/zfs/zfs-0.6.1-r3.ebuild (renamed from sys-fs/zfs/zfs-0.6.1-r2.ebuild)2
-rw-r--r--sys-fs/zfs/zfs-0.6.1.ebuild124
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild11
6 files changed, 20 insertions, 260 deletions
diff --git a/sys-fs/zfs/ChangeLog b/sys-fs/zfs/ChangeLog
index 47bfedcaac7e..0adb9497b239 100644
--- a/sys-fs/zfs/ChangeLog
+++ b/sys-fs/zfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/zfs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/ChangeLog,v 1.66 2013/07/14 11:52:50 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/ChangeLog,v 1.67 2013/07/14 12:16:09 ryao Exp $
+
+*zfs-0.6.1-r3 (14 Jul 2013)
+
+ 14 Jul 2013; Richard Yao <ryao@gentoo.org> +zfs-0.6.1-r3.ebuild,
+ -zfs-0.6.1-r1.ebuild, -zfs-0.6.1-r2.ebuild, -zfs-0.6.1.ebuild,
+ files/zfs.service.in, zfs-9999.ebuild:
+ Add modification to systemd init file: use RemainAfterExit=yes instead of true
*zfs-0.6.1-r2 (14 Jul 2013)
diff --git a/sys-fs/zfs/files/zfs.service.in b/sys-fs/zfs/files/zfs.service.in
index 4e510a8f4d21..c390a480708e 100644
--- a/sys-fs/zfs/files/zfs.service.in
+++ b/sys-fs/zfs/files/zfs.service.in
@@ -5,7 +5,7 @@ After=systemd-udev-settle.target local-fs.target
[Service]
Type=oneshot
-RemainAfterExit=true
+RemainAfterExit=yes
ExecStartPre=/sbin/modprobe zfs
ExecStartPre=/usr/bin/test -c /dev/zfs
ExecStart=/usr/libexec/zfs-init.sh
diff --git a/sys-fs/zfs/zfs-0.6.1-r1.ebuild b/sys-fs/zfs/zfs-0.6.1-r1.ebuild
deleted file mode 100644
index 8d5ae020fae0..000000000000
--- a/sys-fs/zfs/zfs-0.6.1-r1.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-0.6.1-r1.ebuild,v 1.2 2013/05/29 01:12:58 ryao Exp $
-
-EAPI="4"
-
-AT_M4DIR="config"
-AUTOTOOLS_AUTORECONF="1"
-AUTOTOOLS_IN_SOURCE_BUILD="1"
-
-if [ ${PV} == "9999" ] ; then
- inherit git-2 linux-mod
- EGIT_REPO_URI="git://github.com/zfsonlinux/${PN}.git"
-else
- inherit eutils versionator
- MY_PV=$(replace_version_separator 3 '-')
- SRC_URI="https://github.com/zfsonlinux/${PN}/archive/${PN}-${MY_PV}.tar.gz"
- S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
- KEYWORDS="~amd64"
-fi
-
-inherit bash-completion-r1 flag-o-matic toolchain-funcs autotools-utils udev
-
-DESCRIPTION="Userland utilities for ZFS Linux kernel module"
-HOMEPAGE="http://zfsonlinux.org/"
-
-LICENSE="BSD-2 CDDL MIT"
-SLOT="0"
-IUSE="bash-completion custom-cflags kernel-builtin +rootfs selinux test-suite static-libs"
-RESTRICT="test"
-
-COMMON_DEPEND="
- selinux? ( sys-libs/libselinux )
- sys-apps/util-linux[static-libs?]
- sys-libs/zlib[static-libs(+)?]
- virtual/awk
-"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
-"
-
-RDEPEND="${COMMON_DEPEND}
- !=sys-apps/grep-2.13*
- !kernel-builtin? ( =sys-fs/zfs-kmod-${PV}* )
- !sys-fs/zfs-fuse
- !prefix? ( virtual/udev )
- test-suite? (
- sys-apps/util-linux
- sys-devel/bc
- sys-block/parted
- sys-fs/lsscsi
- sys-fs/mdadm
- sys-process/procps
- virtual/modutils
- )
- rootfs? (
- app-arch/cpio
- app-misc/pax-utils
- !<sys-boot/grub-2.00-r2:2
- )
-"
-
-pkg_setup() {
- :
-}
-
-src_prepare() {
- if [ ${PV} != "9999" ]
- then
- # Fix OpenRC dependencies
- epatch "${FILESDIR}/${P}-gentoo-openrc-dependencies.patch"
- fi
-
- # Update paths
- sed -e "s|/sbin/lsmod|/bin/lsmod|" \
- -e "s|/usr/bin/scsi-rescan|/usr/sbin/rescan-scsi-bus|" \
- -e "s|/sbin/parted|/usr/sbin/parted|" \
- -i scripts/common.sh.in
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- use custom-cflags || strip-flags
- local myeconfargs=(
- --bindir="${EPREFIX}/bin"
- --sbindir="${EPREFIX}/sbin"
- --with-config=user
- --with-linux="${KV_DIR}"
- --with-linux-obj="${KV_OUT_DIR}"
- --with-udevdir="$(udev_get_udevdir)"
- $(use_with selinux)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
- gen_usr_ldscript -a uutil nvpair zpool zfs
- rm -rf "${ED}usr/lib/dracut"
- use test-suite || rm -rf "${ED}usr/share/zfs"
-
- use bash-completion && newbashcomp "${FILESDIR}/bash-completion" zfs
-
-}
-
-pkg_postinst() {
-
- if ! use kernel-builtin && [ ${PV} = "9999" ]
- then
- einfo "Adding ${P} to the module database to ensure that the"
- einfo "kernel modules and userland utilities stay in sync."
- update_moduledb
- fi
-
- [ -e "${EROOT}/etc/runlevels/boot/zfs" ] \
- || ewarn 'You should add zfs to the boot runlevel.'
-
- if [ -e "${EROOT}/etc/runlevels/shutdown/zfs-shutdown" ]
- then
- einfo "The zfs-shutdown script is obsolete. Removing it from runlevel."
- rm "${EROOT}/etc/runlevels/shutdown/zfs-shutdown"
- fi
-
-}
-
-pkg_postrm() {
- if ! use kernel-builtin && [ ${PV} = "9999" ]
- then
- remove_moduledb
- fi
-}
diff --git a/sys-fs/zfs/zfs-0.6.1-r2.ebuild b/sys-fs/zfs/zfs-0.6.1-r3.ebuild
index 3aef5bcc5f8e..f3ac208b7d73 100644
--- a/sys-fs/zfs/zfs-0.6.1-r2.ebuild
+++ b/sys-fs/zfs/zfs-0.6.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-0.6.1-r2.ebuild,v 1.1 2013/07/14 11:52:50 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-0.6.1-r3.ebuild,v 1.1 2013/07/14 12:16:09 ryao Exp $
EAPI="4"
diff --git a/sys-fs/zfs/zfs-0.6.1.ebuild b/sys-fs/zfs/zfs-0.6.1.ebuild
deleted file mode 100644
index 8beaa09e191c..000000000000
--- a/sys-fs/zfs/zfs-0.6.1.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-0.6.1.ebuild,v 1.1 2013/03/28 22:19:57 ryao Exp $
-
-EAPI="4"
-
-AT_M4DIR="config"
-AUTOTOOLS_AUTORECONF="1"
-AUTOTOOLS_IN_SOURCE_BUILD="1"
-
-if [ ${PV} == "9999" ] ; then
- inherit git-2 linux-mod
- EGIT_REPO_URI="git://github.com/zfsonlinux/${PN}.git"
-else
- inherit eutils versionator
- MY_PV=$(replace_version_separator 3 '-')
- SRC_URI="https://github.com/zfsonlinux/${PN}/archive/${PN}-${MY_PV}.tar.gz"
- S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
- KEYWORDS="~amd64"
-fi
-
-inherit bash-completion-r1 flag-o-matic toolchain-funcs autotools-utils udev
-
-DESCRIPTION="Userland utilities for ZFS Linux kernel module"
-HOMEPAGE="http://zfsonlinux.org/"
-
-LICENSE="BSD-2 CDDL MIT"
-SLOT="0"
-IUSE="custom-cflags kernel-builtin +rootfs test-suite static-libs"
-RESTRICT="test"
-
-COMMON_DEPEND="
- sys-apps/util-linux[static-libs?]
- sys-libs/zlib[static-libs(+)?]
- virtual/awk
-"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
-"
-
-RDEPEND="${COMMON_DEPEND}
- !=sys-apps/grep-2.13*
- !kernel-builtin? ( =sys-fs/zfs-kmod-${PV}* )
- !sys-fs/zfs-fuse
- !prefix? ( virtual/udev )
- test-suite? (
- sys-apps/util-linux
- sys-devel/bc
- sys-block/parted
- sys-fs/lsscsi
- sys-fs/mdadm
- sys-process/procps
- virtual/modutils
- )
- rootfs? (
- app-arch/cpio
- app-misc/pax-utils
- !<sys-boot/grub-2.00-r2:2
- )
-"
-
-pkg_setup() {
- :
-}
-
-src_prepare() {
- # Update paths
- sed -e "s|/sbin/lsmod|/bin/lsmod|" \
- -e "s|/usr/bin/scsi-rescan|/usr/sbin/rescan-scsi-bus|" \
- -e "s|/sbin/parted|/usr/sbin/parted|" \
- -i scripts/common.sh.in
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- use custom-cflags || strip-flags
- local myeconfargs=(
- --bindir="${EPREFIX}/bin"
- --sbindir="${EPREFIX}/sbin"
- --with-config=user
- --with-linux="${KV_DIR}"
- --with-linux-obj="${KV_OUT_DIR}"
- --with-udevdir="$(udev_get_udevdir)"
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
- gen_usr_ldscript -a uutil nvpair zpool zfs
- rm -rf "${ED}usr/share/dracut"
- use test-suite || rm -rf "${ED}usr/libexec"
-
- newbashcomp "${FILESDIR}/bash-completion" zfs
-
-}
-
-pkg_postinst() {
-
- if ! use kernel-builtin && [ ${PV} = "9999" ]
- then
- einfo "Adding ${P} to the module database to ensure that the"
- einfo "kernel modules and userland utilities stay in sync."
- update_moduledb
- fi
-
- [ -e "${EROOT}/etc/runlevels/boot/zfs" ] \
- || ewarn 'You should add zfs to the boot runlevel.'
-
- if [ -e "${EROOT}/etc/runlevels/shutdown/zfs-shutdown" ]
- then
- einfo "The zfs-shutdown script is obsolete. Removing it from runlevel."
- rm "${EROOT}/etc/runlevels/shutdown/zfs-shutdown"
- fi
-
-}
-
-pkg_postrm() {
- if ! use kernel-builtin && [ ${PV} = "9999" ]
- then
- remove_moduledb
- fi
-}
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index 8195b497c509..958855de5461 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-9999.ebuild,v 1.45 2013/07/14 11:52:50 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-9999.ebuild,v 1.46 2013/07/14 12:16:09 ryao Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
@@ -72,6 +72,15 @@ src_prepare() {
then
# Fix OpenRC dependencies
epatch "${FILESDIR}/${P}-gentoo-openrc-dependencies.patch"
+
+ # Make zvol initialization asynchronous
+ epatch "${FILESDIR}/${P}-fix-zvol-initialization-r1.patch"
+
+ # Use MAXPATHLEN to silence GCC 4.8 warning
+ epatch "${FILESDIR}/${P}-fix-gcc-4.8-warning.patch"
+
+ # Avoid zdb abort
+ epatch "${FILESDIR}/${P}-avoid-zdb-abort.patch"
fi
# Update paths