summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-12-06 16:14:52 +0000
committerJustin Lecher <jlec@gentoo.org>2011-12-06 16:14:52 +0000
commit152f51daa27eae04a61fede0dd93d7cdc6e07584 (patch)
tree031e5f2f0a33b5989d20d90c33272c84afbef8ec /sys-fs
parentDrop zlib dep from system since pkgs pull it in as needed. (diff)
downloadgentoo-2-152f51daa27eae04a61fede0dd93d7cdc6e07584.tar.gz
gentoo-2-152f51daa27eae04a61fede0dd93d7cdc6e07584.tar.bz2
gentoo-2-152f51daa27eae04a61fede0dd93d7cdc6e07584.zip
Version Bump
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cachefilesd/ChangeLog7
-rw-r--r--sys-fs/cachefilesd/cachefilesd-0.10.5.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-fs/cachefilesd/ChangeLog b/sys-fs/cachefilesd/ChangeLog
index 8d3512690fbe..815eee6fc613 100644
--- a/sys-fs/cachefilesd/ChangeLog
+++ b/sys-fs/cachefilesd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/cachefilesd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cachefilesd/ChangeLog,v 1.4 2011/12/01 13:04:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cachefilesd/ChangeLog,v 1.5 2011/12/06 16:14:52 jlec Exp $
+
+*cachefilesd-0.10.5 (06 Dec 2011)
+
+ 06 Dec 2011; Justin Lecher <jlec@gentoo.org> +cachefilesd-0.10.5.ebuild:
+ Version Bump
*cachefilesd-0.10.4 (01 Dec 2011)
diff --git a/sys-fs/cachefilesd/cachefilesd-0.10.5.ebuild b/sys-fs/cachefilesd/cachefilesd-0.10.5.ebuild
new file mode 100644
index 000000000000..880a584bbb81
--- /dev/null
+++ b/sys-fs/cachefilesd/cachefilesd-0.10.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cachefilesd/cachefilesd-0.10.5.ebuild,v 1.1 2011/12/06 16:14:52 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Provides a caching directory on an already mounted filesystem"
+HOMEPAGE="http://people.redhat.com/~dhowells/fscache/"
+SRC_URI="http://people.redhat.com/~dhowells/fscache/${P}.tar.bz2 -> ${P}.tar"
+
+IUSE="doc selinux"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}"/0.10.4-makefile.patch
+ tc-export CC
+ if ! use selinux; then
+ sed -e '/^secctx/s:^:#:g' -i cachefilesd.conf || die
+ fi
+}
+
+src_install() {
+ default
+
+ if use selinux; then
+ insinto /usr/share/doc/${P}
+ doins -r selinux
+ fi
+
+ dodoc howto.txt
+
+ newconfd "${FILESDIR}"/cachefilesd.conf ${PN}
+ newinitd "${FILESDIR}"/cachefilesd.init ${PN}
+
+ keepdir /var/cache/fscache
+}
+
+pkg_postinst() {
+ [[ -d /var/cache/fscache ]] && return
+ elog "Before CacheFiles can be used, a directory for local storage"
+ elog "must be created. The default configuration of /etc/cachefilesd.conf"
+ elog "uses /var/cache/fscache. The filesystem mounted there must support"
+ elog "extended attributes (mount -o user_xattr)."
+ echo ""
+ elog "Once that is taken care of, start the daemon, add -o ...,fsc"
+ elog "to the mount options of your network mounts, and let it fly!"
+}