summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-03-07 09:17:36 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-03-07 09:17:36 +0000
commit186dc4b2c6d67b6b9217737ea2885a3f6298d15a (patch)
tree11846e55dd432f1269a4abb7396a715e9ba0503c /sys-fs
parentMinor syn, whitespace cleanup. (diff)
downloadgentoo-2-186dc4b2c6d67b6b9217737ea2885a3f6298d15a.tar.gz
gentoo-2-186dc4b2c6d67b6b9217737ea2885a3f6298d15a.tar.bz2
gentoo-2-186dc4b2c6d67b6b9217737ea2885a3f6298d15a.zip
Replaced our patch for bug #169623 with the one from debian.
(Portage version: 2.1.2-r10)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/evms/ChangeLog7
-rw-r--r--sys-fs/evms/evms-2.5.5-r5.ebuild4
-rw-r--r--sys-fs/evms/files/evms-2.5.5-pagesize.patch (renamed from sys-fs/evms/files/evms-2.5.5-getpagesize.patch)37
3 files changed, 28 insertions, 20 deletions
diff --git a/sys-fs/evms/ChangeLog b/sys-fs/evms/ChangeLog
index 60324beefb7b..0b9141d85f3f 100644
--- a/sys-fs/evms/ChangeLog
+++ b/sys-fs/evms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/evms
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/evms/ChangeLog,v 1.63 2007/03/06 23:17:45 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/evms/ChangeLog,v 1.64 2007/03/07 09:17:36 dev-zero Exp $
+
+ 07 Mar 2007; Tiziano Müller <dev-zero@gentoo.org>
+ -files/evms-2.5.5-getpagesize.patch, +files/evms-2.5.5-pagesize.patch,
+ evms-2.5.5-r5.ebuild:
+ Replaced our patch for bug #169623 with the one from debian.
06 Mar 2007; Tiziano Müller <dev-zero@gentoo.org>
+files/evms-2.5.5-getpagesize.patch, evms-2.5.5-r5.ebuild:
diff --git a/sys-fs/evms/evms-2.5.5-r5.ebuild b/sys-fs/evms/evms-2.5.5-r5.ebuild
index 0a94e3a64c0a..f4a6ff3b247f 100644
--- a/sys-fs/evms/evms-2.5.5-r5.ebuild
+++ b/sys-fs/evms/evms-2.5.5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/evms/evms-2.5.5-r5.ebuild,v 1.6 2007/03/06 23:17:45 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/evms/evms-2.5.5-r5.ebuild,v 1.7 2007/03/07 09:17:36 dev-zero Exp $
WANT_AUTOMAKE="latest"
WANT_AUTOCONF="latest"
@@ -46,7 +46,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-glib_dep.patch"
epatch "${FILESDIR}/${P}-ocfs2.patch"
epatch "${FILESDIR}/${P}-use_disk_group.patch"
- epatch "${FILESDIR}/${P}-getpagesize.patch"
+ epatch "${FILESDIR}/${P}-pagesize.patch"
eautoreconf
}
diff --git a/sys-fs/evms/files/evms-2.5.5-getpagesize.patch b/sys-fs/evms/files/evms-2.5.5-pagesize.patch
index 656d68429b39..7526247a9ca9 100644
--- a/sys-fs/evms/files/evms-2.5.5-getpagesize.patch
+++ b/sys-fs/evms/files/evms-2.5.5-pagesize.patch
@@ -1,6 +1,7 @@
-diff -Naur evms-2.5.5.orig/plugins/swap/swapfs.c evms-2.5.5/plugins/swap/swapfs.c
---- evms-2.5.5.orig/plugins/swap/swapfs.c 2007-03-06 23:14:01.000000000 +0100
-+++ evms-2.5.5/plugins/swap/swapfs.c 2007-03-06 23:14:54.000000000 +0100
+Index: evms-2.5.5/plugins/swap/swapfs.c
+===================================================================
+--- evms-2.5.5.orig/plugins/swap/swapfs.c
++++ evms-2.5.5/plugins/swap/swapfs.c
@@ -27,7 +27,6 @@
#include <plugin.h>
#include <fcntl.h>
@@ -9,47 +10,49 @@ diff -Naur evms-2.5.5.orig/plugins/swap/swapfs.c evms-2.5.5/plugins/swap/swapfs.
#include <sys/swap.h>
#include "swapfs.h"
-@@ -341,7 +340,7 @@
+@@ -341,7 +340,7 @@ static int swap_get_fs_limits(logical_vo
*max_volume_size = (sector_count_t)-1; /* No limit. */
*max_object_size = (sector_count_t)-1; /* No limit. */
- *min_size = (sector_count_t)(PAGE_SIZE * 10); /* 10 page minimum. */
-+ *min_size = (sector_count_t)(getpagesize() * 10); /* 10 page minimum. */
++ *min_size = (sector_count_t)(sysconf(_SC_PAGESIZE) * 10); /* 10 page minimum. */
LOG_EXTRA("Volume: %s, min: %"PRIu64", max: %"PRIu64"\n",
volume->name, *min_size, *max_volume_size);
-diff -Naur evms-2.5.5.orig/plugins/swap/swapfs.h evms-2.5.5/plugins/swap/swapfs.h
---- evms-2.5.5.orig/plugins/swap/swapfs.h 2007-03-06 23:14:01.000000000 +0100
-+++ evms-2.5.5/plugins/swap/swapfs.h 2007-03-06 23:14:42.000000000 +0100
-@@ -47,8 +47,8 @@
+Index: evms-2.5.5/plugins/swap/swapfs.h
+===================================================================
+--- evms-2.5.5.orig/plugins/swap/swapfs.h
++++ evms-2.5.5/plugins/swap/swapfs.h
+@@ -47,8 +47,8 @@ extern engine_functions_t *EngFncs;
#define PUT 1
#define SWAPFS_MAGIC_STRING "SWAP_SPACE"
#define SWAPFS_MAGIC_STRING2 "SWAPSPACE2"
-#define SWAPFS_MIN_SIZE (PAGE_SIZE / EVMS_VSECTOR_SIZE * 10)
-#define SWAP_MAGIC_OFFSET_IN_BYTES (PAGE_SIZE - 10) /* last 10 bytes of first page */
-+#define SWAPFS_MIN_SIZE (getpagesize() / EVMS_VSECTOR_SIZE * 10)
-+#define SWAP_MAGIC_OFFSET_IN_BYTES (getpagesize() - 10) /* last 10 bytes of first page */
++#define SWAPFS_MIN_SIZE (sysconf(_SC_PAGESIZE) / EVMS_VSECTOR_SIZE * 10)
++#define SWAP_MAGIC_OFFSET_IN_BYTES (sysconf(_SC_PAGESIZE) - 10) /* last 10 bytes of first page */
#define EVMS_Task_swapon EVMS_Task_Plugin_Function + 1
#define EVMS_Task_swapoff EVMS_Task_Plugin_Function + 2
-diff -Naur evms-2.5.5.orig/plugins/xfs/fsimxfs.h evms-2.5.5/plugins/xfs/fsimxfs.h
---- evms-2.5.5.orig/plugins/xfs/fsimxfs.h 2007-03-06 23:14:01.000000000 +0100
-+++ evms-2.5.5/plugins/xfs/fsimxfs.h 2007-03-06 23:16:00.000000000 +0100
+Index: evms-2.5.5/plugins/xfs/fsimxfs.h
+===================================================================
+--- evms-2.5.5.orig/plugins/xfs/fsimxfs.h
++++ evms-2.5.5/plugins/xfs/fsimxfs.h
@@ -19,7 +19,7 @@
*/
#include <uuid/uuid.h>
-#include <asm/page.h>
-+#include <unistd.h> /* for getpagesize() */
++#include <unistd.h>
extern plugin_record_t xfs_plugin_record;
extern plugin_record_t * my_plugin_record;
-@@ -165,7 +165,7 @@
+@@ -165,7 +165,7 @@ typedef struct xfs_volume {
* superblock. This is not the same as the superblock structure, since all of
* this space is not currently being used.
*/
-#define SIZE_OF_SUPER PAGE_SIZE
-+#define SIZE_OF_SUPER getpagesize()
++#define SIZE_OF_SUPER sysconf(_SC_PAGESIZE)
/* Fixed byte offset of primary superblock */
#define XFS_SUPER1_OFF 0x00