summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-05-16 19:19:07 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-05-16 19:19:07 +0000
commit32f43402ee5253897b28158354c0289e800e9702 (patch)
tree44638e65e0ef948dec5db056cf52456314390a2d /sys-fs
parentCleaning up older versions now that 3.1_p2 is stable everywhere. (diff)
downloadgentoo-2-32f43402ee5253897b28158354c0289e800e9702.tar.gz
gentoo-2-32f43402ee5253897b28158354c0289e800e9702.tar.bz2
gentoo-2-32f43402ee5253897b28158354c0289e800e9702.zip
Version bump and closing bug #175700. Thanks to Roman Zimmermann <mereandor@gmail.com> for pointing out a simpel copy would work.
(Portage version: 2.1.2.3)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools/ChangeLog9
-rw-r--r--sys-fs/squashfs-tools/files/digest-squashfs-tools-3.2_p23
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild35
3 files changed, 46 insertions, 1 deletions
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
index c99afbb01608..2f0907e1cf3e 100644
--- a/sys-fs/squashfs-tools/ChangeLog
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/squashfs-tools
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.49 2007/05/16 19:07:23 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.50 2007/05/16 19:19:07 wolf31o2 Exp $
+
+*squashfs-tools-3.2_p2 (16 May 2007)
+
+ 16 May 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ +squashfs-tools-3.2_p2.ebuild:
+ Version bump and closing bug #175700. Thanks to Roman Zimmermann
+ <mereandor@gmail.com> for pointing out a simpel copy would work.
16 May 2007; Chris Gianelloni <wolf31o2@gentoo.org>
-squashfs-tools-2.2_p2.ebuild, -squashfs-tools-3.0.ebuild,
diff --git a/sys-fs/squashfs-tools/files/digest-squashfs-tools-3.2_p2 b/sys-fs/squashfs-tools/files/digest-squashfs-tools-3.2_p2
new file mode 100644
index 000000000000..7847239d084a
--- /dev/null
+++ b/sys-fs/squashfs-tools/files/digest-squashfs-tools-3.2_p2
@@ -0,0 +1,3 @@
+MD5 bf360b92eba9e6d5610196ce2e02fcd1 squashfs3.2-r2.tar.gz 314764
+RMD160 6f21ad0ee90e4b5c6ad2b0b92c96d24af8e19531 squashfs3.2-r2.tar.gz 314764
+SHA256 8482465d58d78099c608b32fc034921f7c8c3cf7934b5edc68c463cd450b40a7 squashfs3.2-r2.tar.gz 314764
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
new file mode 100644
index 000000000000..bf7e298c8de6
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild,v 1.1 2007/05/16 19:19:07 wolf31o2 Exp $
+
+inherit toolchain-funcs
+
+MY_PV=${PV/_p/-r}
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+
+S=${WORKDIR}/squashfs${PV/_p/-r}/squashfs-tools
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s:-O2:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin mksquashfs unsquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README README-3.1
+}