summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2014-10-20 01:38:32 +0000
committerZac Medico <zmedico@gentoo.org>2014-10-20 01:38:32 +0000
commit5803613ccf24a39e115e80523eaa36e20d5a7805 (patch)
treeca6f10bceb1e3122f48b8968fbbcbfa3aa64d203 /sys-fs
parentnearly trivial version bump to fix user reported issue with writing wav file (diff)
downloadgentoo-2-5803613ccf24a39e115e80523eaa36e20d5a7805.tar.gz
gentoo-2-5803613ccf24a39e115e80523eaa36e20d5a7805.tar.bz2
gentoo-2-5803613ccf24a39e115e80523eaa36e20d5a7805.zip
0.4.0 version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xAE5719A3)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse-zip/ChangeLog9
-rw-r--r--sys-fs/fuse-zip/fuse-zip-0.4.0.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/sys-fs/fuse-zip/ChangeLog b/sys-fs/fuse-zip/ChangeLog
index ab2fa5bf8f93..09cac7a725bc 100644
--- a/sys-fs/fuse-zip/ChangeLog
+++ b/sys-fs/fuse-zip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse-zip
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-zip/ChangeLog,v 1.6 2013/08/13 18:40:16 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-zip/ChangeLog,v 1.7 2014/10/20 01:38:32 zmedico Exp $
+
+*fuse-zip-0.4.0 (20 Oct 2014)
+
+ 20 Oct 2014; Zac Medico <zmedico@gentoo.org> +fuse-zip-0.4.0.ebuild:
+ 0.4.0 version bump.
*fuse-zip-0.3.0 (13 Aug 2013)
diff --git a/sys-fs/fuse-zip/fuse-zip-0.4.0.ebuild b/sys-fs/fuse-zip/fuse-zip-0.4.0.ebuild
new file mode 100644
index 000000000000..6a5ce3c548f2
--- /dev/null
+++ b/sys-fs/fuse-zip/fuse-zip-0.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-zip/fuse-zip-0.4.0.ebuild,v 1.1 2014/10/20 01:38:32 zmedico Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="FUSE file system to navigate, extract, create and modify ZIP archives"
+HOMEPAGE="http://code.google.com/p/fuse-zip/"
+SRC_URI="http://fuse-zip.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libzip-0.11.2:=
+ >=sys-fs/fuse-2.7:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ # Fix strip than installing fuse-zip
+ sed -i -e 's/install -m 755 -s/install -m 755/' Makefile || die "sed failed"
+ #enable parallel build
+ sed -i -e "s:make :\$\(MAKE\) :" Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ emake INSTALLPREFIX="${D}"/usr install
+}