summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-12-13 09:14:36 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-12-13 09:14:36 +0000
commit5c0c3f228e8212e4d8d65da77324a5162be94cf7 (patch)
treee7d0ff7a9266eb934a35af02aba325f72a9a760d /sys-fs
parentUnmask sys-cluster/ploop and sys-cluster/vzctl (diff)
downloadgentoo-2-5c0c3f228e8212e4d8d65da77324a5162be94cf7.tar.gz
gentoo-2-5c0c3f228e8212e4d8d65da77324a5162be94cf7.tar.bz2
gentoo-2-5c0c3f228e8212e4d8d65da77324a5162be94cf7.zip
Version bump wrt bug #437690
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/vzquota/ChangeLog9
-rw-r--r--sys-fs/vzquota/vzquota-3.1.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/sys-fs/vzquota/ChangeLog b/sys-fs/vzquota/ChangeLog
index 26256b66795e..c4b0be9d23de 100644
--- a/sys-fs/vzquota/ChangeLog
+++ b/sys-fs/vzquota/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/vzquota
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/vzquota/ChangeLog,v 1.28 2009/07/07 12:34:13 pva Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vzquota/ChangeLog,v 1.29 2012/12/13 09:14:35 pinkbyte Exp $
+
+*vzquota-3.1 (13 Dec 2012)
+
+ 13 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> +vzquota-3.1.ebuild:
+ Version bump wrt bug #437690
07 Jul 2009; Peter Volkov <pva@gentoo.org> vzquota-3.0.12.ebuild:
x86/amd64 stable, bug #199738. Remove old.
diff --git a/sys-fs/vzquota/vzquota-3.1.ebuild b/sys-fs/vzquota/vzquota-3.1.ebuild
new file mode 100644
index 000000000000..2753eea6d222
--- /dev/null
+++ b/sys-fs/vzquota/vzquota-3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vzquota/vzquota-3.1.ebuild,v 1.1 2012/12/13 09:14:36 pinkbyte Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="OpenVZ VPS disk quota utility"
+HOMEPAGE="http://openvz.org/download/utils/vzquota/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -e 's,$(INSTALL) -s -m,$(INSTALL) -m,' \
+ -e 's:$(CC) $(CFLAGS) -o:$(CC) $(CFLAGS) $(LDFLAGS) -o:' \
+ -e 's:-Werror ::' \
+ -i "${S}/src/Makefile" || die 'sed on src/Makefile failed'
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${ED}" INSTALL="${EPREFIX}/usr/bin/install" install
+ keepdir /var/vzquota
+ # remove accidentally created man8 dir
+ rm -r "${ED}/man8" || die 'remove man8 directory failed'
+}